summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin A. Shelton2016-08-11 01:00:48 -0600
committerBenjamin A. Shelton2016-08-11 01:00:48 -0600
commitb5a570337b9d34dcb19dcc2ae926e8d484eed579 (patch)
tree1837edfe9fb695f5f34e4065773f2c3e59291036
parentd57d64c30ef950a04ba184b6b63ee6eafcd8765a (diff)
downloadaur-b5a570337b9d34dcb19dcc2ae926e8d484eed579.tar.gz
Bumped version and made minor clarifications to sentry.install.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--sentry.install14
3 files changed, 18 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 068de2a07046..a39db42ea637 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Jul 26 01:16:13 UTC 2016
+# Thu Aug 11 07:00:40 UTC 2016
pkgbase = sentry
pkgdesc = Python-based realtime logging and aggregation server.
- pkgver = 8.6.0
- pkgrel = 3
+ pkgver = 8.7.0
+ pkgrel = 1
url = http://pypi.python.org/pypi/sentry
arch = any
license = BSD
@@ -22,7 +22,7 @@ pkgbase = sentry
source = sentry.service
source = sentry-web.service
source = sentry.target
- sha256sums = 46f4b2425652aec10dc596bdae8439efd177f2a153a416daa1c23a9438ab02bb
+ sha256sums = 64b046edb8c6ddb9098c2a444d65f66b49a3bfeb6058e09186ad183dcc91bb0c
sha256sums = d60b097721ec4acbc5b1232a0f29ef9d21d60228d17db655848a8e2a5c9a5281
sha256sums = d22b9bde7c39d9d0f031ba1b01c955c9dbe4ffe3f3f083875fe557f75f0050f7
sha256sums = 3c471417a279ac6605d3bb82b7377eaab0e24efe9cf582a11eef0d9e4c89428e
diff --git a/PKGBUILD b/PKGBUILD
index 038ce1ff20e6..9798cb8bc83d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
pkgbase=sentry
pkgname=('sentry' 'sentry-dsym')
-pkgver=8.6.0
-pkgrel=3
+pkgver=8.7.0
+pkgrel=1
pkgdesc="Python-based realtime logging and aggregation server."
arch=(any)
url="http://pypi.python.org/pypi/sentry"
@@ -29,7 +29,7 @@ source=(
"sentry.target"
)
sha256sums=(
- 46f4b2425652aec10dc596bdae8439efd177f2a153a416daa1c23a9438ab02bb # sentry.install
+ 64b046edb8c6ddb9098c2a444d65f66b49a3bfeb6058e09186ad183dcc91bb0c # sentry.install
d60b097721ec4acbc5b1232a0f29ef9d21d60228d17db655848a8e2a5c9a5281 # sentry-celery.service
d22b9bde7c39d9d0f031ba1b01c955c9dbe4ffe3f3f083875fe557f75f0050f7 # sentry-cron.service
3c471417a279ac6605d3bb82b7377eaab0e24efe9cf582a11eef0d9e4c89428e # sentry.service
diff --git a/sentry.install b/sentry.install
index 0b55e1035a68..44a0b8e000f3 100644
--- a/sentry.install
+++ b/sentry.install
@@ -87,10 +87,12 @@ and increasingly more options are being moved to Sentry's YAML-based configs:
sudo -u sentry mkdir /etc/sentry/temp
sudo -u sentry /opt/sentry/bin/sentry init /etc/sentry/temp
- # Optionally edit the old configuration:
+ # Optionally edit the old configurations:
sudo vimdiff /etc/sentry/sentry.conf.py /etc/sentry/temp/sentry.conf.py
+ sudo vimdiff /etc/sentry/config.yml /etc/sentry/temp/config.yml
- # Move Sentry's YAML configuration to the config root:
+ # ...or move Sentry's YAML configuration to the config root:
+ sudo -u sentry mv /etc/sentry/temp/sentry.conf.py /etc/sentry/
sudo -u sentry mv /etc/sentry/temp/config.yml /etc/sentry/
# Delete the temporary config directory:
@@ -107,12 +109,18 @@ and increasingly more options are being moved to Sentry's YAML-based configs:
4) Start Sentry:
- sudo systemctl start sentry sentry-celery
+ sudo systemctl start sentry
If you wish to run Sentry manually, e.g. to test your configuration:
sudo -u sentry /opt/sentry/bin/sentry --config=/etc/sentry run web
+You may need to run the following services if Sentry's web service fails
+during manual testing:
+
+ sudo -u sentry /opt/sentry/bin/sentry --config=/etc/sentry run worker
+ sudo -u sentry /opt/sentry/bin/sentry --config=/etc/sentry run cron
+
EXTRAS
To install additional plugins, you'll need to use Sentry's local copy of pip: