summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin A. Shelton2016-10-05 21:33:10 -0600
committerBenjamin A. Shelton2016-10-05 21:33:10 -0600
commitcffee9dfe7d8c3853bd2a81b81ec41689a116515 (patch)
tree3a53f916b693e6277d03b9e5a04c695e3820ce4d
parenta831c95ca6bdec4222013c1f9c0b219d3d08633d (diff)
downloadaur-cffee9dfe7d8c3853bd2a81b81ec41689a116515.tar.gz
Bump version, deprecate sentry-dsym package.
-rw-r--r--PKGBUILD52
-rw-r--r--sentry.install66
2 files changed, 33 insertions, 85 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dafcee07f48b..fa3b8080dffe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Source: https://github.com/zancarius/archlinux-pkgbuilds
pkgbase=sentry
-pkgname=('sentry' 'sentry-dsym')
-pkgver=8.8.0
+pkgname=('sentry')
+pkgver=8.9.0
pkgrel=1
pkgdesc="Python-based realtime logging and aggregation server."
arch=(any)
@@ -11,13 +11,21 @@ url="http://pypi.python.org/pypi/sentry"
license=(BSD)
makedepends=(
'clang'
+ 'python2-pip'
+ 'python2-setuptools'
+ 'python2-virtualenv'
+)
+install='sentry.install'
+depends=(
+ 'jansson'
'libjpeg-turbo'
'libxml2'
'libxslt'
+ 'llvm'
+ 'ncurses5-compat-libs'
'python2'
- 'python2-pip'
- 'python2-setuptools'
- 'python2-virtualenv'
+ 'postgresql'
+ 'redis'
)
options=(!strip)
source=(
@@ -29,7 +37,7 @@ source=(
"sentry.target"
)
sha256sums=(
- 64b046edb8c6ddb9098c2a444d65f66b49a3bfeb6058e09186ad183dcc91bb0c # sentry.install
+ 496d5b1a26a259070f2714446f903b2eee00affcfb4ba94ca67ca54b9aae29d5 # sentry.install
d60b097721ec4acbc5b1232a0f29ef9d21d60228d17db655848a8e2a5c9a5281 # sentry-celery.service
d22b9bde7c39d9d0f031ba1b01c955c9dbe4ffe3f3f083875fe557f75f0050f7 # sentry-cron.service
3c471417a279ac6605d3bb82b7377eaab0e24efe9cf582a11eef0d9e4c89428e # sentry.service
@@ -37,17 +45,7 @@ sha256sums=(
94121159756f7ac863e2b1149b530ea633efa2f3eeef57cc332e1f4cba724e2d # sentry.target
)
-package_sentry () {
- install="sentry.install"
- depends=(
- 'jansson'
- 'libjpeg-turbo'
- 'libxml2'
- 'libxslt'
- 'python2'
- 'postgresql'
- 'redis'
- )
+package() {
mkdir -p "${pkgdir}/opt/sentry"
virtualenv2 --python=python2.7 "${pkgdir}/opt/sentry"
@@ -82,23 +80,3 @@ package_sentry () {
install -Dm0644 "${srcdir}/sentry.target" "${pkgdir}/usr/lib/systemd/system/sentry.target"
}
-
-package_sentry-dsym() {
- depends=(
- 'llvm'
- 'sentry'
- )
-
- mkdir -p "${pkgdir}/opt/sentry"
- virtualenv2 --python=python2.7 "${srcdir}/dsym-env"
- source "${srcdir}/dsym-env/bin/activate"
-
- "${srcdir}/dsym-env/bin/pip" install "symsynd>=0.6.1,<1.0.0"
-
- mkdir -p "${pkgdir}/opt/sentry/lib/python2.7/site-packages"
- cp -a "${srcdir}/dsym-env/lib/python2.7/site-packages/altgraph"* "${pkgdir}/opt/sentry/lib/python2.7/site-packages/"
- cp -a "${srcdir}/dsym-env/lib/python2.7/site-packages/macholib"* "${pkgdir}/opt/sentry/lib/python2.7/site-packages/"
- cp -a "${srcdir}/dsym-env/lib/python2.7/site-packages/symsynd"* "${pkgdir}/opt/sentry/lib/python2.7/site-packages/"
- cp -a "${srcdir}/dsym-env/lib/python2.7/site-packages/_symsynd_demangler.so" "${pkgdir}/opt/sentry/lib/python2.7/site-packages/"
-
-}
diff --git a/sentry.install b/sentry.install
index 44a0b8e000f3..1c766c4d1e5a 100644
--- a/sentry.install
+++ b/sentry.install
@@ -127,11 +127,6 @@ To install additional plugins, you'll need to use Sentry's local copy of pip:
sudo -u sentry /opt/sentry/bin/pip install <package>
-REMOVAL
-
-As of Sentry 7.1.4, this package will no longer remove the Sentry user by
-default. You must perform this step manually.
-
IMPORTANT 8.0 UPGRADE NOTICE
If you're upgrading from an earlier version of Sentry, the Sentry team has
@@ -140,25 +135,6 @@ options: 1) Manage schema migration manually, 2) consider migrating your data
away from MySQL (there may be some tools to assist, linked below), or 3)
reinstall from scratch with PostgreSQL.
-8.0 Notice:
-
-http://blog.getsentry.com/2016/01/08/sentry-8-on-premise.htmlA
-
-Django migration tools from MySQL-to-PostgreSQL:
-
-https://www.calazan.com/migrating-django-app-from-mysql-to-postgresql/
-http://www.ofbrooklyn.com/2010/07/18/migrating-django-mysql-postgresql-easy-way/
- (2010!)
-
-And lastly, the PostgreSQL guide on moving your data (read carefully):
-
-https://wiki.postgresql.org/wiki/How_to_make_a_proper_migration_from_MySQL_to_PostgreSQL
-
-(Note: I'm not a Django developer although I have some experience with South
-prior to its deprecation; my experience is predominantly limited to
-SQLAlchemy, so I cannot vouch for the veracity of these tools and they are
-provided on an informational basis only.)
-
SENTRY WON'T START?
Recent versions of Sentry included a configuration for specifying large integers
@@ -178,30 +154,24 @@ project page:
https://aur.archlinux.org/packages/sentry/
https://github.com/zancarius/archlinux-pkgbuilds
-SENTRY 8.5.0 UPGRADE
-
-Sentry's run command has introduced new controls and finished the deprecation of
-the old celery worker, replacing it with "sentry run worker" and
-"sentry run cron". Although this has lead to the further proliferation of
-systemd units, control has been coalesced into a single unit file. As of this
-upgrade, you should simply need to run:
-
- sudo systemctl daemon-reload
- sudo systemctl start sentry
-
-or to start Sentry at boot:
-
- sudo systemctl enable sentry
-
-If you're upgrading from Sentry versions earlier than 8.5.0, you'll need to
-run:
-
- sudo systemctl stop sentry sentry-celery
-
-first and continue with the upgrade process as instructed (starting with step
-#2). Do not issue "systemctl daemon-reload" until after Sentry's services have
-stopped. If you have a habit of stopping Sentry before upgrading, there is
-nothing more you need to do.
+SENTRY 8.9.0 UPGRADE NOTICE
+
+dsym support has been integrated into Sentry directly and is no longer a
+plugin. If you've been relying on the sentry-dsym package, you may notice that
+this package is no longer built. Instead, symsynd is installed automatically
+as part of Sentry's "install_requires" dependencies. You will encounter an
+error during Sentry's install as a consequence of this; that's normal. Remove
+your sentry-dsym package first.
+
+If you haven't previously required dsym support, this means that Sentry now
+requires that you also install LLVM for symsynd. It may be possible to remove
+LLVM from the package dependencies, but the build may fail if it's not
+installed. As a workaround if you cannot have LLVM installed for whatever
+reason, try removing "llvm" from the "depends" array, build Sentry on a machine
+that has LLVM installed, and then copy the package to your target server. This
+will cause problems if you use something that requires dsym support, but it's
+presently the easiest way to install Sentry on a target host without LLVM
+installed.
EOF