summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin A. Shelton2016-05-07 23:10:58 -0600
committerBenjamin A. Shelton2016-05-07 23:10:58 -0600
commitee25703577edd89efb4c97fd831c5938769b7111 (patch)
tree903162e9523bdead2e31954162ceb50d5ee35b20
parent835ba83f988ad775a352ec161477bddd2829c741 (diff)
downloadaur-ee25703577edd89efb4c97fd831c5938769b7111.tar.gz
Added dependencies and possible workaround for GCC 6.1.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 12 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 83005ac0ff3f..593b722d96af 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat May 7 17:19:07 UTC 2016
+# Sun May 8 05:10:49 UTC 2016
pkgbase = sentry
pkgdesc = Python-based realtime logging and aggregation server.
pkgver = 8.4.0
- pkgrel = 1
+ pkgrel = 2
url = http://pypi.python.org/pypi/sentry
install = sentry.install
arch = any
@@ -12,6 +12,8 @@ pkgbase = sentry
makedepends = python2-setuptools
makedepends = python2-virtualenv
depends = jansson
+ depends = libxml2
+ depends = libxslt
depends = python2
depends = postgresql
depends = redis
diff --git a/PKGBUILD b/PKGBUILD
index fd684ab23004..ef40bbe9aca4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,15 @@
pkgname=sentry
pkgver=8.4.0
-pkgrel=1
+pkgrel=2
pkgdesc="Python-based realtime logging and aggregation server."
arch=(any)
url="http://pypi.python.org/pypi/sentry"
license=(BSD)
depends=(
jansson
+ libxml2
+ libxslt
python2
postgresql
redis
@@ -38,6 +40,11 @@ package () {
# Begin Sentry installation for our specific version via PyPI. This
# guarantees we'll grab all of the appropriate dependencies and
# automates the process.
+ #
+ # If you're running GCC 6.1 and Sentry won't build, uncomment the following
+ # line and comment-out or remove the one immediately after it. If you wish
+ # to be more specific, replace -Wno-error with -Wno-misleading-indentation.
+ #CFLAGS="-Wno-error" "${pkgdir}/opt/sentry/bin/pip" install "sentry==${pkgver}"
"${pkgdir}/opt/sentry/bin/pip" install "sentry==${pkgver}"
# Make certain the virtualenv is relocatable.