summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarl Smedstad2024-01-10 16:05:50 +0100
committerCarl Smedstad2024-01-10 16:05:50 +0100
commitd7d023df4bc0fe5594a8e8e1636c16e7715fee11 (patch)
tree78d412391ae184a71d64a26d2721280c00ffbe2c
parente3c22573a25536565f75fafa3a856665d805a27f (diff)
downloadaur-d7d023df4bc0fe5594a8e8e1636c16e7715fee11.tar.gz
Publish version 0.7.0-1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD37
2 files changed, 30 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b30a40da33f2..4f5272b1009e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,28 @@
pkgbase = sentry-native
pkgdesc = Sentry SDK for C, C++ and native applications
- pkgver = 0.6.7
- pkgrel = 3
+ pkgver = 0.7.0
+ pkgrel = 1
url = https://github.com/getsentry/sentry-native
arch = x86_64
license = MIT
- checkdepends = python-pytest
checkdepends = python-msgpack
+ checkdepends = python-pytest
+ checkdepends = python-pytest-httpserver
makedepends = cmake
makedepends = git
depends = curl
depends = gcc-libs
depends = glibc
- source = git+https://github.com/getsentry/sentry-native.git#commit=a3d58622a807b9dda174cb9fc18fa0f98c89d043
+ depends = zlib
+ source = git+https://github.com/getsentry/sentry-native.git#commit=4ec95c0725df5f34440db8fa8d37b4c519fce74e
source = git+https://github.com/getsentry/libunwindstack-ndk.git
source = git+https://github.com/getsentry/breakpad.git
source = git+https://chromium.googlesource.com/linux-syscall-support.git
source = git+https://github.com/getsentry/crashpad.git
+ source = git+https://chromium.googlesource.com/chromium/mini_chromium.git
+ source = git+https://chromium.googlesource.com/chromium/src/third_party/zlib.git
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 5667bf548e62..5a93aa987e83 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Carl Smedstad <carl.smedstad at protonmail dot com>
pkgname=sentry-native
-pkgver=0.6.7
-pkgrel=3
+pkgver=0.7.0
+pkgrel=1
pkgdesc="Sentry SDK for C, C++ and native applications"
arch=(x86_64)
url="https://github.com/getsentry/sentry-native"
@@ -11,23 +11,27 @@ depends=(
curl
gcc-libs
glibc
+ zlib
)
makedepends=(
cmake
git
)
checkdepends=(
- python-pytest
python-msgpack
+ python-pytest
+ python-pytest-httpserver
)
-_commit=a3d58622a807b9dda174cb9fc18fa0f98c89d043 # git rev-parse "$pkgver"
+_commit=4ec95c0725df5f34440db8fa8d37b4c519fce74e # git rev-parse "$pkgver"
source=(
"git+$url.git#commit=$_commit"
"git+https://github.com/getsentry/libunwindstack-ndk.git"
"git+https://github.com/getsentry/breakpad.git"
"git+https://chromium.googlesource.com/linux-syscall-support.git"
"git+https://github.com/getsentry/crashpad.git"
+ "git+https://chromium.googlesource.com/chromium/mini_chromium.git"
+ "git+https://chromium.googlesource.com/chromium/src/third_party/zlib.git"
)
sha256sums=(
'SKIP'
@@ -35,6 +39,8 @@ sha256sums=(
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
)
_archive="$pkgname"
@@ -54,6 +60,13 @@ prepare() {
git config submodule.external/third_party/lss.url "$srcdir/linux-syscall-support"
git config submodule.external/crashpad.url "$srcdir/crashpad"
git -c protocol.file.allow=always submodule update
+
+ cd external/crashpad
+ git submodule init
+ git config submodule.third_party/mini_chromium/mini_chromium.url "$srcdir/mini_chromium"
+ git config submodule.third_party/zlib/zlib.url "$srcdir/zlib"
+ git config submoduel.third_party/lss/lss.url "$srcdir/linux-syscall-support"
+ git -c protocol.file.allow=always submodule update
}
build() {
@@ -62,26 +75,16 @@ build() {
cmake -S . -B build \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
- -Wno-dev \
- -DSENTRY_BUILD_TESTS=ON
+ -Wno-dev
cmake --build build
}
check() {
cd "$_archive"
- # Skip tests failing in a chroot - not sure why
- ./build/tests/unit/sentry_test_unit --skip \
- build_id_parser \
- fuzz_json
-
- python -m pytest \
+ pytest \
--ignore="external/crashpad/test/win" \
- --ignore="external/crashpad/snapshot/win/" \
- --ignore="tests/test_build_static.py" \
- --ignore="tests/test_integration_crashpad.py" \
- --ignore="tests/test_integration_http.py" \
- --ignore="tests/test_integration_ratelimits.py"
+ --ignore="external/crashpad/snapshot/win/"
}
package() {