summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2015-02-05 16:02:35 +0800
committerNicolas Iooss2015-06-27 11:45:00 +0800
commit2cca1bbc81aa3b1c770cd947e899eff1582eb6da (patch)
treebec1f16ff40a07e738caf5885251ee1adfb33d60
parent5e360f939bf0b408c65eb89d6d3dbf81338c0cf9 (diff)
downloadaur-2cca1bbc81aa3b1c770cd947e899eff1582eb6da.tar.gz
sepolgen 1.2.2-1 update
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD21
2 files changed, 13 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 15a285d40d0c..c779484da69a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = sepolgen
pkgdesc = SELinux policy generator
- pkgver = 1.2.1
- pkgrel = 2
+ pkgver = 1.2.2
+ pkgrel = 1
url = http://userspace.selinuxproject.org
arch = any
groups = selinux
license = GPL
depends = python2
- provides = selinux-usr-sepolgen=1.2.1-2
+ provides = selinux-usr-sepolgen=1.2.2-1
conflicts = selinux-usr-sepolgen
- source = https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20140506/sepolgen-1.2.1.tar.gz
- sha256sums = 438c246bdc6b3cf1b12116831f4c601aaae6e93decb007dddab212a3c88781b0
+ source = https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20150202/sepolgen-1.2.2.tar.gz
+ sha256sums = bebda8eeb2d386d26823d724ea320508a02b50828d44aff47c3f907cf54c2324
pkgname = sepolgen
diff --git a/PKGBUILD b/PKGBUILD
index 997afe004e2a..9b82cefc627e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# Contributor: Sergej Pupykin (pupykin <dot> s+arch <at> gmail <dot> com)
pkgname=sepolgen
-pkgver=1.2.1
-pkgrel=2
+pkgver=1.2.2
+pkgrel=1
pkgdesc="SELinux policy generator"
groups=('selinux')
arch=('any')
@@ -14,20 +14,15 @@ license=('GPL')
depends=('python2')
conflicts=("selinux-usr-${pkgname}")
provides=("selinux-usr-${pkgname}=${pkgver}-${pkgrel}")
-source=("https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20140506/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('438c246bdc6b3cf1b12116831f4c601aaae6e93decb007dddab212a3c88781b0')
-
-prepare() {
- cd ${pkgname}-${pkgver}
- sed -i -e "s/ python/ python2/" src/sepolgen/Makefile
-}
+source=("https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20150202/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('bebda8eeb2d386d26823d724ea320508a02b50828d44aff47c3f907cf54c2324')
build() {
- cd ${pkgname}-${pkgver}
- make
+ cd "${pkgname}-${pkgver}"
+ make PYTHON=python2
}
package(){
- cd ${pkgname}-${pkgver}
- make DESTDIR="${pkgdir}" install
+ cd "${pkgname}-${pkgver}"
+ make PYTHON=python2 DESTDIR="${pkgdir}" install
}