summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordiggit2019-03-20 22:44:01 +0100
committerdiggit2019-03-20 22:44:01 +0100
commit428e3ee88908b03b30694b5d73544bb14299b070 (patch)
tree682064410c0526316e7f11e77901c3a0cfad8154
parent97ed99c7ad4acb062dc5540b9d89c313b6820079 (diff)
downloadaur-428e3ee88908b03b30694b5d73544bb14299b070.tar.gz
force branch selection to "default"
which is default, but makepkg somehow selects most recently updated one https://bugs.archlinux.org/task/62092
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
-rw-r--r--cmake_qwt.patch21
3 files changed, 4 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac69f250bab7..923cc2bd2cab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,11 +14,9 @@ pkgbase = serialplot-hg
depends = hicolor-icon-theme
provides = serialplot
conflicts = serialplot
- source = hg+https://bitbucket.org/hyOzd/serialplot
- source = cmake_qwt.patch
+ source = hg+https://bitbucket.org/hyOzd/serialplot#branch=default
source = update_check_disable.patch
sha256sums = SKIP
- sha256sums = b1508ee32f79c82ad6e1749ddc79c33e4af3e3178c0e8e67c9011eda040c8652
sha256sums = 116736d9471b5e0d283c264c1df8db5e4eb5e927839db7eee0022ab7b9177961
pkgname = serialplot-hg
diff --git a/PKGBUILD b/PKGBUILD
index 583d6d28b8c5..47d1cc2e7d7b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Patrik Bachan <patrikbachan at gmail dot com>
pkgname=serialplot-hg
_pkgname=serialplot
-pkgver=796+.f5f0a29e6433+
+pkgver=794+.9d8cc029351b+
pkgrel=1
pkgdesc="Small and simple software for plotting data from serial port in realtime"
arch=('i686' 'x86_64')
@@ -11,11 +11,9 @@ depends=('qwt' 'qt5-base' 'qt5-serialport' 'hicolor-icon-theme')
makedepends=('mercurial' 'cmake')
provides=('serialplot')
conflicts=('serialplot')
-source=('hg+https://bitbucket.org/hyOzd/serialplot'
- 'cmake_qwt.patch'
+source=('hg+https://bitbucket.org/hyOzd/serialplot#branch=default'
'update_check_disable.patch')
sha256sums=('SKIP'
- 'b1508ee32f79c82ad6e1749ddc79c33e4af3e3178c0e8e67c9011eda040c8652'
'116736d9471b5e0d283c264c1df8db5e4eb5e927839db7eee0022ab7b9177961')
pkgver() {
@@ -26,12 +24,8 @@ pkgver() {
prepare() {
cd "$srcdir"
#disable update checking, otherwise app crashes
- #this is dirty fix
+ #this is dirty fix, just immediately returning from update function
patch --forward --strip=1 --input="${srcdir}/update_check_disable.patch"
- #patch qwt search script
- #https://bitbucket.org/hyOzd/serialplot/issues/15
- cd "$srcdir"
- patch --forward --strip=1 --input="${srcdir}/cmake_qwt.patch"
}
build() {
diff --git a/cmake_qwt.patch b/cmake_qwt.patch
deleted file mode 100644
index c2a48ff25319..000000000000
--- a/cmake_qwt.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff --unified --recursive --text orig/serialplot/cmake/modules/FindQwt.cmake new/serialplot/cmake/modules/FindQwt.cmake
---- orig/serialplot/cmake/modules/FindQwt.cmake 2019-03-19 10:27:30.757849192 +0100
-+++ new/serialplot/cmake/modules/FindQwt.cmake 2019-03-19 10:28:59.446743650 +0100
-@@ -66,7 +66,7 @@
-
- if(QWT_ROOT)
- set(QWT_INCLUDE_DIR "${QWT_ROOT}/include")
-- find_library(QWT_LIBRARY "qwt-qt5"
-+ find_library(QWT_LIBRARY "qwt-qt5" "qwt"
- PATHS "${QWT_ROOT}/lib")
- else (QWT_ROOT)
- ## Look into system locations
-@@ -90,7 +90,7 @@
- endif(qwt_version_string)
- endif (QWT_INCLUDE_DIR)
- # look into system locations for lib file
-- find_library(QWT_LIBRARY "qwt-qt5" PATHS /usr/lib)
-+ find_library(QWT_LIBRARY "qwt-qt5" "qwt" PATHS /usr/lib)
- endif(QWT_ROOT)
-
- # set version variables