summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordiggit2019-05-06 18:22:50 +0200
committerdiggit2019-05-06 18:22:50 +0200
commit8c359a63e02e898202cd4730bbebd126f8eb406c (patch)
tree144bfd47ab752c2d5a69db3039682292603dcf60
parent428e3ee88908b03b30694b5d73544bb14299b070 (diff)
downloadaur-8c359a63e02e898202cd4730bbebd126f8eb406c.tar.gz
remove patch disabling update checking
- bug fixed in upstream - version update
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
-rw-r--r--update_check_disable.patch12
3 files changed, 5 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 923cc2bd2cab..4d0b66c96d56 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = serialplot-hg
pkgdesc = Small and simple software for plotting data from serial port in realtime
- pkgver = 796+.f5f0a29e6433+
+ pkgver = 811.5c9db4e54bbd
pkgrel = 1
url = https://bitbucket.org/hyOzd/serialplot
arch = i686
@@ -14,10 +14,8 @@ pkgbase = serialplot-hg
depends = hicolor-icon-theme
provides = serialplot
conflicts = serialplot
- source = hg+https://bitbucket.org/hyOzd/serialplot#branch=default
- source = update_check_disable.patch
+ source = hg+https://bitbucket.org/hyOzd/serialplot
sha256sums = SKIP
- sha256sums = 116736d9471b5e0d283c264c1df8db5e4eb5e927839db7eee0022ab7b9177961
pkgname = serialplot-hg
diff --git a/PKGBUILD b/PKGBUILD
index 47d1cc2e7d7b..39b4b4b36715 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Patrik Bachan <patrikbachan at gmail dot com>
pkgname=serialplot-hg
_pkgname=serialplot
-pkgver=794+.9d8cc029351b+
+pkgver=811.5c9db4e54bbd
pkgrel=1
pkgdesc="Small and simple software for plotting data from serial port in realtime"
arch=('i686' 'x86_64')
@@ -11,23 +11,14 @@ depends=('qwt' 'qt5-base' 'qt5-serialport' 'hicolor-icon-theme')
makedepends=('mercurial' 'cmake')
provides=('serialplot')
conflicts=('serialplot')
-source=('hg+https://bitbucket.org/hyOzd/serialplot#branch=default'
- 'update_check_disable.patch')
-sha256sums=('SKIP'
- '116736d9471b5e0d283c264c1df8db5e4eb5e927839db7eee0022ab7b9177961')
+source=('hg+https://bitbucket.org/hyOzd/serialplot')
+sha256sums=('SKIP')
pkgver() {
cd "$srcdir/$_pkgname"
echo $(hg identify -n).$(hg identify -i)
}
-prepare() {
- cd "$srcdir"
- #disable update checking, otherwise app crashes
- #this is dirty fix, just immediately returning from update function
- patch --forward --strip=1 --input="${srcdir}/update_check_disable.patch"
-}
-
build() {
cd "$srcdir/$_pkgname"
mkdir build
diff --git a/update_check_disable.patch b/update_check_disable.patch
deleted file mode 100644
index 8e4afda18efa..000000000000
--- a/update_check_disable.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --unified --recursive --text orig/serialplot/src/updatechecker.cpp new/serialplot/src/updatechecker.cpp
---- orig/serialplot/src/updatechecker.cpp 2019-03-19 10:39:03.674912791 +0100
-+++ new/serialplot/src/updatechecker.cpp 2019-03-19 10:39:22.542052005 +0100
-@@ -47,7 +47,7 @@
-
- void UpdateChecker::checkUpdate()
- {
-- if (isChecking()) return;
-+ return;
-
- auto req = QNetworkRequest(QUrl(BB_DOWNLOADS_URL));
- activeReply = nam.get(req);