summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordiggit2019-03-19 10:49:11 +0100
committerdiggit2019-03-19 10:49:11 +0100
commit97ed99c7ad4acb062dc5540b9d89c313b6820079 (patch)
tree8362f6fa15acbfa0636e6b8ea79c1db3b22cbaac
parent484fee8795d4fc465cb4ef790adc53b760f478a9 (diff)
downloadaur-97ed99c7ad4acb062dc5540b9d89c313b6820079.tar.gz
add temporary fix for FindQwt cmake script
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD19
-rw-r--r--cmake_qwt.patch21
-rw-r--r--update_check_disable.patch12
4 files changed, 53 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b34fc6c8a1f..ac69f250bab7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = serialplot-hg
pkgdesc = Small and simple software for plotting data from serial port in realtime
- pkgver = 794+.9d8cc029351b+
+ pkgver = 796+.f5f0a29e6433+
pkgrel = 1
url = https://bitbucket.org/hyOzd/serialplot
arch = i686
@@ -15,7 +15,11 @@ pkgbase = serialplot-hg
provides = serialplot
conflicts = serialplot
source = hg+https://bitbucket.org/hyOzd/serialplot
- md5sums = SKIP
+ source = cmake_qwt.patch
+ source = update_check_disable.patch
+ sha256sums = SKIP
+ sha256sums = b1508ee32f79c82ad6e1749ddc79c33e4af3e3178c0e8e67c9011eda040c8652
+ sha256sums = 116736d9471b5e0d283c264c1df8db5e4eb5e927839db7eee0022ab7b9177961
pkgname = serialplot-hg
diff --git a/PKGBUILD b/PKGBUILD
index 3f4014cb710d..583d6d28b8c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Patrik Bachan <patrikbachan at gmail dot com>
pkgname=serialplot-hg
_pkgname=serialplot
-pkgver=794+.9d8cc029351b+
+pkgver=796+.f5f0a29e6433+
pkgrel=1
pkgdesc="Small and simple software for plotting data from serial port in realtime"
arch=('i686' 'x86_64')
@@ -11,8 +11,12 @@ depends=('qwt' 'qt5-base' 'qt5-serialport' 'hicolor-icon-theme')
makedepends=('mercurial' 'cmake')
provides=('serialplot')
conflicts=('serialplot')
-source=('hg+https://bitbucket.org/hyOzd/serialplot')
-md5sums=('SKIP')
+source=('hg+https://bitbucket.org/hyOzd/serialplot'
+ 'cmake_qwt.patch'
+ 'update_check_disable.patch')
+sha256sums=('SKIP'
+ 'b1508ee32f79c82ad6e1749ddc79c33e4af3e3178c0e8e67c9011eda040c8652'
+ '116736d9471b5e0d283c264c1df8db5e4eb5e927839db7eee0022ab7b9177961')
pkgver() {
cd "$srcdir/$_pkgname"
@@ -20,9 +24,14 @@ pkgver() {
}
prepare() {
- cd "$srcdir/$_pkgname"
+ cd "$srcdir"
#disable update checking, otherwise app crashes
- sed -i -e 's/if (isChecking()) return/return/g' src/updatechecker.cpp
+ #this is dirty fix
+ patch --forward --strip=1 --input="${srcdir}/update_check_disable.patch"
+ #patch qwt search script
+ #https://bitbucket.org/hyOzd/serialplot/issues/15
+ cd "$srcdir"
+ patch --forward --strip=1 --input="${srcdir}/cmake_qwt.patch"
}
build() {
diff --git a/cmake_qwt.patch b/cmake_qwt.patch
new file mode 100644
index 000000000000..c2a48ff25319
--- /dev/null
+++ b/cmake_qwt.patch
@@ -0,0 +1,21 @@
+diff --unified --recursive --text orig/serialplot/cmake/modules/FindQwt.cmake new/serialplot/cmake/modules/FindQwt.cmake
+--- orig/serialplot/cmake/modules/FindQwt.cmake 2019-03-19 10:27:30.757849192 +0100
++++ new/serialplot/cmake/modules/FindQwt.cmake 2019-03-19 10:28:59.446743650 +0100
+@@ -66,7 +66,7 @@
+
+ if(QWT_ROOT)
+ set(QWT_INCLUDE_DIR "${QWT_ROOT}/include")
+- find_library(QWT_LIBRARY "qwt-qt5"
++ find_library(QWT_LIBRARY "qwt-qt5" "qwt"
+ PATHS "${QWT_ROOT}/lib")
+ else (QWT_ROOT)
+ ## Look into system locations
+@@ -90,7 +90,7 @@
+ endif(qwt_version_string)
+ endif (QWT_INCLUDE_DIR)
+ # look into system locations for lib file
+- find_library(QWT_LIBRARY "qwt-qt5" PATHS /usr/lib)
++ find_library(QWT_LIBRARY "qwt-qt5" "qwt" PATHS /usr/lib)
+ endif(QWT_ROOT)
+
+ # set version variables
diff --git a/update_check_disable.patch b/update_check_disable.patch
new file mode 100644
index 000000000000..8e4afda18efa
--- /dev/null
+++ b/update_check_disable.patch
@@ -0,0 +1,12 @@
+diff --unified --recursive --text orig/serialplot/src/updatechecker.cpp new/serialplot/src/updatechecker.cpp
+--- orig/serialplot/src/updatechecker.cpp 2019-03-19 10:39:03.674912791 +0100
++++ new/serialplot/src/updatechecker.cpp 2019-03-19 10:39:22.542052005 +0100
+@@ -47,7 +47,7 @@
+
+ void UpdateChecker::checkUpdate()
+ {
+- if (isChecking()) return;
++ return;
+
+ auto req = QNetworkRequest(QUrl(BB_DOWNLOADS_URL));
+ activeReply = nam.get(req);