summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortx00100xt2022-07-05 12:09:55 +0300
committertx00100xt2022-07-05 12:09:55 +0300
commit1a5ecb6dec77d165eb57f15d33205339ad9b70a9 (patch)
tree243e441d03b3430d1dcfa4feddf2aba2b853584d
parent55cc72edbbd1344a470d882f0fca1d434219578c (diff)
downloadaur-1a5ecb6dec77d165eb57f15d33205339ad9b70a9.tar.gz
Update amd change revision.
-rwxr-xr-x.SRCINFO2
-rwxr-xr-x.gitignore1
-rwxr-xr-xPKGBUILD6
-rw-r--r--hud_isore.patch264
4 files changed, 270 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ae045e6f6d80..46ca83e382ce 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = serioussam
pkgdesc = Serious Sam Classic native Linux version with XPLUS Modification.
pkgver = 1.10.2
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/tx00100xt/SeriousSamClassic
arch = i686
arch = x86_64
diff --git a/.gitignore b/.gitignore
index 47b1c504a952..ed7aa52188ab 100755
--- a/.gitignore
+++ b/.gitignore
@@ -9,3 +9,4 @@
!serioussam-tse.desktop
!serioussam-tse.desktop
!gcc-11.3_Timer.patch
+!hud_isore.patch
diff --git a/PKGBUILD b/PKGBUILD
index 8b9d4711a0b4..b32a47964ea5 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ xplus_tfe=SamTFE-XPLUS.tar.xz
xplus_tse=SamTSE-XPLUS.tar.xz
pkgver=1.10.2
_srcname="SeriousSamClassic-$pkgver"
-pkgrel=2
+pkgrel=3
pkgdesc="Serious Sam Classic native Linux version with XPLUS Modification."
arch=('i686' 'x86_64')
url="https://github.com/tx00100xt/SeriousSamClassic"
@@ -57,6 +57,7 @@ fi
prepare(){
# Prepare patch
cat gcc-11.3_Timer.patch > "$srcdir/$_srcname/gcc-11.3_Timer.patch"
+ cat hud_isore.patch > "$srcdir/$_srcname/hud_isore.patch"
# Prepare XPLUS archive
cat "$xplus_tfe".part* > "$xplus_tfe"
@@ -88,9 +89,10 @@ prepare(){
chmod 755 build-linux"$_bits".sh
chmod 755 build-linux"$_bits"xplus.sh
- # gcc 11.3 patch
+ # gcc 11.3 patch && hud score patch
cd "$srcdir/$_srcname"
patch -p1 < gcc-11.3_Timer.patch || return 1
+ patch -p1 < hud_isore.patch || return 1
}
build(){
diff --git a/hud_isore.patch b/hud_isore.patch
new file mode 100644
index 000000000000..03fa210e9e3e
--- /dev/null
+++ b/hud_isore.patch
@@ -0,0 +1,264 @@
+diff -aurN a/SamTFE/Sources/Entities/Common/HUD.cpp b/SamTFE/Sources/Entities/Common/HUD.cpp
+--- a/SamTFE/Sources/Entities/Common/HUD.cpp 2022-02-15 23:17:59.801581000 +0300
++++ b/SamTFE/Sources/Entities/Common/HUD.cpp 2022-07-02 22:36:30.450372313 +0300
+@@ -25,6 +25,7 @@
+ //
+ extern INDEX hud_bShowPing;
+ extern INDEX hud_bShowKills;
++extern INDEX hud_bShowScore;
+
+ // cheats
+ extern INDEX cht_bEnable;
+@@ -1046,15 +1047,17 @@
+ iScore = iScoreSum;
+ }
+
+- // prepare and draw score or frags info
+- strValue.PrintF( "%d", iScore);
+- fRow = pixTopBound +fHalfUnit;
+- fCol = pixLeftBound +fHalfUnit;
+- fAdv = fAdvUnit+ fChrUnit*fWidthAdj/2 -fHalfUnit;
+- HUD_DrawBorder( fCol, fRow, fOneUnit, fOneUnit, colBorder);
+- HUD_DrawBorder( fCol+fAdv, fRow, fChrUnit*fWidthAdj, fOneUnit, colBorder);
+- HUD_DrawText( fCol+fAdv, fRow, strValue, colScore, 1.0f);
+- HUD_DrawIcon( fCol, fRow, _toFrags, colScore, 1.0f, FALSE);
++ if( hud_bShowScore ) {
++ // prepare and draw score or frags info
++ strValue.PrintF( "%d", iScore);
++ fRow = pixTopBound +fHalfUnit;
++ fCol = pixLeftBound +fHalfUnit;
++ fAdv = fAdvUnit+ fChrUnit*fWidthAdj/2 -fHalfUnit;
++ HUD_DrawBorder( fCol, fRow, fOneUnit, fOneUnit, colBorder);
++ HUD_DrawBorder( fCol+fAdv, fRow, fChrUnit*fWidthAdj, fOneUnit, colBorder);
++ HUD_DrawText( fCol+fAdv, fRow, strValue, colScore, 1.0f);
++ HUD_DrawIcon( fCol, fRow, _toFrags, colScore, 1.0f, FALSE);
++ }
+
+ // eventually draw mana info
+ if( bScoreMatch || bFragMatch) {
+@@ -1069,7 +1072,7 @@
+ }
+
+ // if single player or cooperative mode
+- if( bSinglePlay || bCooperative)
++ if( (bSinglePlay || bCooperative) && hud_bShowScore)
+ {
+ // prepare and draw hiscore info
+ strValue.PrintF( "%d", Max(_penPlayer->m_iHighScore, _penPlayer->m_psGameStats.ps_iScore));
+diff -aurN a/SamTFE/Sources/Entities/Player.es b/SamTFE/Sources/Entities/Player.es
+--- a/SamTFE/Sources/Entities/Player.es 2022-05-04 21:32:31.277241000 +0300
++++ b/SamTFE/Sources/Entities/Player.es 2022-07-02 22:29:07.341514706 +0300
+@@ -44,6 +44,7 @@
+
+ extern INDEX hud_bShowPing = TRUE;
+ extern INDEX hud_bShowKills = TRUE;
++extern INDEX hud_bShowScore = TRUE;
+
+ extern void JumpFromBouncer(CEntity *penToBounce, CEntity *penBouncer);
+ // from game
+@@ -619,6 +620,7 @@
+ // declare player control variables
+ _pShell->DeclareSymbol("persistent user INDEX hud_bShowPing;", &hud_bShowPing);
+ _pShell->DeclareSymbol("persistent user INDEX hud_bShowKills;", &hud_bShowKills);
++ _pShell->DeclareSymbol("persistent user INDEX hud_bShowScore;", &hud_bShowScore);
+
+ _pShell->DeclareSymbol("user INDEX ctl_bMoveForward;", &pctlCurrent.bMoveForward);
+ _pShell->DeclareSymbol("user INDEX ctl_bMoveBackward;", &pctlCurrent.bMoveBackward);
+diff -aurN a/SamTFE/Sources/EntitiesMP/Common/HUD.cpp b/SamTFE/Sources/EntitiesMP/Common/HUD.cpp
+--- a/SamTFE/Sources/EntitiesMP/Common/HUD.cpp 2022-02-15 23:17:59.895076000 +0300
++++ b/SamTFE/Sources/EntitiesMP/Common/HUD.cpp 2022-07-02 22:49:21.587330000 +0300
+@@ -42,6 +42,7 @@
+ //
+ extern INDEX hud_bShowPing;
+ extern INDEX hud_bShowKills;
++extern INDEX hud_bShowScore;
+
+ // cheats
+ extern INDEX cht_bEnable;
+@@ -1363,15 +1364,17 @@
+ iScore = iScoreSum;
+ }
+
+- // prepare and draw score or frags info
+- strValue.PrintF( "%d", iScore);
+- fRow = pixTopBound +fHalfUnit;
+- fCol = pixLeftBound +fHalfUnit;
+- fAdv = fAdvUnit+ fChrUnit*fWidthAdj/2 -fHalfUnit;
+- HUD_DrawBorder( fCol, fRow, fOneUnit, fOneUnit, colBorder);
+- HUD_DrawBorder( fCol+fAdv, fRow, fChrUnit*fWidthAdj, fOneUnit, colBorder);
+- HUD_DrawText( fCol+fAdv, fRow, strValue, colScore, 1.0f);
+- HUD_DrawIcon( fCol, fRow, _toFrags, C_WHITE /*colScore*/, 1.0f, FALSE);
++ if( hud_bShowScore ) {
++ // prepare and draw score or frags info
++ strValue.PrintF( "%d", iScore);
++ fRow = pixTopBound +fHalfUnit;
++ fCol = pixLeftBound +fHalfUnit;
++ fAdv = fAdvUnit+ fChrUnit*fWidthAdj/2 -fHalfUnit;
++ HUD_DrawBorder( fCol, fRow, fOneUnit, fOneUnit, colBorder);
++ HUD_DrawBorder( fCol+fAdv, fRow, fChrUnit*fWidthAdj, fOneUnit, colBorder);
++ HUD_DrawText( fCol+fAdv, fRow, strValue, colScore, 1.0f);
++ HUD_DrawIcon( fCol, fRow, _toFrags, C_WHITE /*colScore*/, 1.0f, FALSE);
++ }
+
+ // eventually draw mana info
+ if( bScoreMatch || bFragMatch) {
+@@ -1386,7 +1389,7 @@
+ }
+
+ // if single player or cooperative mode
+- if( bSinglePlay || bCooperative)
++ if( (bSinglePlay || bCooperative) && hud_bShowScore)
+ {
+ // prepare and draw hiscore info
+ strValue.PrintF( "%d", Max(_penPlayer->m_iHighScore, _penPlayer->m_psGameStats.ps_iScore));
+diff -aurN a/SamTFE/Sources/EntitiesMP/Player.es b/SamTFE/Sources/EntitiesMP/Player.es
+--- a/SamTFE/Sources/EntitiesMP/Player.es 2022-05-04 21:32:31.277241000 +0300
++++ b/SamTFE/Sources/EntitiesMP/Player.es 2022-07-02 22:47:15.470124000 +0300
+@@ -66,6 +66,7 @@
+
+ extern INDEX hud_bShowPing = TRUE;
+ extern INDEX hud_bShowKills = TRUE;
++extern INDEX hud_bShowScore = TRUE;
+
+ extern void JumpFromBouncer(CEntity *penToBounce, CEntity *penBouncer);
+ // from game
+@@ -710,6 +711,7 @@
+ // declare player control variables
+ _pShell->DeclareSymbol("persistent user INDEX hud_bShowPing;", &hud_bShowPing);
+ _pShell->DeclareSymbol("persistent user INDEX hud_bShowKills;", &hud_bShowKills);
++ _pShell->DeclareSymbol("persistent user INDEX hud_bShowScore;", &hud_bShowScore);
+
+ _pShell->DeclareSymbol("user INDEX ctl_bMoveForward;", (void *) &pctlCurrent.bMoveForward);
+ _pShell->DeclareSymbol("user INDEX ctl_bMoveBackward;", (void *) &pctlCurrent.bMoveBackward);
+diff -aurN a/SamTSE/Sources/Entities/Common/HUD.cpp b/SamTSE/Sources/Entities/Common/HUD.cpp
+--- a/SamTSE/Sources/Entities/Common/HUD.cpp 2022-02-15 23:17:59.801581000 +0300
++++ b/SamTSE/Sources/Entities/Common/HUD.cpp 2022-07-02 22:36:30.450372313 +0300
+@@ -25,6 +25,7 @@
+ //
+ extern INDEX hud_bShowPing;
+ extern INDEX hud_bShowKills;
++extern INDEX hud_bShowScore;
+
+ // cheats
+ extern INDEX cht_bEnable;
+@@ -1046,15 +1047,17 @@
+ iScore = iScoreSum;
+ }
+
+- // prepare and draw score or frags info
+- strValue.PrintF( "%d", iScore);
+- fRow = pixTopBound +fHalfUnit;
+- fCol = pixLeftBound +fHalfUnit;
+- fAdv = fAdvUnit+ fChrUnit*fWidthAdj/2 -fHalfUnit;
+- HUD_DrawBorder( fCol, fRow, fOneUnit, fOneUnit, colBorder);
+- HUD_DrawBorder( fCol+fAdv, fRow, fChrUnit*fWidthAdj, fOneUnit, colBorder);
+- HUD_DrawText( fCol+fAdv, fRow, strValue, colScore, 1.0f);
+- HUD_DrawIcon( fCol, fRow, _toFrags, colScore, 1.0f, FALSE);
++ if( hud_bShowScore ) {
++ // prepare and draw score or frags info
++ strValue.PrintF( "%d", iScore);
++ fRow = pixTopBound +fHalfUnit;
++ fCol = pixLeftBound +fHalfUnit;
++ fAdv = fAdvUnit+ fChrUnit*fWidthAdj/2 -fHalfUnit;
++ HUD_DrawBorder( fCol, fRow, fOneUnit, fOneUnit, colBorder);
++ HUD_DrawBorder( fCol+fAdv, fRow, fChrUnit*fWidthAdj, fOneUnit, colBorder);
++ HUD_DrawText( fCol+fAdv, fRow, strValue, colScore, 1.0f);
++ HUD_DrawIcon( fCol, fRow, _toFrags, colScore, 1.0f, FALSE);
++ }
+
+ // eventually draw mana info
+ if( bScoreMatch || bFragMatch) {
+@@ -1069,7 +1072,7 @@
+ }
+
+ // if single player or cooperative mode
+- if( bSinglePlay || bCooperative)
++ if( (bSinglePlay || bCooperative) && hud_bShowScore)
+ {
+ // prepare and draw hiscore info
+ strValue.PrintF( "%d", Max(_penPlayer->m_iHighScore, _penPlayer->m_psGameStats.ps_iScore));
+diff -aurN a/SamTSE/Sources/Entities/Player.es b/SamTSE/Sources/Entities/Player.es
+--- a/SamTSE/Sources/Entities/Player.es 2022-05-04 21:32:31.277241000 +0300
++++ b/SamTSE/Sources/Entities/Player.es 2022-07-02 22:29:07.341514706 +0300
+@@ -44,6 +44,7 @@
+
+ extern INDEX hud_bShowPing = TRUE;
+ extern INDEX hud_bShowKills = TRUE;
++extern INDEX hud_bShowScore = TRUE;
+
+ extern void JumpFromBouncer(CEntity *penToBounce, CEntity *penBouncer);
+ // from game
+@@ -619,6 +620,7 @@
+ // declare player control variables
+ _pShell->DeclareSymbol("persistent user INDEX hud_bShowPing;", &hud_bShowPing);
+ _pShell->DeclareSymbol("persistent user INDEX hud_bShowKills;", &hud_bShowKills);
++ _pShell->DeclareSymbol("persistent user INDEX hud_bShowScore;", &hud_bShowScore);
+
+ _pShell->DeclareSymbol("user INDEX ctl_bMoveForward;", &pctlCurrent.bMoveForward);
+ _pShell->DeclareSymbol("user INDEX ctl_bMoveBackward;", &pctlCurrent.bMoveBackward);
+diff -aurN a/SamTSE/Sources/EntitiesMP/Common/HUD.cpp b/SamTSE/Sources/EntitiesMP/Common/HUD.cpp
+--- a/SamTSE/Sources/EntitiesMP/Common/HUD.cpp 2022-02-15 23:17:59.895076000 +0300
++++ b/SamTSE/Sources/EntitiesMP/Common/HUD.cpp 2022-07-02 22:49:21.587330000 +0300
+@@ -42,6 +42,7 @@
+ //
+ extern INDEX hud_bShowPing;
+ extern INDEX hud_bShowKills;
++extern INDEX hud_bShowScore;
+
+ // cheats
+ extern INDEX cht_bEnable;
+@@ -1363,15 +1364,17 @@
+ iScore = iScoreSum;
+ }
+
+- // prepare and draw score or frags info
+- strValue.PrintF( "%d", iScore);
+- fRow = pixTopBound +fHalfUnit;
+- fCol = pixLeftBound +fHalfUnit;
+- fAdv = fAdvUnit+ fChrUnit*fWidthAdj/2 -fHalfUnit;
+- HUD_DrawBorder( fCol, fRow, fOneUnit, fOneUnit, colBorder);
+- HUD_DrawBorder( fCol+fAdv, fRow, fChrUnit*fWidthAdj, fOneUnit, colBorder);
+- HUD_DrawText( fCol+fAdv, fRow, strValue, colScore, 1.0f);
+- HUD_DrawIcon( fCol, fRow, _toFrags, C_WHITE /*colScore*/, 1.0f, FALSE);
++ if( hud_bShowScore ) {
++ // prepare and draw score or frags info
++ strValue.PrintF( "%d", iScore);
++ fRow = pixTopBound +fHalfUnit;
++ fCol = pixLeftBound +fHalfUnit;
++ fAdv = fAdvUnit+ fChrUnit*fWidthAdj/2 -fHalfUnit;
++ HUD_DrawBorder( fCol, fRow, fOneUnit, fOneUnit, colBorder);
++ HUD_DrawBorder( fCol+fAdv, fRow, fChrUnit*fWidthAdj, fOneUnit, colBorder);
++ HUD_DrawText( fCol+fAdv, fRow, strValue, colScore, 1.0f);
++ HUD_DrawIcon( fCol, fRow, _toFrags, C_WHITE /*colScore*/, 1.0f, FALSE);
++ }
+
+ // eventually draw mana info
+ if( bScoreMatch || bFragMatch) {
+@@ -1386,7 +1389,7 @@
+ }
+
+ // if single player or cooperative mode
+- if( bSinglePlay || bCooperative)
++ if( (bSinglePlay || bCooperative) && hud_bShowScore)
+ {
+ // prepare and draw hiscore info
+ strValue.PrintF( "%d", Max(_penPlayer->m_iHighScore, _penPlayer->m_psGameStats.ps_iScore));
+diff -aurN a/SamTSE/Sources/EntitiesMP/Player.es b/SamTSE/Sources/EntitiesMP/Player.es
+--- a/SamTSE/Sources/EntitiesMP/Player.es 2022-05-04 21:32:31.277241000 +0300
++++ b/SamTSE/Sources/EntitiesMP/Player.es 2022-07-02 22:47:15.470124000 +0300
+@@ -66,6 +66,7 @@
+
+ extern INDEX hud_bShowPing = TRUE;
+ extern INDEX hud_bShowKills = TRUE;
++extern INDEX hud_bShowScore = TRUE;
+
+ extern void JumpFromBouncer(CEntity *penToBounce, CEntity *penBouncer);
+ // from game
+@@ -710,6 +711,7 @@
+ // declare player control variables
+ _pShell->DeclareSymbol("persistent user INDEX hud_bShowPing;", &hud_bShowPing);
+ _pShell->DeclareSymbol("persistent user INDEX hud_bShowKills;", &hud_bShowKills);
++ _pShell->DeclareSymbol("persistent user INDEX hud_bShowScore;", &hud_bShowScore);
+
+ _pShell->DeclareSymbol("user INDEX ctl_bMoveForward;", (void *) &pctlCurrent.bMoveForward);
+ _pShell->DeclareSymbol("user INDEX ctl_bMoveBackward;", (void *) &pctlCurrent.bMoveBackward);