summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortx00100xt2023-06-09 12:54:14 +0300
committertx00100xt2023-06-09 12:54:14 +0300
commit8ef75ae5aacb379bcc4b0207d7d78a51636311d1 (patch)
tree891b3b5ea07be9c047555a2298243afd70626c3c
parentdd8661c07c2a016e0ebcfed22ea4dd74de0445f0 (diff)
downloadaur-8ef75ae5aacb379bcc4b0207d7d78a51636311d1.tar.gz
Added 0001-remove_SE1_10b_depend.patch
-rw-r--r--.SRCINFO2
-rw-r--r--0001-remove_SE1_10b_depend.patch80
-rw-r--r--PKGBUILD16
3 files changed, 90 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2b15d57d2167..086c8cd23d14 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = serioussam
pkgdesc = Serious Sam Classic native Linux version.
pkgver = 1.10.5
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/tx00100xt/SeriousSamClassic
arch = i686
arch = x86_64
diff --git a/0001-remove_SE1_10b_depend.patch b/0001-remove_SE1_10b_depend.patch
new file mode 100644
index 000000000000..dec6d3bef440
--- /dev/null
+++ b/0001-remove_SE1_10b_depend.patch
@@ -0,0 +1,80 @@
+--- a/SamTFE/Sources/GameMP/Map.cpp 2023-06-03 21:49:29.345299714 +0300
++++ b/SamTFE/Sources/GameMP/Map.cpp 2023-06-07 11:33:13.865159902 +0300
+@@ -427,6 +427,7 @@
+ BOOL ObtainMapData(void)
+ {
+ try {
++#ifndef FIRST_ENCOUNTER
+ // the second encounter
+ atoIconsSE[ 0].SetData_t(CTFILENAME("TexturesMP\\Computer\\Map\\Book.tex"));
+ atoIconsSE[ 1].SetData_t(CTFILENAME("TexturesMP\\Computer\\Map\\Level00.tex"));
+@@ -465,7 +466,7 @@
+ ((CTextureData*)_toMapBcgLUSE .GetData())->Force(TEX_CONSTANT);
+ ((CTextureData*)_toMapBcgRDSE .GetData())->Force(TEX_CONSTANT);
+ ((CTextureData*)_toMapBcgRUSE .GetData())->Force(TEX_CONSTANT);
+-
++#else
+ // the first encounter
+ atoIconsFE[ 0].SetData_t(CTFILENAME("Textures\\Computer\\Map\\Level00.tex"));
+ atoIconsFE[ 1].SetData_t(CTFILENAME("Textures\\Computer\\Map\\Level01.tex"));
+@@ -482,6 +483,7 @@
+ atoIconsFE[12].SetData_t(CTFILENAME("Textures\\Computer\\Map\\Level12.tex"));
+ atoIconsFE[13].SetData_t(CTFILENAME("Textures\\Computer\\Map\\Level13.tex"));
+ atoIconsFE[14].SetData_t(CTFILENAME("Textures\\Computer\\Map\\Level14.tex"));
++ _toPathDot .SetData_t(CTFILENAME("Textures\\Computer\\Map\\PathDot.tex"));
+ _toMapBcgLDFE .SetData_t(CTFILENAME("Textures\\Computer\\Map\\MapBcgLD.tex"));
+ _toMapBcgLUFE .SetData_t(CTFILENAME("Textures\\Computer\\Map\\MapBcgLU.tex"));
+ _toMapBcgRDFE .SetData_t(CTFILENAME("Textures\\Computer\\Map\\MapBcgRD.tex"));
+@@ -502,10 +504,12 @@
+ ((CTextureData*)atoIconsFE[12].GetData())->Force(TEX_CONSTANT);
+ ((CTextureData*)atoIconsFE[13].GetData())->Force(TEX_CONSTANT);
+ ((CTextureData*)atoIconsFE[14].GetData())->Force(TEX_CONSTANT);
++ ((CTextureData*)_toPathDot .GetData())->Force(TEX_CONSTANT);
+ ((CTextureData*)_toMapBcgLDFE .GetData())->Force(TEX_CONSTANT);
+ ((CTextureData*)_toMapBcgLUFE .GetData())->Force(TEX_CONSTANT);
+ ((CTextureData*)_toMapBcgRDFE .GetData())->Force(TEX_CONSTANT);
+ ((CTextureData*)_toMapBcgRUFE .GetData())->Force(TEX_CONSTANT);
++#endif
+ }
+ catch (const char *strError) {
+ CPrintF("%s\n", (const char *)strError);
+--- a/SamTSE/Sources/GameMP/Map.cpp 2023-06-03 21:49:29.345299714 +0300
++++ b/SamTSE/Sources/GameMP/Map.cpp 2023-06-07 11:33:13.865159902 +0300
+@@ -427,6 +427,7 @@
+ BOOL ObtainMapData(void)
+ {
+ try {
++#ifndef FIRST_ENCOUNTER
+ // the second encounter
+ atoIconsSE[ 0].SetData_t(CTFILENAME("TexturesMP\\Computer\\Map\\Book.tex"));
+ atoIconsSE[ 1].SetData_t(CTFILENAME("TexturesMP\\Computer\\Map\\Level00.tex"));
+@@ -465,7 +466,7 @@
+ ((CTextureData*)_toMapBcgLUSE .GetData())->Force(TEX_CONSTANT);
+ ((CTextureData*)_toMapBcgRDSE .GetData())->Force(TEX_CONSTANT);
+ ((CTextureData*)_toMapBcgRUSE .GetData())->Force(TEX_CONSTANT);
+-
++#else
+ // the first encounter
+ atoIconsFE[ 0].SetData_t(CTFILENAME("Textures\\Computer\\Map\\Level00.tex"));
+ atoIconsFE[ 1].SetData_t(CTFILENAME("Textures\\Computer\\Map\\Level01.tex"));
+@@ -482,6 +483,7 @@
+ atoIconsFE[12].SetData_t(CTFILENAME("Textures\\Computer\\Map\\Level12.tex"));
+ atoIconsFE[13].SetData_t(CTFILENAME("Textures\\Computer\\Map\\Level13.tex"));
+ atoIconsFE[14].SetData_t(CTFILENAME("Textures\\Computer\\Map\\Level14.tex"));
++ _toPathDot .SetData_t(CTFILENAME("Textures\\Computer\\Map\\PathDot.tex"));
+ _toMapBcgLDFE .SetData_t(CTFILENAME("Textures\\Computer\\Map\\MapBcgLD.tex"));
+ _toMapBcgLUFE .SetData_t(CTFILENAME("Textures\\Computer\\Map\\MapBcgLU.tex"));
+ _toMapBcgRDFE .SetData_t(CTFILENAME("Textures\\Computer\\Map\\MapBcgRD.tex"));
+@@ -502,10 +504,12 @@
+ ((CTextureData*)atoIconsFE[12].GetData())->Force(TEX_CONSTANT);
+ ((CTextureData*)atoIconsFE[13].GetData())->Force(TEX_CONSTANT);
+ ((CTextureData*)atoIconsFE[14].GetData())->Force(TEX_CONSTANT);
++ ((CTextureData*)_toPathDot .GetData())->Force(TEX_CONSTANT);
+ ((CTextureData*)_toMapBcgLDFE .GetData())->Force(TEX_CONSTANT);
+ ((CTextureData*)_toMapBcgLUFE .GetData())->Force(TEX_CONSTANT);
+ ((CTextureData*)_toMapBcgRDFE .GetData())->Force(TEX_CONSTANT);
+ ((CTextureData*)_toMapBcgRUFE .GetData())->Force(TEX_CONSTANT);
++#endif
+ }
+ catch (const char *strError) {
+ CPrintF("%s\n", (const char *)strError);
diff --git a/PKGBUILD b/PKGBUILD
index cb8abafc8f81..47354c727fb9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgname=serioussam
pkginstdir=serioussam
pkgver=1.10.5
_srcname="SeriousSamClassic-$pkgver"
-pkgrel=1
+pkgrel=2
pkgdesc="Serious Sam Classic native Linux version."
arch=('i686' 'x86_64')
url="https://github.com/tx00100xt/SeriousSamClassic"
@@ -17,11 +17,13 @@ install=serioussam.install
source=("https://github.com/tx00100xt/SeriousSamClassic/archive/refs/tags/v$pkgver.tar.gz"
"serioussam-tfe.desktop"
"serioussam-tse.desktop"
- "serioussam.xpm")
+ "serioussam.xpm"
+ "0001-remove_SE1_10b_depend.patch")
sha256sums=('ecd850cabd144b29bcec97de4ad8a1ffc14144432744de9bf39fe1d00385daf6'
'1e36d7b0d11f68729aa5c79ac9a44157d4af0bf61060040ab92a37d96ca89aba'
'49680c65d26b264a1d7735c6310fcc5d0ac0e0e56273d3bccf539c0c87d31b2b'
- '1fd56e04072372e1e8dab0bae40da1519d82a28895cbe5661b18561ee9ea47b4')
+ '1fd56e04072372e1e8dab0bae40da1519d82a28895cbe5661b18561ee9ea47b4'
+ '244101d02598010e4c45e57f26e0842d4cff058e3cde5e59062b9d36b5ffaca0')
if [[ $CARCH = "i686" ]]; then
_bits="32"
else
@@ -29,23 +31,23 @@ else
fi
prepare(){
+ # Prepare patch
+ cat 0001-remove_SE1_10b_depend.patch > "$srcdir/$_srcname/0001-remove_SE1_10b_depend.patch"
# Making building TFE scripts.
cd "$srcdir/$_srcname/SamTFE/Sources/"
sed -i 's/cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo/cmake -DCMAKE_BUILD_TYPE=Release/g' build-linux"$_bits".sh
sed 's/cmake -DCMAKE_BUILD_TYPE=Release/cmake -DTFE=TRUE -DCMAKE_BUILD_TYPE=Release/g' build-linux"$_bits".sh > build-linux"$_bits"-tfe.sh
- # sed -i 's/Threaded version" FALSE/Threaded version" TRUE/g' CMakeLists.txt
chmod 755 build-linux"$_bits"-tfe.sh
# Making building TSE scripts.
cd "$srcdir/$_srcname/SamTSE/Sources/"
sed -i 's/cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo/cmake -DCMAKE_BUILD_TYPE=Release/g' build-linux"$_bits".sh
- # sed -i 's/Threaded version" FALSE/Threaded version" TRUE/g' CMakeLists.txt
chmod 755 build-linux"$_bits".sh
cd "$srcdir/$_srcname"
- # patch
- # patch -p1 < sam-1.10.4-to-1.10.5-pre.patch || return 1
+ # apply patch
+ patch -p1 < 0001-remove_SE1_10b_depend.patch || return 1
}
build(){