summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortx00100xt2022-06-21 18:31:45 +0300
committertx00100xt2022-06-21 18:31:45 +0300
commitacc69b2158f3c085db830de40dba2cf24a5f4fd2 (patch)
tree7932bda01299e907676bbed9703b1d7717aa259e
downloadaur-acc69b2158f3c085db830de40dba2cf24a5f4fd2.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD59
2 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..56dcacffe32e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = serioussam
+ pkgdesc = A game engine developed by Croteam for the classic Serious Sam games.
+ pkgver = 1.10.2
+ pkgrel = 1
+ url = https://github.com/tx00100xt/SeriousSamClassic"
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = cmake
+ makedepends = make
+ makedepends = sed
+ depends = sdl2
+ depends = python
+ depends = bash
+ source = https://github.com/tx00100xt/SeriousSamClassic/archive/refs/tags/v$pkgver.tar.gz
+ sha512sums = SKIP
+
+pkgname = serioussam
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd848c2d3ac4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: tx00100xt <tx00100xt@yandex.ru>
+# Contributer: tx00100xt <tx00100xt@yandex.ru>
+
+pkgname=serioussam
+pkgver=1.10.2
+_srcname="SeriousSamClassic-$pkgver"
+pkgrel=1
+pkgdesc="A game engine developed by Croteam for the classic Serious Sam games."
+arch=('i686' 'x86_64')
+url="https://github.com/tx00100xt/SeriousSamClassic"
+license=('GPL2')
+depends=('sdl2' 'python' 'bash')
+makedepends=('cmake' 'make' 'sed')
+source=(https://github.com/tx00100xt/SeriousSamClassic/archive/refs/tags/v$pkgver.tar.gz)
+sha512sums=('SKIP')
+if [[ $CARCH = "i686" ]]; then
+ _bits="32"
+else
+ _bits="64"
+fi
+
+prepare(){
+ cd "$srcdir/$_srcname/SamTFE/Sources/"
+ sed -i 's/cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo/cmake -DCMAKE_BUILD_TYPE=Release/g' build-linux"$_bits".sh
+ sed 's/cmake -DCMAKE_BUILD_TYPE=Release/cmake -DTFE=TRUE -DCMAKE_BUILD_TYPE=Release/g' build-linux"$_bits".sh > build-linux"$_bits"-tfe.sh
+ sed -i 's/cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo/cmake -DCMAKE_BUILD_TYPE=Release/g' build-linux"$_bits"xplus.sh
+ sed 's/cmake -DCMAKE_BUILD_TYPE=Release/cmake -DTFE=TRUE -DCMAKE_BUILD_TYPE=Release/g' build-linux"$_bits"xplus.sh > build-linux"$_bits"xplus-tfe.sh
+ chmod 755 build-linux"$_bits"-tfe.sh
+ chmod 755 build-linux"$_bits"xplus-tfe.sh
+}
+build(){
+ cd "$srcdir/$_srcname/SamTFE/Sources/"
+ ./build-linux"$_bits"-tfe.sh
+
+ cd "$srcdir/$_srcname/SamTFE/Sources/"
+ ./build-linux"$_bits"xplus-tfe.sh
+
+ cd "$srcdir/$_srcname/SamTSE/Sources/"
+ ./build-linux"$_bits".sh
+
+ cd "$srcdir/$_srcname/SamTSE/Sources/"
+ ./build-linux"$_bits"xplus.sh
+
+ cd "$srcdir/$_srcname/SamTFE/"
+ rm -fr "Sources"
+ rm -fr "Tools.Win32"
+
+ cd "$srcdir/$_srcname/SamTSE/"
+ rm -fr "Sources"
+ rm -fr "Tools.Win32"
+
+ rm -f "$srcdir/$_srcname"/{*.sh,*.old}
+}
+package(){
+ mkdir -p "$pkgdir"/usr/{bin,share}/
+ mv "$srcdir/$_srcname" "$pkgdir/usr/share/$pkgname"
+ ln -s /usr/share/$pkgname/SamTFE/Bin/SeriousSam "$pkgdir/usr/bin/serioussam-tfe"
+ ln -s /usr/share/$pkgname/SamTSE/Bin/SeriousSam "$pkgdir/usr/bin/serioussam-tse"
+}