summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortx00100xt2023-05-22 23:13:26 +0300
committertx00100xt2023-05-22 23:13:26 +0300
commitd4c0ab924a0a09527d3cf078791e20a43a40849f (patch)
treebcffa3b45917158a271ecce072a9fe614809b04a
parent10df8b3f8fbd9b64554b118174134a97fd3d3f5a (diff)
downloadaur-d4c0ab924a0a09527d3cf078791e20a43a40849f.tar.gz
Fix run on gnome44. Added start mods from command promt.
-rwxr-xr-x.SRCINFO2
-rwxr-xr-xPKGBUILD15
-rw-r--r--fix_sdl2_fullscreen_on_gnome44.patch24
-rwxr-xr-xserioussam-tfe.sh2
-rwxr-xr-xserioussam-tse.sh2
5 files changed, 37 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 439e8e7fa84d..f91a7bd1a3f1 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = serioussam
pkgdesc = Serious Sam Classic native Linux version with XPLUS Modification.
pkgver = 1.10.4
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/tx00100xt/SeriousSamClassic
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 8bdbacd2987b..c76c14f43b2c 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ xplus_tfe=SamTFE-XPLUS.tar.xz
xplus_tse=SamTSE-XPLUS.tar.xz
pkgver=1.10.4
_srcname="SeriousSamClassic-$pkgver"
-pkgrel=5
+pkgrel=6
pkgdesc="Serious Sam Classic native Linux version with XPLUS Modification."
arch=('i686' 'x86_64')
url="https://github.com/tx00100xt/SeriousSamClassic"
@@ -30,7 +30,8 @@ source=("https://github.com/tx00100xt/SeriousSamClassic/archive/refs/tags/v$pkgv
"serioussam-tse.sh"
"tfe-last-update.patch"
"tse-last-update.patch"
- "fix-thunder.patch")
+ "fix-thunder.patch"
+ "fix_sdl2_fullscreen_on_gnome44.patch")
noextract=("SamTFE-XPLUS.tar.xz.partaa"
"SamTFE-XPLUS.tar.xz.partab"
"SamTFE-XPLUS.tar.xz.partac"
@@ -47,11 +48,12 @@ sha256sums=('c42e1434e03f713ffc60aa627f0a24c64287598bc5ee7cdbd2cbe91aa363ef51'
'8e9f0d7138ab5da6b4b899f39234f6e3c48d0d47970c6b12372e33e86e39d606'
'134bbc9088b8c323c9a17a7ea8a39942e4cf4b83e149cb4f89e161adf7290122'
'1fd56e04072372e1e8dab0bae40da1519d82a28895cbe5661b18561ee9ea47b4'
- '649c2a4f2c0dfa1a096192cd6a24206fba19512a1b8094663b9cfb21a93a2d35'
- 'd1938c4422ad9f4b00703b29edfb4bb39aa7e5c6b4ad64a38cd530d88cec46f3'
+ '092d0806cba13368419c63887dec4dd556ffc63d0421634e268c544260f78b1f'
+ '6332bcfe309be35f5381bdf3dc7c334674a936b3793ac0840dc9992e9a98d6a3'
'3e7556a71e8627ea0e94e1abd1112e493e12e27d8465aa3a7c37a138d08893b7'
'637b388f88a241ad7f140ed22cc49b92174cb9b8abe9bb8a876a9b40af7b3f16'
- 'ad07c6b9d29a0d8a1a276b0c00d07e2d24d8c63c425efa21daa31ec3c1d366df')
+ 'ad07c6b9d29a0d8a1a276b0c00d07e2d24d8c63c425efa21daa31ec3c1d366df'
+ '18244ab0be66d5f5ea98e2ad387290803be08a77d71820a53972e4d58d3e2ac0')
if [[ $CARCH = "i686" ]]; then
_bits="32"
else
@@ -63,6 +65,7 @@ prepare(){
cat tfe-last-update.patch > "$srcdir/$_srcname/tfe-last-update.patch"
cat tse-last-update.patch > "$srcdir/$_srcname/tse-last-update.patch"
cat fix-thunder.patch > "$srcdir/$_srcname/fix-thunder.patch"
+ cat fix_sdl2_fullscreen_on_gnome44.patch > "$srcdir/$_srcname/fix_sdl2_fullscreen_on_gnome44.patch"
# Prepare XPLUS archive
cat "$xplus_tfe".part* > "$xplus_tfe"
@@ -99,6 +102,8 @@ prepare(){
patch -p1 < tfe-last-update.patch || return 1
patch -p1 < tse-last-update.patch || return 1
patch -p1 < fix-thunder.patch || return 1
+ # gnone44 sdl2 patch
+ patch -p1 < fix_sdl2_fullscreen_on_gnome44.patch || return 1
}
build(){
diff --git a/fix_sdl2_fullscreen_on_gnome44.patch b/fix_sdl2_fullscreen_on_gnome44.patch
new file mode 100644
index 000000000000..4609f49cf61a
--- /dev/null
+++ b/fix_sdl2_fullscreen_on_gnome44.patch
@@ -0,0 +1,24 @@
+diff -aurN a/SamTFE/Sources/SeriousSam/MainWindow.cpp b/SamTFE/Sources/SeriousSam/MainWindow.cpp
+--- a/SamTFE/Sources/SeriousSam/MainWindow.cpp 2023-05-12 17:44:37.195187204 +0300
++++ b/SamTFE/Sources/SeriousSam/MainWindow.cpp 2023-05-22 17:24:45.608842154 +0300
+@@ -285,7 +285,7 @@
+ #else
+ SDL_snprintf( achWindowTitle, sizeof (achWindowTitle), TRANSV("Serious Sam (FullScreen %dx%d)"), pixSizeI, pixSizeJ);
+ //CPrintF((const char*)"--- %s ---\n",achWindowTitle);
+- _hwndMain = SDL_CreateWindow((const char*)strWindow1251ToUtf8(achWindowTitle), SDL_WINDOWPOS_CENTERED, SDL_WINDOWPOS_CENTERED, pixSizeI, pixSizeJ, SDL_WINDOW_OPENGL | SDL_WINDOW_FULLSCREEN);
++ _hwndMain = SDL_CreateWindow((const char*)strWindow1251ToUtf8(achWindowTitle), SDL_WINDOWPOS_CENTERED, SDL_WINDOWPOS_CENTERED, pixSizeI, pixSizeJ, SDL_WINDOW_OPENGL | SDL_WINDOW_FULLSCREEN | SDL_WINDOW_BORDERLESS);
+ if( _hwndMain==NULL) FatalError(TRANSV("Cannot open main window!"));
+ SE_UpdateWindowHandle( _hwndMain);
+ _pixLastSizeI = pixSizeI;
+diff -aurN a/SamTSE/Sources/SeriousSam/MainWindow.cpp b/SamTSE/Sources/SeriousSam/MainWindow.cpp
+--- a/SamTSE/Sources/SeriousSam/MainWindow.cpp 2023-05-12 17:44:37.375188656 +0300
++++ b/SamTSE/Sources/SeriousSam/MainWindow.cpp 2023-05-22 17:25:10.229068219 +0300
+@@ -285,7 +285,7 @@
+ #else
+ SDL_snprintf( achWindowTitle, sizeof (achWindowTitle), TRANSV("Serious Sam (FullScreen %dx%d)"), pixSizeI, pixSizeJ);
+ //CPrintF((const char*)"--- %s ---\n",achWindowTitle);
+- _hwndMain = SDL_CreateWindow((const char*)strWindow1251ToUtf8(achWindowTitle), SDL_WINDOWPOS_CENTERED, SDL_WINDOWPOS_CENTERED, pixSizeI, pixSizeJ, SDL_WINDOW_OPENGL | SDL_WINDOW_FULLSCREEN);
++ _hwndMain = SDL_CreateWindow((const char*)strWindow1251ToUtf8(achWindowTitle), SDL_WINDOWPOS_CENTERED, SDL_WINDOWPOS_CENTERED, pixSizeI, pixSizeJ, SDL_WINDOW_OPENGL | SDL_WINDOW_FULLSCREEN | SDL_WINDOW_BORDERLESS);
+ if( _hwndMain==NULL) FatalError(TRANSV("Cannot open main window!"));
+ SE_UpdateWindowHandle( _hwndMain);
+ _pixLastSizeI = pixSizeI;
diff --git a/serioussam-tfe.sh b/serioussam-tfe.sh
index 19bb97ea5dcf..aba6222ca4a3 100755
--- a/serioussam-tfe.sh
+++ b/serioussam-tfe.sh
@@ -1,4 +1,4 @@
#!/bin/sh
cd "/usr/share/serioussam/SamTFE/Bin"
export LD_LIBRARY_PATH=".:${LD_LIBRARY_PATH}"
-./SeriousSam
+./SeriousSam $1 $2
diff --git a/serioussam-tse.sh b/serioussam-tse.sh
index 2a0817adb2d8..c17db2b15d34 100755
--- a/serioussam-tse.sh
+++ b/serioussam-tse.sh
@@ -1,4 +1,4 @@
#!/bin/sh
cd "/usr/share/serioussam/SamTSE/Bin"
export LD_LIBRARY_PATH=".:${LD_LIBRARY_PATH}"
-./SeriousSam
+./SeriousSam $1 $2