summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortx00100xt2023-06-15 21:10:12 +0300
committertx00100xt2023-06-15 21:10:12 +0300
commite1cbded34522c21ebaf6e4a8fd1c47e5d218124b (patch)
treeafb8367156293df55ff184ef49492d94d77b0152
parent8ef75ae5aacb379bcc4b0207d7d78a51636311d1 (diff)
downloadaur-e1cbded34522c21ebaf6e4a8fd1c47e5d218124b.tar.gz
Fix platform definition and fix opengl lens flare
-rw-r--r--.SRCINFO2
-rw-r--r--0002-Fixed_Platform_definition.patch24
-rw-r--r--PKGBUILD10
3 files changed, 32 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 086c8cd23d14..720a16ae1f2a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = serioussam
pkgdesc = Serious Sam Classic native Linux version.
pkgver = 1.10.5
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/tx00100xt/SeriousSamClassic
arch = i686
arch = x86_64
diff --git a/0002-Fixed_Platform_definition.patch b/0002-Fixed_Platform_definition.patch
new file mode 100644
index 000000000000..d4ea63667f98
--- /dev/null
+++ b/0002-Fixed_Platform_definition.patch
@@ -0,0 +1,24 @@
+--- a/SamTFE/Sources/Engine/Graphics/DrawPort.cpp 2023-06-15 15:33:34.948634151 +0300
++++ b/SamTFE/Sources/Engine/Graphics/DrawPort.cpp 2023-06-15 15:35:00.308972920 +0300
+@@ -1168,7 +1168,8 @@
+ // if the point is out or at the edge of drawport, it is not visible by default
+ if( pixI<1 || pixI>dp_Width-2 || pixJ<1 || pixJ>dp_Height-2) return FALSE;
+
+- #if defined(__arm__) || defined(PLATFORM_RISCV64)
++ #if defined(__arm__) || PLATFORM_RISCV64
++ #warning PLATFORM_NOT_X86 use GLES based GPU (Lens Flare not work)
+ // Assuming here that all ARM machine use GLES based GPU, were DEPTH reading is probably not available (or super slow)
+ return FALSE;
+ #endif
+--- a/SamTSE/Sources/Engine/Graphics/DrawPort.cpp 2023-06-15 15:33:34.948634151 +0300
++++ b/SamTSE/Sources/Engine/Graphics/DrawPort.cpp 2023-06-15 15:35:00.308972920 +0300
+@@ -1168,7 +1168,8 @@
+ // if the point is out or at the edge of drawport, it is not visible by default
+ if( pixI<1 || pixI>dp_Width-2 || pixJ<1 || pixJ>dp_Height-2) return FALSE;
+
+- #if defined(__arm__) || defined(PLATFORM_RISCV64)
++ #if defined(__arm__) || PLATFORM_RISCV64
++ #warning PLATFORM_NOT_X86 use GLES based GPU (Lens Flare not work)
+ // Assuming here that all ARM machine use GLES based GPU, were DEPTH reading is probably not available (or super slow)
+ return FALSE;
+ #endif
diff --git a/PKGBUILD b/PKGBUILD
index 47354c727fb9..692125daba52 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgname=serioussam
pkginstdir=serioussam
pkgver=1.10.5
_srcname="SeriousSamClassic-$pkgver"
-pkgrel=2
+pkgrel=3
pkgdesc="Serious Sam Classic native Linux version."
arch=('i686' 'x86_64')
url="https://github.com/tx00100xt/SeriousSamClassic"
@@ -18,12 +18,14 @@ source=("https://github.com/tx00100xt/SeriousSamClassic/archive/refs/tags/v$pkgv
"serioussam-tfe.desktop"
"serioussam-tse.desktop"
"serioussam.xpm"
- "0001-remove_SE1_10b_depend.patch")
+ "0001-remove_SE1_10b_depend.patch"
+ "0002-Fixed_Platform_definition.patch")
sha256sums=('ecd850cabd144b29bcec97de4ad8a1ffc14144432744de9bf39fe1d00385daf6'
'1e36d7b0d11f68729aa5c79ac9a44157d4af0bf61060040ab92a37d96ca89aba'
'49680c65d26b264a1d7735c6310fcc5d0ac0e0e56273d3bccf539c0c87d31b2b'
'1fd56e04072372e1e8dab0bae40da1519d82a28895cbe5661b18561ee9ea47b4'
- '244101d02598010e4c45e57f26e0842d4cff058e3cde5e59062b9d36b5ffaca0')
+ '244101d02598010e4c45e57f26e0842d4cff058e3cde5e59062b9d36b5ffaca0'
+ '21100e7993892d5ac7b4d44b87cf29d47afac5bfbc0e39c2777a3e0dc813dbd2')
if [[ $CARCH = "i686" ]]; then
_bits="32"
else
@@ -33,6 +35,7 @@ fi
prepare(){
# Prepare patch
cat 0001-remove_SE1_10b_depend.patch > "$srcdir/$_srcname/0001-remove_SE1_10b_depend.patch"
+ cat 0002-Fixed_Platform_definition.patch > "$srcdir/$_srcname/0002-Fixed_Platform_definition.patch"
# Making building TFE scripts.
cd "$srcdir/$_srcname/SamTFE/Sources/"
@@ -48,6 +51,7 @@ prepare(){
cd "$srcdir/$_srcname"
# apply patch
patch -p1 < 0001-remove_SE1_10b_depend.patch || return 1
+ patch -p1 < 0002-Fixed_Platform_definition.patch || return 1
}
build(){