summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortx00100xt2023-07-13 13:14:33 +0300
committertx00100xt2023-07-13 13:14:33 +0300
commitfb73ac5fa5c4af6041159f985d2ee861f05ba78b (patch)
tree8fd42db7d743a0040d825a8dc2ba9bd007aa2575
parente1cbded34522c21ebaf6e4a8fd1c47e5d218124b (diff)
downloadaur-fb73ac5fa5c4af6041159f985d2ee861f05ba78b.tar.gz
Fixed loading of some incorrect custom maps.
-rw-r--r--.SRCINFO2
-rw-r--r--0003-Fix-load-some-incorrect-custom-maps.patch50
-rw-r--r--PKGBUILD10
3 files changed, 58 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 720a16ae1f2a..0c5dc06c1b8f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = serioussam
pkgdesc = Serious Sam Classic native Linux version.
pkgver = 1.10.5
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/tx00100xt/SeriousSamClassic
arch = i686
arch = x86_64
diff --git a/0003-Fix-load-some-incorrect-custom-maps.patch b/0003-Fix-load-some-incorrect-custom-maps.patch
new file mode 100644
index 000000000000..2c8f422c7679
--- /dev/null
+++ b/0003-Fix-load-some-incorrect-custom-maps.patch
@@ -0,0 +1,50 @@
+--- a/SamTFE/Sources/GameMP/LoadingHook.cpp 2023-06-04 21:21:47.000000000 +0300
++++ b/SamTFE/Sources/GameMP/LoadingHook.cpp 2023-07-07 11:29:23.589269179 +0300
+@@ -119,14 +119,20 @@
+ RemapLevelNames(iLevelNext);
+
+ // first encounter
+- if(iLevel == -1) {
++ if((iLevel == -1) && (_pNetwork->md_strGameID == "serioussam") ) {
+ strLevelName.ScanF("%02d_", &iLevel);
+ strNextLevelName.ScanF("%02d_", &iLevelNext);
+
+- if(iLevel != -1) {
++ /*if(iLevel != -1) {
+ map_bIsFirstEncounter = TRUE;
+ }
+ } else {
++ map_bIsFirstEncounter = FALSE;*/
++ }
++
++ if(_pNetwork->md_strGameID == "serioussam") {
++ map_bIsFirstEncounter = TRUE;
++ } else {
+ map_bIsFirstEncounter = FALSE;
+ }
+
+--- a/SamTSE/Sources/GameMP/LoadingHook.cpp 2023-06-04 21:21:47.000000000 +0300
++++ b/SamTSE/Sources/GameMP/LoadingHook.cpp 2023-07-07 11:29:23.589269179 +0300
+@@ -119,14 +119,20 @@
+ RemapLevelNames(iLevelNext);
+
+ // first encounter
+- if(iLevel == -1) {
++ if((iLevel == -1) && (_pNetwork->md_strGameID == "serioussam") ) {
+ strLevelName.ScanF("%02d_", &iLevel);
+ strNextLevelName.ScanF("%02d_", &iLevelNext);
+
+- if(iLevel != -1) {
++ /*if(iLevel != -1) {
+ map_bIsFirstEncounter = TRUE;
+ }
+ } else {
++ map_bIsFirstEncounter = FALSE;*/
++ }
++
++ if(_pNetwork->md_strGameID == "serioussam") {
++ map_bIsFirstEncounter = TRUE;
++ } else {
+ map_bIsFirstEncounter = FALSE;
+ }
+
diff --git a/PKGBUILD b/PKGBUILD
index 692125daba52..2f9d57cbd00c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgname=serioussam
pkginstdir=serioussam
pkgver=1.10.5
_srcname="SeriousSamClassic-$pkgver"
-pkgrel=3
+pkgrel=4
pkgdesc="Serious Sam Classic native Linux version."
arch=('i686' 'x86_64')
url="https://github.com/tx00100xt/SeriousSamClassic"
@@ -19,13 +19,15 @@ source=("https://github.com/tx00100xt/SeriousSamClassic/archive/refs/tags/v$pkgv
"serioussam-tse.desktop"
"serioussam.xpm"
"0001-remove_SE1_10b_depend.patch"
- "0002-Fixed_Platform_definition.patch")
+ "0002-Fixed_Platform_definition.patch"
+ "0003-Fix-load-some-incorrect-custom-maps.patch")
sha256sums=('ecd850cabd144b29bcec97de4ad8a1ffc14144432744de9bf39fe1d00385daf6'
'1e36d7b0d11f68729aa5c79ac9a44157d4af0bf61060040ab92a37d96ca89aba'
'49680c65d26b264a1d7735c6310fcc5d0ac0e0e56273d3bccf539c0c87d31b2b'
'1fd56e04072372e1e8dab0bae40da1519d82a28895cbe5661b18561ee9ea47b4'
'244101d02598010e4c45e57f26e0842d4cff058e3cde5e59062b9d36b5ffaca0'
- '21100e7993892d5ac7b4d44b87cf29d47afac5bfbc0e39c2777a3e0dc813dbd2')
+ '21100e7993892d5ac7b4d44b87cf29d47afac5bfbc0e39c2777a3e0dc813dbd2'
+ '36b0c4da5133ef5dcdcfd21767c84f7b3e9711413549b565957a734e549ee300')
if [[ $CARCH = "i686" ]]; then
_bits="32"
else
@@ -36,6 +38,7 @@ prepare(){
# Prepare patch
cat 0001-remove_SE1_10b_depend.patch > "$srcdir/$_srcname/0001-remove_SE1_10b_depend.patch"
cat 0002-Fixed_Platform_definition.patch > "$srcdir/$_srcname/0002-Fixed_Platform_definition.patch"
+ cat 0003-Fix-load-some-incorrect-custom-maps.patch > "$srcdir/$_srcname/0003-Fix-load-some-incorrect-custom-maps.patch"
# Making building TFE scripts.
cd "$srcdir/$_srcname/SamTFE/Sources/"
@@ -52,6 +55,7 @@ prepare(){
# apply patch
patch -p1 < 0001-remove_SE1_10b_depend.patch || return 1
patch -p1 < 0002-Fixed_Platform_definition.patch || return 1
+ patch -p1 < 0003-Fix-load-some-incorrect-custom-maps.patch || return 1
}
build(){