diff options
author | tx00100xt | 2023-06-01 21:11:51 +0300 |
---|---|---|
committer | tx00100xt | 2023-06-01 21:11:51 +0300 |
commit | feab1d3ce29ddaa32411538bfd9812d577462c4e (patch) | |
tree | 8c948037460eaeffce4305644e5ce14f3660e1b3 | |
parent | 981f3ba68178b4b656ceab001580a791b2b182a9 (diff) | |
download | aur-feab1d3ce29ddaa32411538bfd9812d577462c4e.tar.gz |
Addded patch for fix library path
-rw-r--r-- | .SRCINFO | 2 | ||||
-rw-r--r-- | PKGBUILD | 2 | ||||
-rw-r--r-- | arch_linux_libraries_path.patch | 34 |
3 files changed, 36 insertions, 2 deletions
@@ -1,7 +1,7 @@ pkgbase = serioussam pkgdesc = Serious Sam Classic native Linux version with XPLUS Modification. pkgver = 1.10.4 - pkgrel = 7 + pkgrel = 8 url = https://github.com/tx00100xt/SeriousSamClassic arch = i686 arch = x86_64 @@ -7,7 +7,7 @@ xplus_tfe=SamTFE-XPLUS.tar.xz xplus_tse=SamTSE-XPLUS.tar.xz pkgver=1.10.4 _srcname="SeriousSamClassic-$pkgver" -pkgrel=7 +pkgrel=8 pkgdesc="Serious Sam Classic native Linux version with XPLUS Modification." arch=('i686' 'x86_64') url="https://github.com/tx00100xt/SeriousSamClassic" diff --git a/arch_linux_libraries_path.patch b/arch_linux_libraries_path.patch new file mode 100644 index 000000000000..68235c6df672 --- /dev/null +++ b/arch_linux_libraries_path.patch @@ -0,0 +1,34 @@ +--- a/SamTFE/Sources/Engine/Engine.cpp 2023-06-01 20:23:35.433010942 +0300 ++++ b/SamTFE/Sources/Engine/Engine.cpp 2023-06-01 20:27:29.016031099 +0300 +@@ -743,13 +743,7 @@ + + // get library path for mods + _fnmModLibPath = ""; +- if( sys_iSysPath == 1 && sys_iGameBits == 64 && _pFileSystem->IsDirectory((const char *) "/usr/lib/x86_64-linux-gnu")) { +- _fnmModLibPath = "/usr/lib/x86_64-linux-gnu/" + strGameID + "/"; +- } else if( sys_iSysPath == 1 && sys_iGameBits == 32 && _pFileSystem->IsDirectory((const char *) "/usr/lib/i386-linux-gnu")) { +- _fnmModLibPath = "/usr/lib/i386-linux-gnu/" + strGameID + "/"; +- } else if( sys_iSysPath == 1 && sys_iGameBits == 64 && _pFileSystem->IsDirectory((const char *) "/usr/lib64")) { +- _fnmModLibPath = "/usr/lib64/" + strGameID + "/"; +- } else if( sys_iSysPath == 1 && sys_iGameBits == 32 && _pFileSystem->IsDirectory((const char *) "/usr/lib")) { ++ if( sys_iSysPath == 1 ) { + _fnmModLibPath = "/usr/lib/" + strGameID + "/"; + } else { + _fnmModLibPath = _fnmApplicationPath; +--- a/SamTSE/Sources/Engine/Engine.cpp 2023-06-01 20:23:35.433010942 +0300 ++++ b/SamTSE/Sources/Engine/Engine.cpp 2023-06-01 20:27:29.016031099 +0300 +@@ -743,13 +743,7 @@ + + // get library path for mods + _fnmModLibPath = ""; +- if( sys_iSysPath == 1 && sys_iGameBits == 64 && _pFileSystem->IsDirectory((const char *) "/usr/lib/x86_64-linux-gnu")) { +- _fnmModLibPath = "/usr/lib/x86_64-linux-gnu/" + strGameID + "/"; +- } else if( sys_iSysPath == 1 && sys_iGameBits == 32 && _pFileSystem->IsDirectory((const char *) "/usr/lib/i386-linux-gnu")) { +- _fnmModLibPath = "/usr/lib/i386-linux-gnu/" + strGameID + "/"; +- } else if( sys_iSysPath == 1 && sys_iGameBits == 64 && _pFileSystem->IsDirectory((const char *) "/usr/lib64")) { +- _fnmModLibPath = "/usr/lib64/" + strGameID + "/"; +- } else if( sys_iSysPath == 1 && sys_iGameBits == 32 && _pFileSystem->IsDirectory((const char *) "/usr/lib")) { ++ if( sys_iSysPath == 1 ) { + _fnmModLibPath = "/usr/lib/" + strGameID + "/"; + } else { + _fnmModLibPath = _fnmApplicationPath; |