summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortx00100xt2022-06-24 13:30:02 +0300
committertx00100xt2022-06-24 13:30:02 +0300
commit191e90424657da96977c65681939f757e3e00950 (patch)
tree713bde51c4dffce08753c0c1848c454fa242644e
parent48103c1efd83bc09a25945fe7f1a4623bb5b0329 (diff)
downloadaur-191e90424657da96977c65681939f757e3e00950.tar.gz
Update
-rwxr-xr-x.SRCINFO2
-rwxr-xr-xPKGBUILD12
2 files changed, 12 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dd1a7915440e..6dfaab7c1be9 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = serioussam-oddworld
- pkgdesc = Serious Sam Classic Odd World native Linux.
+ pkgdesc = Serious Sam Classic Odd World native Linux
pkgver = 0.20
pkgrel = 1
url = https://github.com/tx00100xt/SE1-TFE-OddWorld
diff --git a/PKGBUILD b/PKGBUILD
index 9638e3b0d28a..103f4e60a404 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,17 @@ pkgdesc="Serious Sam Classic Odd World native Linux."
arch=('i686' 'x86_64')
url="https://github.com/tx00100xt/SE1-TFE-OddWorld"
license=('GPL2')
-depends=('sdl2' 'python' 'bash')
+
+if pacman -Qq serioussam >/dev/null 2>&1; then
+ depends=('sdl2' 'python' 'bash' 'serioussam')
+elif pacman -Qq serioussam-vk >/dev/null 2>&1; then
+ depends=('sdl2' 'python' 'bash' 'serioussam-vk')
+else
+ echo "This package requires either "serioussam" or "serioussam-vk", but neither is installed."
+ echo "Compilation aborted."
+ return 1
+fi
+
makedepends=('cmake' 'make' 'sed')
source=("https://github.com/tx00100xt/SE1-TFE-OddWorld/archive/refs/tags/v$pkgver.tar.gz"
"https://github.com/tx00100xt/serioussam-mods/raw/main/SamTFE-OddWorld/SamTFE-OddWorld.tar.xz.partaa"