summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMio Nekoya2024-02-22 06:17:46 +0900
committerMio Nekoya2024-02-22 06:17:46 +0900
commit8037d157b64b160836529fe78303b746084378e2 (patch)
tree9335bd6b89dedb92f87265a4f2e3f2522fd6c7d4
downloadaur-8037d157b64b160836529fe78303b746084378e2.tar.gz
First build
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD53
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1f507f901ff2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = serve-bin
+ pkgdesc = A quick solution to serving static folder
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/tabbybox/serve
+ arch = x86_64
+ license = MIT
+ source = serve-0.1.0-1::https://github.com/tabbybox/serve/releases/download/v0.1.0/serve-linux-amd64
+ sha256sums = 10d2952a9fd974e7f474f2dc4a3cd3147d238edd289a01f6262fb3da6704376f
+
+pkgname = serve-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..82c8faa0329f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Mio Nekoya <mio9 at tabbybox.art>
+pkgname=serve-bin
+pkgver=0.1.0
+pkgrel=1
+epoch=
+pkgdesc="A quick solution to serving static folder"
+arch=('x86_64')
+url="https://github.com/tabbybox/serve"
+license=('MIT')
+groups=()
+depends=()
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("serve-$pkgver-$pkgrel::https://github.com/tabbybox/serve/releases/download/v0.1.0/serve-linux-amd64")
+noextract=()
+sha256sums=("10d2952a9fd974e7f474f2dc4a3cd3147d238edd289a01f6262fb3da6704376f")
+validpgpkeys=()
+
+#prepare() {
+#cd "$pkgname-$pkgver"
+# echo "prepare running"
+# ls
+# patch -p1 -i "$srcdir/$pkgname-$pkgver.patch"
+#}
+
+#build() {
+# echo "building"
+#cd "$pkgname-$pkgver"
+
+#./configure --prefix=/usr
+#make
+#}
+
+#check() {
+# echo "checking"
+#cd "$pkgname-$pkgver"
+#make -k check
+#}
+
+package() {
+ mkdir -p "${pkgdir}/usr/bin"
+ mv "${srcdir}/serve-${pkgver}-${pkgrel}" "${pkgdir}/usr/bin/serve"
+ chmod +x "${pkgdir}/usr/bin/serve"
+ #make DESTDIR="$pkgdir/" install
+}