summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShootingStarDragons2023-10-13 11:31:43 +0800
committerShootingStarDragons2023-10-13 11:31:43 +0800
commitc50c7d0b740064dee789ade5d35c93e034a99917 (patch)
tree8754851659a7282f4af6f1dfe271b4df297fab77
downloadaur-session-lock-qt-git.tar.gz
chore: init
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD32
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..522b4f93bd89
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = session-lock-qt-git
+ pkgdesc = session-lock-qt
+ pkgver = r36.8c631fb
+ pkgrel = 1
+ url = https://github.com/waycrate/qt-session-lock
+ arch = x86_64
+ arch = aarch64
+ license = GPL
+ makedepends = git
+ makedepends = ninja
+ makedepends = cmake
+ makedepends = wayland-protocols
+ depends = qt6-wayland
+ provides = session-lock-qt
+ conflicts = session-lock-qt
+ source = session-lock-qt::git+https://github.com/waycrate/qt-session-lock.git
+ sha256sums = SKIP
+
+pkgname = session-lock-qt-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..40f2091fa544
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+_pkgname=session-lock-qt
+pkgname=session-lock-qt-git
+pkgver=r36.8c631fb
+pkgrel=1
+pkgdesc="session-lock-qt"
+url="https://github.com/waycrate/qt-session-lock"
+arch=('x86_64' 'aarch64')
+license=('GPL')
+makedepends=('git' 'ninja' 'cmake' 'wayland-protocols')
+depends=(qt6-wayland)
+provides=('session-lock-qt')
+conflicts=('session-lock-qt')
+source=("${_pkgname}::git+${url}.git")
+sha256sums=('SKIP')
+
+build() {
+ cd "${_pkgname}"
+ cmake -GNinja \
+ -DQT_PLUGIN_INSTALL_DIR=/usr/lib/qt6/plugins/ \
+ -DCMAKE_INSTALL_PREFIX=/usr .
+ ninja
+}
+
+package() {
+ cd "${_pkgname}"
+ DESTDIR="$pkgdir" ninja install
+}
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
+}