summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkaptoxic2016-05-03 12:28:31 -0400
committerkaptoxic2016-05-03 12:28:31 -0400
commited7275000dada5412ea4241ffd029303a0aa5736 (patch)
treed4a5bebd45bc0dbe4759bd92e32f2c66cd9d6a69
downloadaur-ed7275000dada5412ea4241ffd029303a0aa5736.tar.gz
Revive original package
-rw-r--r--.SRCINFO17
-rw-r--r--LICENSE38
-rw-r--r--PKGBUILD28
3 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..defd7e6ed861
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Tue May 3 16:28:27 UTC 2016
+pkgbase = setlx
+ pkgdesc = Interpreter for the SetlX programming language
+ pkgver = 2.3.4
+ pkgrel = 1
+ url = http://randoom.org/Software/SetlX
+ arch = any
+ license = BSD
+ depends = java-runtime
+ source = http://download.randoom.org/setlX/pc/setlX_v2-3-4.binary_only.zip
+ source = LICENSE
+ sha256sums = 81e3172a3ebee4a32f44818088145cad8f8b639d3556197d21ecfb3bbfb8d08b
+ sha256sums = c4ac68ea51527f7cc2859cac9f2fed74e9072fb7595a08d3f958cc2aa5fb99e5
+
+pkgname = setlx
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..3c9bbd5c17b3
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,38 @@
+You may distribute setlX under the terms of the BSD license,
+which is stated at the end of this document.
+
+This program uses the ANTLR parser generator in version 4.4,
+which is also licensed under the BSD license
+(see src/antlr/antlr_LICENSE.txt).
+
+[The "BSD license"]
+Copyright (c) 2011-2014, Tom Herrmann
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or
+without modification, are permitted provided that the following
+conditions are met:
+
+1. Redistributions of source code must retain the above
+ copyright notice, this list of conditions and the following
+ disclaimer.
+2. Redistributions in binary form must reproduce the above
+ copyright notice, this list of conditions and the following
+ disclaimer in the documentation and/or other materials
+ provided with the distribution.
+3. The name of the author may not be used to endorse or
+ promote products derived from this software without
+ specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE AUTHOR ‘‘ AS IS ’’ AND ANY
+EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
+THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
+PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR
+BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
+EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED
+TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
+ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING
+IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF
+THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..727c472e14a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id$
+# Maintainer: Thomas Lange <thomas-lange2@gmx.de>
+
+pkgname=setlx
+pkgver=2.3.4
+pkgrel=1
+pkgdesc='Interpreter for the SetlX programming language'
+arch=('any')
+url='http://randoom.org/Software/SetlX'
+license=('BSD')
+depends=('java-runtime')
+source=(http://download.randoom.org/setlX/pc/setlX_v${pkgver//./-}.binary_only.zip
+ LICENSE)
+sha256sums=('81e3172a3ebee4a32f44818088145cad8f8b639d3556197d21ecfb3bbfb8d08b'
+ 'c4ac68ea51527f7cc2859cac9f2fed74e9072fb7595a08d3f958cc2aa5fb99e5')
+
+package() {
+ sed -i 's|"."|"/usr/share/java/setlx/"|' setlX
+
+ install -D -m755 setlX "${pkgdir}/usr/bin/${pkgname}"
+ install -D -m644 setlX.jar "${pkgdir}/usr/share/java/${pkgname}/setlX.jar"
+ install -D -m644 setlX-gfx.jar "${pkgdir}/usr/share/java/${pkgname}/setlX-gfx.jar"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m644 manual.pdf "${pkgdir}/usr/share/doc/${pkgname}/manual.pdf"
+ install -D -m644 tutorial.pdf "${pkgdir}/usr/share/doc/${pkgname}/tutorial.pdf"
+ install -D -m644 syntax_highlighting/gedit_GtkSourceView/setlx.lang \
+ "${pkgdir}/usr/share/gtksourceview-3.0/language-specs/setlx.lang"
+}