summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2017-08-20 14:59:10 +0200
committerNicolas Iooss2017-08-20 14:59:10 +0200
commit17b1046f8d1a3102c8fdd93ff6be51b4e504bf11 (patch)
tree2280543794d14d232ec71382c5d1d65c8ddbfa9e
parente80f0d8ff41eb71b277680c5b08ff1964d85d7a4 (diff)
downloadaur-17b1046f8d1a3102c8fdd93ff6be51b4e504bf11.tar.gz
setools 4.1.1-2: include qpol.py in Python2 installed files
in "setup.py build", setools/policyrep/qpol.py is generated after that the Python files are copied to the build directory (build_ext is executed after build_by). Therefore /usr/lib/python2.7/site-packages/setools/policyrep/qpol.py is not installed, which causes applications like system-config-selinux to fail to load. Fix this by always running "setup.py build_ext" before build. Upstream issue: https://github.com/TresysTechnology/setools/issues/173
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2404e3a0151e..d9933e621115 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = setools
pkgdesc = Policy analysis tools for SELinux
pkgver = 4.1.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/TresysTechnology/setools/wiki
arch = i686
arch = x86_64
@@ -28,7 +28,7 @@ pkgbase = setools
optdepends = python2-enum34: Python2 support
optdepends = python2-networkx: Python2 support
optdepends = qt5-tools: display apol help with Qt Assistant
- provides = selinux-setools=4.1.1-1
+ provides = selinux-setools=4.1.1-2
conflicts = selinux-setools
source = setools-4.1.1.tar.gz::https://github.com/TresysTechnology/setools/archive/4.1.1.tar.gz
sha256sums = 46a927ea2b163cbe1d35cc35da43e45853e13720c7e02d4cf75a498783c19610
diff --git a/PKGBUILD b/PKGBUILD
index f68ccf7ec28b..f25d805adc74 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,7 @@
pkgname=setools
pkgver=4.1.1
-pkgrel=1
+pkgrel=2
pkgdesc="Policy analysis tools for SELinux"
groups=('selinux')
arch=('i686' 'x86_64')
@@ -52,7 +52,9 @@ prepare() {
build() {
cd "${pkgname}-${pkgver}"
+ python2 setup.py build_ext
python2 setup.py build
+ python setup.py build_ext
python setup.py build
}