summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2017-01-23 20:13:09 +0100
committerNicolas Iooss2017-01-23 20:13:09 +0100
commit3a67ea6522f46f0944cc0e9616a2b5a7f57de2a0 (patch)
tree19f4459a76404aded6019956fce4bd4e66ebaa2c
parentebc663b302c39ff453c124c03efede70af9096d5 (diff)
downloadaur-3a67ea6522f46f0944cc0e9616a2b5a7f57de2a0.tar.gz
setools: fix build with flex 2.6.3
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a46f6e35b13b..3c88676cc68a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = setools
pkgdesc = Policy analysis tools for SELinux
pkgver = 4.0.1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/TresysTechnology/setools/wiki
arch = i686
arch = x86_64
@@ -25,7 +25,7 @@ pkgbase = setools
optdepends = python-pyqt5: needed for graphical tools
optdepends = python2: Python2 support
optdepends = python2-networkx: Python2 support
- provides = selinux-setools=4.0.1-2
+ provides = selinux-setools=4.0.1-3
conflicts = selinux-setools
source = setools-4.0.1.tar.gz::https://github.com/TresysTechnology/setools/archive/4.0.1.tar.gz
sha256sums = 4c2049877f2f68e4485b72bc280fe20127b49a019169a2cf1d8295c908bdcdfe
diff --git a/PKGBUILD b/PKGBUILD
index 532021488023..bfe2f0a875df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,7 @@
pkgname=setools
pkgver=4.0.1
-pkgrel=2
+pkgrel=3
pkgdesc="Policy analysis tools for SELinux"
groups=('selinux')
arch=('i686' 'x86_64')
@@ -38,14 +38,14 @@ sha256sums=('4c2049877f2f68e4485b72bc280fe20127b49a019169a2cf1d8295c908bdcdfe')
prepare() {
cd "${pkgname}-${pkgver}"
- # Flex 2.6.1 generates C code which causes -Wsign-compare to trigger:
- # libqpol/policy_scan.c: In function ‘yy_scan_bytes’:
- # libqpol/policy_scan.c:3254:17: warning: comparison between signed and
- # unsigned integer expressions [-Wsign-compare]
- # for ( i = 0; i < _yybytes_len; ++i )
- # ^
+ # Flex 2.6.3 generates C code which causes -Werror to trigger:
+ # libqpol/policy_scan.c:398:0: error: "yywrap" redefined [-Werror]
+ # #define yywrap() (/*CONSTCOND*/1)
+ # libqpol/policy_scan.c:74:0: note: this is the location of the previous definition
+ # #define yywrap yywrap
+ # This a a bug in Flex, https://github.com/westes/flex/issues/155
# Do not make the build fail because of this
- sed -e "s/\('-Werror',\)/\1 '-Wno-error=sign-compare',/" -i setup.py
+ sed -e "s/'-Werror',//" -i setup.py
}
build() {