summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2024-04-14 22:33:07 +0200
committerNicolas Iooss2024-04-14 22:33:07 +0200
commit8f862e9df1da4ae5dc7bfd852df1f24771a7ed28 (patch)
treec339f170d5a2a9e712d2e54894d6378545587ba5
parent87431d505260a559e407c555f19b0df81cff7671 (diff)
downloadaur-8f862e9df1da4ae5dc7bfd852df1f24771a7ed28.tar.gz
setools 4.5.0-1 update
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD20
2 files changed, 23 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ad62001977e..8f9ffb7953a2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = setools
pkgdesc = Policy analysis tools for SELinux
- pkgver = 4.4.4
+ pkgver = 4.5.0
pkgrel = 1
url = https://github.com/SELinuxProject/setools/wiki
arch = i686
@@ -10,18 +10,20 @@ pkgbase = setools
license = GPL
license = LGPL
checkdepends = checkpolicy
+ checkdepends = python-pytest
makedepends = cython
makedepends = python-tox
depends = libsepol>=3.2
depends = libselinux>=3.2
depends = python
- depends = python-networkx>=2.0
+ depends = python-networkx>=2.6
depends = python-setuptools
- optdepends = python-pyqt5: needed for graphical tools
- optdepends = qt5-tools: display apol help with Qt Assistant
- provides = selinux-setools=4.4.4-1
+ optdepends = python-graphviz: for seinfoflow, sedta, apol
+ optdepends = python-pyqt6: needed for graphical tools
+ optdepends = qt6-tools: display apol help with Qt Assistant
+ provides = selinux-setools=4.5.0-1
conflicts = selinux-setools
- source = https://github.com/SELinuxProject/setools/releases/download/4.4.4/setools-4.4.4.tar.bz2
- sha256sums = 3c5fa76a674fe3f6890d900df59b9d142e4b63c9ffbde653904f90ed6e666ef9
+ source = https://github.com/SELinuxProject/setools/releases/download/4.5.0/setools-4.5.0.tar.bz2
+ sha256sums = 68469ae9bd114b42bba4cb41795577ca1e4f50e3e4234817f13ff1a8bbd9ce77
pkgname = setools
diff --git a/PKGBUILD b/PKGBUILD
index dc6c3b182b84..b185e1fc2860 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,22 +18,30 @@
# - replace setools 3.3.8 with setools3-libs and install setools then.
pkgname=setools
-pkgver=4.4.4
+pkgver=4.5.0
pkgrel=1
pkgdesc="Policy analysis tools for SELinux"
groups=('selinux')
arch=('i686' 'x86_64' 'aarch64')
url="https://github.com/SELinuxProject/setools/wiki"
license=('GPL' 'LGPL')
-depends=('libsepol>=3.2' 'libselinux>=3.2' 'python' 'python-networkx>=2.0' 'python-setuptools')
-optdepends=('python-pyqt5: needed for graphical tools'
- 'qt5-tools: display apol help with Qt Assistant')
+depends=('libsepol>=3.2' 'libselinux>=3.2' 'python' 'python-networkx>=2.6' 'python-setuptools')
+optdepends=('python-graphviz: for seinfoflow, sedta, apol'
+ 'python-pyqt6: needed for graphical tools'
+ 'qt6-tools: display apol help with Qt Assistant')
makedepends=('cython' 'python-tox')
-checkdepends=('checkpolicy')
+checkdepends=('checkpolicy' 'python-pytest')
conflicts=("selinux-${pkgname}")
provides=("selinux-${pkgname}=${pkgver}-${pkgrel}")
source=("https://github.com/SELinuxProject/setools/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.bz2")
-sha256sums=('3c5fa76a674fe3f6890d900df59b9d142e4b63c9ffbde653904f90ed6e666ef9')
+sha256sums=('68469ae9bd114b42bba4cb41795577ca1e4f50e3e4234817f13ff1a8bbd9ce77')
+
+prepare() {
+ cd "${pkgname}"
+
+ # Fix https://github.com/SELinuxProject/setools/issues/124
+ sed "s/package_data={'': \['\*\.html'\],/package_data={'': ['*.html', '*.css'],/" -i setup.py
+}
build() {
cd "${pkgname}"