summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2020-12-05 17:43:50 +0100
committerNicolas Iooss2020-12-05 17:43:50 +0100
commitd513821eac5e5261626401998249d0179d3143ab (patch)
treea5f6d4069cae76c18675ffcb79d0aeff6aa3060a
parentccc02813e1e0cd01e9dcdfa8d3802d378a685ea4 (diff)
downloadaur-d513821eac5e5261626401998249d0179d3143ab.tar.gz
setools 4.3.0-2 update: Python 3.9 rebuild
-rw-r--r--.SRCINFO6
-rw-r--r--0001-Disable-deprecated-function-warnings-to-fix-build-wi.patch26
-rw-r--r--PKGBUILD15
3 files changed, 42 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 496d0bc43ddf..16a8bf0a84e7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = setools
pkgdesc = Policy analysis tools for SELinux
pkgver = 4.3.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/SELinuxProject/setools/wiki
arch = i686
arch = x86_64
@@ -18,10 +18,12 @@ pkgbase = setools
depends = python-setuptools
optdepends = python-pyqt5: needed for graphical tools
optdepends = qt5-tools: display apol help with Qt Assistant
- provides = selinux-setools=4.3.0-1
+ provides = selinux-setools=4.3.0-2
conflicts = selinux-setools
source = https://github.com/SELinuxProject/setools/releases/download/4.3.0/setools-4.3.0.tar.bz2
+ source = 0001-Disable-deprecated-function-warnings-to-fix-build-wi.patch
sha256sums = 315df3ae0eb29b399123c5e3330480c5d1c0da038671c9fd62a439c49a6f9105
+ sha256sums = 95973be9faf3380986b0cf5969b9e28d1ba4d8eea7d78e24786c49871977cd40
pkgname = setools
diff --git a/0001-Disable-deprecated-function-warnings-to-fix-build-wi.patch b/0001-Disable-deprecated-function-warnings-to-fix-build-wi.patch
new file mode 100644
index 000000000000..b2c55ffd37de
--- /dev/null
+++ b/0001-Disable-deprecated-function-warnings-to-fix-build-wi.patch
@@ -0,0 +1,26 @@
+From 6c7238fcd0eca358686076d4db940d67a509e303 Mon Sep 17 00:00:00 2001
+From: Nicolas Iooss <nicolas.iooss@m4x.org>
+Date: Sat, 5 Dec 2020 17:24:51 +0100
+Subject: [PATCH 1/1] Disable deprecated function warnings to fix build with
+ Cython 0.29.21 and Python 3.9
+
+Fixes: https://github.com/SELinuxProject/setools/issues/54
+---
+ setup.py | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/setup.py b/setup.py
+index 457c83049ca5..0f717c5a1d0b 100644
+--- a/setup.py
++++ b/setup.py
+@@ -126,6 +126,7 @@ ext_py_mods = [Extension('setools.policyrep', ['setools/policyrep.pyx'],
+ '-Wno-unreachable-code',
+ '-Wno-implicit-fallthrough',
+ '-Wno-cast-function-type',
++ '-Wno-error=deprecated-declarations',
+ '-fno-exceptions'])]
+
+ installed_data = [('share/man/man1', glob.glob("man/*.1"))]
+--
+2.29.2
+
diff --git a/PKGBUILD b/PKGBUILD
index 5a4426378cf6..0a4e2ccfb6ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,7 +19,7 @@
pkgname=setools
pkgver=4.3.0
-pkgrel=1
+pkgrel=2
pkgdesc="Policy analysis tools for SELinux"
groups=('selinux')
arch=('i686' 'x86_64')
@@ -32,8 +32,17 @@ makedepends=('cython' 'python-tox')
checkdepends=('checkpolicy')
conflicts=("selinux-${pkgname}")
provides=("selinux-${pkgname}=${pkgver}-${pkgrel}")
-source=("https://github.com/SELinuxProject/setools/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.bz2")
-sha256sums=('315df3ae0eb29b399123c5e3330480c5d1c0da038671c9fd62a439c49a6f9105')
+source=("https://github.com/SELinuxProject/setools/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.bz2"
+ '0001-Disable-deprecated-function-warnings-to-fix-build-wi.patch')
+sha256sums=('315df3ae0eb29b399123c5e3330480c5d1c0da038671c9fd62a439c49a6f9105'
+ '95973be9faf3380986b0cf5969b9e28d1ba4d8eea7d78e24786c49871977cd40')
+
+prepare() {
+ cd "${pkgname}"
+ # Fix compatibility issues with Cython 0.29.21 and Python 3.9
+ # https://github.com/SELinuxProject/setools/issues/54
+ patch -Np1 -i ../0001-Disable-deprecated-function-warnings-to-fix-build-wi.patch
+}
build() {
cd "${pkgname}"