summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmile Pesik2015-07-08 14:14:38 +0100
committerEmile Pesik2015-07-08 14:14:38 +0100
commit0c5a7db905b962d3b1efa9fea05dace273397559 (patch)
tree4603b9daca3ca9c0b38ba57eaf833a1e4d9d0381
downloadaur-setpwc.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
-rw-r--r--setpwc.install9
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4ab337bd0d7c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = setpwc
+ pkgdesc = Set various aspects of Philips (and compatible) webcams.
+ pkgver = 1.3
+ pkgrel = 2
+ url = http://www.vanheusden.com/setpwc/
+ install = setpwc.install
+ arch = any
+ license = GPL2
+ optdepends = gtksetpwc: GTK2 frontend for setpwc
+ source = http://www.vanheusden.com/setpwc/setpwc-1.3.tgz
+ md5sums = 79d5ee468c0076feb3cac473bef661d2
+
+pkgname = setpwc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4b95bba4dff5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Emile Pesik <ristridin [at] gmail [dot] com>
+# Contributor Todd Maynard <arch [at] toddmaynard [dot] com>
+pkgname=setpwc
+pkgver=1.3
+pkgrel=2
+pkgdesc="Set various aspects of Philips (and compatible) webcams."
+url="http://www.vanheusden.com/setpwc/"
+license=('GPL2')
+optdepends=('gtksetpwc: GTK2 frontend for setpwc')
+arch=('any')
+install=setpwc.install
+source=(http://www.vanheusden.com/$pkgname/$pkgname-$pkgver.tgz)
+md5sums=('79d5ee468c0076feb3cac473bef661d2')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ make || return 1
+ }
+
+package() {
+ #make DESTDIR=$pkgdir install
+ #The Makefile has a hardcoded destination so we will install the binary manually instead
+ cd $srcdir/$pkgname-$pkgver
+ install -D -m 755 setpwc $pkgdir/usr/bin/setpwc
+ }
diff --git a/setpwc.install b/setpwc.install
new file mode 100644
index 000000000000..8c39978de4b9
--- /dev/null
+++ b/setpwc.install
@@ -0,0 +1,9 @@
+# This is a default template for a post-install scriptlet.
+# Uncomment only required functions and remove any functions
+# you don't need (and this header).
+
+post_install() {
+ echo
+ echo "Type 'setpwc -h' for options"
+ echo
+}