summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhoutim2017-01-23 22:56:59 -0800
committerzhoutim2017-01-23 22:56:59 -0800
commitf0bffe15bd50b625e75310d011c826d6fe80f11a (patch)
treea6af74a7781d4e303e6e4976cb86e66580b9d308
parentc405912b57b25111b22bb0adc662615dc311919b (diff)
downloadaur-f0bffe15bd50b625e75310d011c826d6fe80f11a.tar.gz
setroot is now the only package; updated version, no longer out-of-date
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 03411c867720..e16b31e8c7c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = setroot
pkgdesc = simple program that sets your (X11) wallpaper. inspired by the *setroots and feh.
- pkgver = v1.5
+ pkgver = v2.0.g16b07b3
pkgrel = 1
url = https://github.com/ttzhou/setroot
install = setroot.install
@@ -15,7 +15,7 @@ pkgbase = setroot
optdepends = libxinerama: for multiple monitors
provides = setroot
conflicts = setroot
- source = git+https://github.com/ttzhou/setroot.git#tag=v1.5
+ source = git+https://github.com/ttzhou/setroot.git
md5sums = SKIP
pkgname = setroot
diff --git a/PKGBUILD b/PKGBUILD
index 36f8f28162e2..38cbaf757254 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=setroot
pkgname=setroot
-pkgver=v1.5
+pkgver=v2.0.g16b07b3
pkgrel=1
pkgdesc="simple program that sets your (X11) wallpaper. inspired by the *setroots and feh."
arch=('i686' 'x86_64')
@@ -15,18 +15,18 @@ optdepends=('sxiv: use its image viewer along with key-handler to call setroot'
'libxinerama: for multiple monitors')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
-source=("git+https://github.com/ttzhou/${_pkgname}.git#tag=${pkgver}")
-install=setroot.install
+source=("git+https://github.com/ttzhou/${_pkgname}.git")
+install='setroot.install'
md5sums=('SKIP')
pkgver() {
cd $_pkgname
- echo $(git describe)
+ echo $(git describe --long | sed 's|-[0-9]\+-|.|g')
}
build() {
cd $_pkgname
- make xinerama=$(pkg-config --exists xinerama && echo 1)
+ make xinerama="$(pkg-config --exists xinerama && echo 1)"
}
package() {