summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoar Heimonen2023-12-11 03:43:25 +0100
committerJoar Heimonen2023-12-11 03:43:25 +0100
commitc3396cbba5c50460eb7649bbee8c02cbe0c3530e (patch)
treef9134b4a0e048700bc8347d2fdc2280e1124daf4
parentcd33b576f7769f2fe00fd65de7ffdbfb953378f9 (diff)
downloadaur-c3396cbba5c50460eb7649bbee8c02cbe0c3530e.tar.gz
Initial PKGBUILD release
-rw-r--r--.SRCINFO35
-rw-r--r--[-rwxr-xr-x]PKGBUILD40
2 files changed, 47 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 23104a7d6afb..abadb421c7f6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,27 @@
-pkgbase = pkgbase
- pkgdesc = simplelock is a simple wayland screen lock. (git version)
- pkgver = 0.0.0
+pkgbase = yuma123-git
+ pkgdesc = Open-source YANG API in C and CLI (yangcli) and server (netconfd)
+ pkgver = 1.0
pkgrel = 1
- url = https://github.com/tgabor7/sl
- arch = any
- license = MIT
- makedepends = git
- source = git+https://github.com/tgabor7/sl.git
- sha512sums = SKIP
+ url = https://github.com/YumaWorks/yuma123
+ arch = x86_64
+ license = BSD
+ depends = git
+ depends = autoconf
+ depends = automake
+ depends = pkg-config
+ depends = gcc
+ depends = libtool
+ depends = libxml2
+ depends = libssh2
+ depends = make
+ depends = ncurses
+ depends = zlib
+ depends = readline
+ depends = openssl
+ depends = openssh
+ provides = yuma123
+ conflicts = yuma123
+ source = git+https://github.com/vlvassilev/yuma123
+ sha256sums = SKIP
-pkgname = simplelock-git
+pkgname = yuma123-git
diff --git a/PKGBUILD b/PKGBUILD
index 836bcd7bd2d2..7c0209210fff 100755..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,35 @@
-# Maintainer: TarkoGabor (@tgabor7)
-pkgname=simplelock
-pkgver=0.0.0
+# Maintainer: Joar Heimonen <joarheimonen@live.no>
+# Note: This is only an install script for Yuma123, not the actual project itself.
+
+pkgname=yuma123-git
+pkgver=latest
pkgrel=1
-pkgdesc="A very simple screen locker for Wayland"
+pkgdesc="Open-source YANG API in C and CLI (yangcli) and server (netconfd)"
arch=('x86_64')
-url="https://github.com/tgabor7/sl"
+url="https://github.com/YumaWorks/yuma123"
license=('BSD')
-depends=('wayland' 'wayland-protocols' 'cargo')
-source=("sl-$pkgver-linux.tar.gz::https://github.com/tgabor7/sl/archive/tags/v$pkgver.tar.gz")
-b2sums=('SKIP')
+depends=('git' 'autoconf' 'automake' 'make' 'gcc')
+makedepends=()
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
-pkgver() {
- cd cbindgen
- git describe --tags | sed 's/^v//;s/[^-]*-g/r&/;s/-/+/g'
-}
+source=("git+https://github.com/vlvassilev/yuma123")
prepare() {
- export RUSTUP_TOOLCHAIN=stable
- cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+ cd "$srcdir/yuma123"
+ autoreconf -i -f
}
build() {
- export RUSTUP_TOOLCHAIN=stable
- export CARGO_TARGET_DIR=target
- cargo build --frozen --release --all-features
+ cd "$srcdir/yuma123"
+ ./configure CFLAGS='-g -O0' CXXFLAGS='-g -O0' --prefix=/usr
+ make
}
package() {
- install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/$pkgname"
+ cd "$srcdir/yuma123"
+ make DESTDIR="${pkgdir}" install
+ mv "${pkgdir}/usr/sbin" "${pkgdir}/usr/bin"
}
+
+sha256sums=('SKIP') \ No newline at end of file