summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNitin Mathew2016-03-12 13:59:58 +0800
committerNitin Mathew2016-03-12 13:59:58 +0800
commit635f4c6e4c9d35ccf86efa335fe8bf4609574148 (patch)
tree1f54d009cfa36277fc27ce4146e9a9597d3b836e
downloadaur-635f4c6e4c9d35ccf86efa335fe8bf4609574148.tar.gz
first commit into the aur git repo
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
-rw-r--r--settimezone.install13
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..275e1dadcbd8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = settimezone
+ pkgdesc = To change the timezone in Arch Linux.
+ pkgver = 0.2.1
+ pkgrel = 3
+ url = https://github.com/nsmathew/settimezone
+ install = settimezone.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = python
+ source = https://github.com/nsmathew/SetTimeZone/archive/v0.2.1.tar.gz
+ sha256sums = a3791910bbfc6cbb90228c89ceb146d699e376df11bd0898b8a73fb78a70de35
+
+pkgname = settimezone
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..69e0b282221b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Nitin Mathew <nitn_mathew2000@hotmail.com>
+
+pkgname=settimezone
+pkgver=0.2.1
+pkgrel=3
+pkgdesc="To change the timezone in Arch Linux."
+
+arch=('i686' 'x86_64')
+url="https://github.com/nsmathew/settimezone"
+license=('GPL3')
+depends=('python')
+makedepends=()
+install=$pkgname.install
+source=(https://github.com/nsmathew/SetTimeZone/archive/v${pkgver}.tar.gz)
+sha256sums=('a3791910bbfc6cbb90228c89ceb146d699e376df11bd0898b8a73fb78a70de35')
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ install -D -m755 sources/settimezone.py ${pkgdir}/usr/bin/settimezone
+ install -D -m644 COPYING ${pkgdir}/usr/share/licenses/settimezone/COPYING
+
+ install -D -m644 resources/settimezone16x16.png ${pkgdir}/usr/share/icons/hicolor/16x16/apps/settimezone.png
+ install -D -m644 resources/settimezone22x22.png ${pkgdir}/usr/share/icons/hicolor/22x22/apps/settimezone.png
+ install -D -m644 resources/settimezone32x32.png ${pkgdir}/usr/share/icons/hicolor/32x32/apps/settimezone.png
+ install -D -m644 resources/settimezone48x48.png ${pkgdir}/usr/share/icons/hicolor/48x48/apps/settimezone.png
+ install -D -m644 resources/settimezone.desktop ${pkgdir}/usr/share/applications/settimezone.desktop
+
+ #Remove the downloaded source
+ cd ../.. && rm -fr v${pkgver}.tar.gz
+}
+
diff --git a/settimezone.install b/settimezone.install
new file mode 100644
index 000000000000..ab2e7110c9ab
--- /dev/null
+++ b/settimezone.install
@@ -0,0 +1,13 @@
+# Maintainer: Nitin Mathew <nitn_mathew2000@hotmail.com>
+
+post_install() {
+ gtk-update-icon-cache -t -f /usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install "$1"
+}
+
+post_remove() {
+ post_install "$1"
+} \ No newline at end of file