summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDang Mai2017-11-22 17:30:56 -0500
committerDang Mai2017-11-22 17:35:06 -0500
commit11031bf8533ed546a1000215ac8b9a4378070aaf (patch)
tree9d8e52af71e3d949c5c869285a3bad237f19fc98
downloadaur-11031bf8533ed546a1000215ac8b9a4378070aaf.tar.gz
Initial version
Add SRCINFO
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD39
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..51b51fc8a49f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = sfdx-cli
+ pkgdesc = a tool for creating and managing Salesforce DX projects from the command line
+ pkgver = 6.0.16_3780698
+ pkgrel = 1
+ url = https://developer.salesforce.com/tools/sfdxcli
+ arch = i686
+ arch = x86_64
+ license = unknown
+ provides = sfdx-cli
+ source_i686 = https://developer.salesforce.com/media/salesforce-cli/sfdx-linux-amd64.tar.xz
+ md5sums_i686 = SKIP
+ source_x86_64 = https://developer.salesforce.com/media/salesforce-cli/sfdx-linux-386.tar.xz
+ md5sums_x86_64 = SKIP
+
+pkgname = sfdx-cli
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..76373c27588e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Dang Mai <contact at dangmai dot net>
+
+pkgname=sfdx-cli
+pkgver=6.0.16_3780698
+pkgrel=1
+_dirname="${pkgname}-v${pkgver}"
+pkgdesc="a tool for creating and managing Salesforce DX projects from the command line"
+arch=('i686' 'x86_64')
+url="https://developer.salesforce.com/tools/sfdxcli"
+license=('unknown')
+optdepends=()
+provides=('sfdx-cli')
+conflicts=()
+source_i686=("https://developer.salesforce.com/media/salesforce-cli/sfdx-linux-amd64.tar.xz")
+source_x86_64=("https://developer.salesforce.com/media/salesforce-cli/sfdx-linux-386.tar.xz")
+
+package() {
+ _arch=""
+ case $CARCH in
+ "x86_64")
+ _arch="x64"
+ ;;
+ "i686")
+ _arch="x86"
+ ;;
+ esac
+
+ cd "${srcdir}"
+
+ install -dm 755 "${pkgdir}"/opt/
+ install -dm 755 "${pkgdir}"/usr/bin
+ pwd
+ install -D sfdx/bin/sfdx "${pkgdir}"/opt/sfdx-cli/sfdx
+
+ # cp -R "${_dirname}-${_arch}" "${pkgdir}"/opt/heroku-cli
+ ln -s /opt/sfdx-cli/sfdx "${pkgdir}"/usr/bin/sfdx
+}
+md5sums_i686=('SKIP')
+md5sums_x86_64=('SKIP')