summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-06-26 10:27:25 +1200
committercaltlgin2020-06-26 10:27:25 +1200
commitc8417ad1dc75fcec07002296b46577be9fa4dc9b (patch)
treed47ce6f13da2bd2262ffabef1e0e283848f7c779
downloadaur-c8417ad1dc75fcec07002296b46577be9fa4dc9b.tar.gz
Add to AUR
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7c5c66030509
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = sfeed-curses-git
+ pkgdesc = Curses UI front-end for sfeed RSS and Atom parser
+ pkgver = 0.1.r0.g239d2c9
+ pkgrel = 1
+ url = https://www.codemadness.org/sfeed_curses-ui.html
+ arch = x86_64
+ license = ISC
+ makedepends = git
+ depends = ncurses
+ optdepends = sfeed: RSS and Atom parser
+ provides = sfeed_curses
+ options = !buildflags
+ source = git://git.codemadness.org/sfeed_curses
+ sha256sums = SKIP
+
+pkgname = sfeed-curses-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..94ca90579e05
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+
+_pkgname=sfeed_curses
+pkgname=sfeed-curses-git
+pkgver=0.1.r0.g239d2c9
+pkgrel=1
+pkgdesc='Curses UI front-end for sfeed RSS and Atom parser'
+arch=('x86_64')
+url='https://www.codemadness.org/sfeed_curses-ui.html'
+license=('ISC')
+depends=('ncurses')
+makedepends=('git')
+optdepends=('sfeed: RSS and Atom parser')
+options=('!buildflags')
+provides=("${_pkgname}")
+source=("git://git.codemadness.org/${_pkgname}")
+sha256sums=('SKIP')
+
+pkgver() {
+ git -C "${_pkgname}" describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ make -C "${_pkgname}"
+}
+
+package() {
+ make DESTDIR="${pkgdir}" PREFIX="/usr" MANPREFIX="/usr/share/man" -C "${_pkgname}" install
+ install -Dm644 "${_pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+}
+
+# vim: ts=2 sw=2 et: