summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJerome Rose2015-08-12 13:25:32 +0000
committerJerome Rose2015-08-12 13:25:32 +0000
commit836f4a0d8686385c2ae935b0cb02eca057a59caa (patch)
tree126026bfb2f9b47794d94a2c9ad0524884431e73
parentc569acd6ec3ddad38564ea7c6878bd051ba16391 (diff)
downloadaur-sfemovie-git.tar.gz
do not use ffmpeg from sfemovie repo, use native arch provided ffmpeg instead
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f01859e0a442..b152df991e1d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sfemovie-git
pkgdesc = sfeMovie is a simple C++ library that lets you play movies in SFML based applications. It relies on FFmpeg to read medias and remains consistent with SFML's naming conventions.
pkgver = 1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Yalir/sfeMovie
arch = x86_64
arch = i686
@@ -11,6 +11,8 @@ pkgbase = sfemovie-git
makedepends = yasm
depends = sfml
depends = ffmpeg
+ provides = sfemovie
+ conflicts = sfemovie
pkgname = sfemovie-git
diff --git a/PKGBUILD b/PKGBUILD
index 8983effa92d6..b285df8b51a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jerome Rose <jrose[dot]pub[at]gmail[dot]com>
pkgname=sfemovie-git
pkgver=1
-pkgrel=1
+pkgrel=2
pkgdesc="sfeMovie is a simple C++ library that lets you play movies in SFML based applications. It relies on FFmpeg to read medias and remains consistent with SFML's naming conventions."
url="https://github.com/Yalir/sfeMovie"
arch=('x86_64' 'i686')
@@ -9,7 +9,8 @@ license=('LGPLv2.1')
depends=('sfml' 'ffmpeg')
optdepends=()
makedepends=('git' 'cmake' 'yasm')
-conflicts=()
+conflicts=('sfemovie')
+provides=('sfemovie')
replaces=()
backup=()
#install='foo.install'
@@ -25,6 +26,7 @@ build() {
cd "${srcdir}/${_pkgnameshort}"
git checkout $_gitbranch
cmake ./ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DSFEMOVIE_BUILD_FFMPEG:BOOL=FALSE \
-DLINK_AGAINST_INTERNAL_FFMPEG:BOOL=FALSE
make
}