summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Pierre Cimalando2020-07-06 14:54:05 +0200
committerJean Pierre Cimalando2020-07-06 14:54:05 +0200
commit112c3e29a38b00a868b84e494c4d6da6db2b19b2 (patch)
tree128e788500c448a2451ab001bfb21c725179e5a9
parent1f6c5ed09c19ab93f41162dba8a25370977f6dd7 (diff)
downloadaur-112c3e29a38b00a868b84e494c4d6da6db2b19b2.tar.gz
Update to add VST / move license
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD9
2 files changed, 16 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 88a7e1ca060d..a14f659b2986 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sfizz-git
pkgdesc = SFZ library and LV2 plugin
- pkgver = r802.4b116e8
+ pkgver = r2043.fa610c1f
pkgrel = 1
url = https://sfz.tools/sfizz
arch = x86_64
@@ -10,6 +10,16 @@ pkgbase = sfizz-git
makedepends = cmake
depends = libsndfile
depends = jack
+ depends = libx11
+ depends = libxcb
+ depends = xcb-util
+ depends = xcb-util-cursor
+ depends = xcb-util-keysyms
+ depends = libxkbcommon
+ depends = libxkbcommon-x11
+ depends = fontconfig
+ depends = cairo
+ depends = freetype2
provides = sfizz
conflicts = sfizz
source = sfizz-git::git+https://github.com/sfztools/sfizz#branch=develop
diff --git a/PKGBUILD b/PKGBUILD
index 68cf6e99f103..be5832482301 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,16 @@
# Maintainer: RedTide <redtid3@gmail.com>
+# Maintainer: Jean Pierre Cimalando <jp-dev@inbox.ru>
_pkgname="sfizz"
pkgname="${_pkgname}-git"
-pkgver=r802.4b116e8
+pkgver=r2043.fa610c1f
pkgrel=1
pkgdesc="SFZ library and LV2 plugin"
url="https://sfz.tools/sfizz"
arch=('x86_64')
license=('custom:BSD-2-Clause' 'custom:ISC')
makedepends=('git' 'cmake')
-depends=('libsndfile' 'jack')
+depends=('libsndfile' 'jack' 'libx11' 'libxcb' 'xcb-util' 'xcb-util-cursor' 'xcb-util-keysyms' 'libxkbcommon' 'libxkbcommon-x11' 'fontconfig' 'cairo' 'freetype2')
provides=('sfizz')
conflicts=('sfizz')
source=("$pkgname"::"git+https://github.com/sfztools/sfizz#branch=develop")
@@ -25,10 +26,10 @@ prepare() {
build() {
mkdir -p build
cd build
- cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX="/usr" "${srcdir}/${pkgname}"
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX="/usr" -DSFIZZ_JACK=ON -DSFIZZ_LV2=ON -DSFIZZ_VST=ON "${srcdir}/${pkgname}"
cmake --build . --target all
}
package() {
DESTDIR="${pkgdir}" cmake --build "${srcdir}/build" --target install
- install -Dm644 "${srcdir}/${pkgname}/LICENSE.md" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+ install -Dm644 "${srcdir}/${pkgname}/LICENSE.md" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}