summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroi_wtf2018-03-27 18:03:45 +0200
committeroi_wtf2018-03-27 18:03:45 +0200
commit1bcfa5b1c744a7c35a2009cecae1d5f30351d052 (patch)
tree099bca0afadd981ed82c0785814fe78f9d5f1845
parentbe596c816592df40ec5bc416a204fc1d0655ea6b (diff)
downloadaur-1bcfa5b1c744a7c35a2009cecae1d5f30351d052.tar.gz
remove unneccessary patch
-rw-r--r--.SRCINFO4
-rw-r--r--0001-fix_cmake_module_install_path.patch12
-rw-r--r--PKGBUILD14
3 files changed, 7 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c701d351b1db..fbcb4015d56c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sfml-git
pkgdesc = A simple, fast, cross-platform, and object-oriented multimedia API
- pkgver = 2.4.0.r37.g858c9ce9
+ pkgver = 2.4.0.r126.gfc655f52
pkgrel = 1
url = http://www.sfml-dev.org/
arch = i686
@@ -22,9 +22,7 @@ pkgbase = sfml-git
replaces = sfml
options = debug
source = git+https://github.com/SFML/SFML.git
- source = 0001-fix_cmake_module_install_path.patch
sha256sums = SKIP
- sha256sums = c0be2636b1d342f636f2587e043dbfa8becdd8d9c65044cf7749ab4b2c81eb47
pkgname = sfml-git
diff --git a/0001-fix_cmake_module_install_path.patch b/0001-fix_cmake_module_install_path.patch
deleted file mode 100644
index f8bbaa021ae6..000000000000
--- a/0001-fix_cmake_module_install_path.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- CMakeLists.txt.orig 2015-01-12 21:34:37.788280159 +0100
-+++ CMakeLists.txt 2015-01-12 21:36:44.646681413 +0100
-@@ -242,7 +242,8 @@
- install(FILES license.txt DESTINATION ${INSTALL_MISC_DIR})
- install(FILES readme.txt DESTINATION ${INSTALL_MISC_DIR})
- if(NOT SFML_OS_ANDROID)
-- install(FILES cmake/Modules/FindSFML.cmake DESTINATION ${INSTALL_MISC_DIR}/cmake/Modules)
-+ set(CM_VER ${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION})
-+ install(FILES cmake/Modules/FindSFML.cmake DESTINATION share/cmake-${CM_VER}/Modules)
- endif()
-
- # install 3rd-party libraries and tools
diff --git a/PKGBUILD b/PKGBUILD
index dda89172335b..982571481437 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: oi_wtf <brainpower at mailbox dot org>
pkgname=sfml-git
-pkgver=2.4.0.r37.g858c9ce9
+pkgver=2.4.0.r126.gfc655f52
pkgrel=1
pkgdesc="A simple, fast, cross-platform, and object-oriented multimedia API"
arch=('i686' 'x86_64')
@@ -14,10 +14,8 @@ conflicts=('sfml')
replaces=('sfml')
options=('debug')
-source=("git+https://github.com/SFML/SFML.git"
- "0001-fix_cmake_module_install_path.patch")
-sha256sums=('SKIP'
- 'c0be2636b1d342f636f2587e043dbfa8becdd8d9c65044cf7749ab4b2c81eb47')
+source=("git+https://github.com/SFML/SFML.git")
+sha256sums=('SKIP')
pkgver() {
cd "${srcdir}/SFML"
@@ -26,7 +24,6 @@ pkgver() {
prepare() {
cd "$srcdir/SFML"
- patch -p0 -i "$srcdir/0001-fix_cmake_module_install_path.patch"
}
build() {
@@ -34,8 +31,9 @@ build() {
cmake -DCMAKE_INSTALL_PREFIX=/usr . \
-DCMAKE_BUILD_TYPE=RelWithDebugInfo \
- -DBUILD_DOC=true \
- -DBUILD_EXAMPLES=false
+ -DSFML_BUILD_DOC=false \ # switch to true if you need offline documentation
+ -DSFML_BUILD_EXAMPLES=false \
+ -DSFML_INSTALL_PKGCONFIG_FILES=true # prints a warning if pkg-config not supported
make
make doc
}