summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShayne Hartford2024-04-01 04:39:38 -0400
committerShayne Hartford2024-04-01 04:39:38 -0400
commit5badf3324cf087f5fd47675a24f4fbc7ffbd57ab (patch)
tree9d220e9c5d4429a53e54dfbf492a73bb4fe16fa6
downloadaur-5badf3324cf087f5fd47675a24f4fbc7ffbd57ab.tar.gz
0.0.54
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD21
3 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..57967efeb9f2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = sfp-ui-bin
+ pkgdesc = This utility is designed to allow you to apply skins to the modern Steam client
+ pkgver = 0.0.54
+ pkgrel = 1
+ url = https://github.com/PhantomGamers/sfp
+ arch = x86_64
+ license = MIT
+ depends = ttf-ms-fonts
+ depends = dotnet-runtime-7.0
+ source = https://github.com/PhantomGamers/sfp/releases/download/0.0.54/SFP_UI-linux-x64-net7.tar.gz
+ sha512sums = 730dbee62bad3015d4462fbeab461d29e9209dc0f07632e5097b8532b6b724bf354cc7cb4316cfb1cedbf958f3c3596f74fd4cd1dbed72ee94d361a21e3a4984
+
+pkgname = sfp-ui-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a0a795a3be6f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Shayne Hartford <shaybox@shaybox.com>
+
+_pkgname=sfp
+pkgname="${_pkgname}-ui-bin"
+pkgver=0.0.54
+pkgrel=1
+pkgdesc="This utility is designed to allow you to apply skins to the modern Steam client"
+arch=("x86_64")
+url="https://github.com/PhantomGamers/${_pkgname}"
+license=('MIT')
+depends=("ttf-ms-fonts" "dotnet-runtime-7.0")
+source=("${url}/releases/download/${pkgver}/SFP_UI-linux-x64-net7.tar.gz")
+sha512sums=("730dbee62bad3015d4462fbeab461d29e9209dc0f07632e5097b8532b6b724bf354cc7cb4316cfb1cedbf958f3c3596f74fd4cd1dbed72ee94d361a21e3a4984")
+
+prepare() {
+ tar -zxvf SFP_UI-linux-x64-net7.tar.gz
+}
+
+package() {
+ install -Dm755 "${srcdir}/SFP_UI" "${pkgdir}/usr/bin/SFP_UI"
+}