summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Murino2021-06-16 18:46:57 +0200
committerNicola Murino2021-06-16 18:46:57 +0200
commit0fa78baf154fe9f7837616214c460c1652b76cf6 (patch)
treeea6fd124ecdd700a4236b2b4d6aab3bbbc2eadb8
parentb11f1f3e3c0a5d9b7f4d1e3bb34e979a28dcbe14 (diff)
downloadaur-0fa78baf154fe9f7837616214c460c1652b76cf6.tar.gz
update to v2.1.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD11
-rw-r--r--sftpgo.json49
3 files changed, 54 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2aba8d650ebe..2b46f71017f5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = sftpgo
pkgdesc = Fully featured and highly configurable SFTP server with optional FTP/S and WebDAV support. It can serve local filesystem, S3, GCS, Azure Blob, SFTP
- pkgver = 2.0.4
+ pkgver = 2.1.0
pkgrel = 1
url = https://github.com/drakkan/sftpgo
install = sftpgo.install
arch = i686
arch = x86_64
- license = GPL3
+ arch = aarch64
+ license = AGPLv3
makedepends = gcc
makedepends = git
makedepends = go
@@ -15,13 +16,13 @@ pkgbase = sftpgo
optdepends = sqlite: to use SQLite provider
optdepends = postgresql: to use PostgreSQL provider
optdepends = mariadb: to use MySQL provider
+ optdepends = cockroachdb: to use CockroachDB provider
backup = etc/sftpgo/sftpgo.json
- source = git+https://github.com/drakkan/sftpgo#tag=v2.0.4
+ source = git+https://github.com/drakkan/sftpgo#tag=v2.1.0
source = sftpgo.json
source = sftpgo.sysusers
sha256sums = SKIP
- sha256sums = 75008457de7bf3e5c6b673a29d79853f75e934d80907c40859ec963bb134a99d
+ sha256sums = 6f1fbbf9d19a10b09bd37f293bcae5a807bfd7bc12552f7b2a5d19eb87afa0dc
sha256sums = 44658210043f805057c2e4b473653637a91204e4da17954b08081292c72edcb8
pkgname = sftpgo
-
diff --git a/PKGBUILD b/PKGBUILD
index 1a3082820a0c..d8225c9e298a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
# Maintainer: drakkan <nicola.murino at gmail dot com>
# Contributor: drakkan <nicola.murino at gmail dot com>
pkgname=sftpgo
-pkgver=2.0.4
+pkgver=2.1.0
pkgrel=1
pkgdesc='Fully featured and highly configurable SFTP server with optional FTP/S and WebDAV support. It can serve local filesystem, S3, GCS, Azure Blob, SFTP'
-arch=('i686' 'x86_64')
+arch=('i686' 'x86_64' 'aarch64')
url="https://github.com/drakkan/${pkgname}"
-license=('GPL3')
+license=('AGPLv3')
depends=('glibc')
makedepends=('gcc' 'git' 'go' 'gzip')
optdepends=(
"sqlite: to use SQLite provider"
"postgresql: to use PostgreSQL provider"
"mariadb: to use MySQL provider"
+ "cockroachdb: to use CockroachDB provider"
)
backup=("etc/${pkgname}/sftpgo.json")
install=${pkgname}.install
@@ -21,7 +22,7 @@ source=("git+https://github.com/drakkan/${pkgname}#tag=v${pkgver}"
"sftpgo.json"
"sftpgo.sysusers")
sha256sums=('SKIP'
- '75008457de7bf3e5c6b673a29d79853f75e934d80907c40859ec963bb134a99d'
+ '6f1fbbf9d19a10b09bd37f293bcae5a807bfd7bc12552f7b2a5d19eb87afa0dc'
'44658210043f805057c2e4b473653637a91204e4da17954b08081292c72edcb8')
_uid_sftpgo=315
@@ -29,7 +30,7 @@ _gid_sftpgo=315
build() {
cd "${pkgname}"
- go build -ldflags "-s -w -X github.com/drakkan/sftpgo/version.commit=`git describe --always --dirty` -X github.com/drakkan/sftpgo/version.date=`date --utc +%FT%TZ`" -o sftpgo
+ go build -trimpath -ldflags "-s -w -X github.com/drakkan/sftpgo/version.commit=`git describe --always --dirty` -X github.com/drakkan/sftpgo/version.date=`date --utc +%FT%TZ`" -o sftpgo
./sftpgo gen completion bash > sftpgo-completion.bash
./sftpgo gen man -d man1
gzip man1/*
diff --git a/sftpgo.json b/sftpgo.json
index 650b4926da22..ddf12c4b1764 100644
--- a/sftpgo.json
+++ b/sftpgo.json
@@ -4,13 +4,17 @@
"upload_mode": 0,
"actions": {
"execute_on": [],
+ "execute_sync": [],
"hook": ""
},
"setstat_mode": 0,
+ "temp_path": "",
"proxy_protocol": 0,
"proxy_allowed": [],
+ "startup_hook": "",
"post_connect_hook": "",
"max_total_connections": 0,
+ "max_per_host_connections": 20,
"defender": {
"enabled": false,
"ban_time": 30,
@@ -18,12 +22,30 @@
"threshold": 15,
"score_invalid": 2,
"score_valid": 1,
+ "score_limit_exceeded": 3,
"observation_time": 30,
"entries_soft_limit": 100,
"entries_hard_limit": 150,
"safelist_file": "",
"blocklist_file": ""
- }
+ },
+ "rate_limiters": [
+ {
+ "average": 0,
+ "period": 1000,
+ "burst": 1,
+ "type": 2,
+ "protocols": [
+ "SSH",
+ "FTP",
+ "DAV",
+ "HTTP"
+ ],
+ "generate_defender_events": false,
+ "entries_soft_limit": 100,
+ "entries_hard_limit": 150
+ }
+ ]
},
"sftpd": {
"bindings": [
@@ -86,7 +108,9 @@
"address": "",
"enable_https": false,
"client_auth_type": 0,
- "tls_cipher_suites": []
+ "tls_cipher_suites": [],
+ "prefix": "",
+ "proxy_allowed": []
}
],
"certificate_file": "",
@@ -124,6 +148,7 @@
"connection_string": "",
"sql_tables_prefix": "",
"track_quota": 2,
+ "delayed_quota_update": 0,
"pool_size": 0,
"users_base_dir": "/srv/sftpgo/data",
"actions": {
@@ -140,29 +165,38 @@
"check_password_hook": "",
"check_password_scope": 0,
"password_hashing": {
+ "bcrypt_options": {
+ "cost": 10
+ },
"argon2_options": {
"memory": 65536,
"iterations": 1,
"parallelism": 2
- }
+ },
+ "algo": "bcrypt"
},
+ "password_caching": true,
"update_mode": 0,
- "skip_natural_keys_validation": false
+ "skip_natural_keys_validation": false,
+ "create_default_admin": false
},
"httpd": {
"bindings": [
{
"port": 8080,
- "address": "127.0.0.1",
+ "address": "",
"enable_web_admin": true,
+ "enable_web_client": true,
"enable_https": false,
"client_auth_type": 0,
- "tls_cipher_suites": []
+ "tls_cipher_suites": [],
+ "proxy_allowed": []
}
],
"templates_path": "/usr/share/sftpgo/templates",
"static_files_path": "/usr/share/sftpgo/static",
"backups_path": "/srv/sftpgo/backups",
+ "web_root": "",
"certificate_file": "",
"certificate_key_file": "",
"ca_certificates": [],
@@ -184,7 +218,8 @@
"retry_max": 3,
"ca_certificates": [],
"certificates": [],
- "skip_tls_verify": false
+ "skip_tls_verify": false,
+ "headers": []
},
"kms": {
"secrets": {