summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Murino2020-07-11 13:02:19 +0200
committerNicola Murino2020-07-11 13:02:19 +0200
commit1550b7c9a442f85c4fddc8f458bfd3276a448ef4 (patch)
tree7d32c75333f97b71530856162a4e0af6f45a12d9
parentec310aebfb8fbe6954890c2e173909d44b3f2199 (diff)
downloadaur-1550b7c9a442f85c4fddc8f458bfd3276a448ef4.tar.gz
use more standard paths
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rw-r--r--sftpgo.json4
3 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8351494ace1a..276560f43366 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sftpgo
pkgdesc = Fully featured and highly configurable SFTP server
pkgver = 1.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/drakkan/sftpgo
install = sftpgo.install
arch = i686
@@ -20,7 +20,7 @@ pkgbase = sftpgo
source = git+https://github.com/drakkan/sftpgo#tag=v1.0.0
source = sftpgo.json
sha256sums = SKIP
- sha256sums = d4bc2ddb3104e2e1be40103e7653f2d7802658576ba8e80bebfad7901a8b46a4
+ sha256sums = fb4dc558c4dcba5e9d9ce9716653439b11d34f468599609cc4b8e79692ef8417
pkgname = sftpgo
diff --git a/PKGBUILD b/PKGBUILD
index cf8f53cc4455..0dee2a2de71c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: drakkan <nicola.murino at gmail dot com>
pkgname=sftpgo
pkgver=1.0.0
-pkgrel=1
+pkgrel=2
pkgdesc='Fully featured and highly configurable SFTP server'
arch=('i686' 'x86_64')
url="https://github.com/drakkan/${pkgname}"
@@ -22,7 +22,7 @@ install=${pkgname}.install
source=("git+https://github.com/drakkan/${pkgname}#tag=v${pkgver}"
"sftpgo.json")
sha256sums=('SKIP'
- 'd4bc2ddb3104e2e1be40103e7653f2d7802658576ba8e80bebfad7901a8b46a4')
+ 'fb4dc558c4dcba5e9d9ce9716653439b11d34f468599609cc4b8e79692ef8417')
build() {
cd "${pkgname}"
@@ -36,9 +36,10 @@ package() {
install -Dm 644 init/${pkgname}.service -t "${pkgdir}/usr/lib/systemd/system"
install -Dm 644 "$srcdir/sftpgo.json" -t "${pkgdir}/etc/${pkgname}"
install -d "${pkgdir}/var/lib/${pkgname}"
- cp -r templates "${pkgdir}/var/lib/${pkgname}/"
- cp -r static "${pkgdir}/var/lib/${pkgname}/"
- install -d "${pkgdir}/usr/share/doc/${pkgname}"
+ install -d "${pkgdir}/usr/share/${pkgname}"
+ cp -r templates "${pkgdir}/usr/share/${pkgname}/"
+ cp -r static "${pkgdir}/usr/share/${pkgname}/"
+ install -Dm 644 "$srcdir/sftpgo.json" "${pkgdir}/usr/share/doc/${pkgname}/sftpgo.json.default"
echo "For documentation please take a look here:" > "${pkgdir}"/usr/share/doc/${pkgname}/README
echo "" >> "${pkgdir}"/usr/share/doc/${pkgname}/README
echo "https://github.com/drakkan/sftpgo/blob/v${pkgver}/README.md" >> "${pkgdir}"/usr/share/doc/${pkgname}/README
diff --git a/sftpgo.json b/sftpgo.json
index 44369fd86074..1b8679cb6f71 100644
--- a/sftpgo.json
+++ b/sftpgo.json
@@ -55,8 +55,8 @@
"httpd": {
"bind_port": 8080,
"bind_address": "127.0.0.1",
- "templates_path": "/var/lib/sftpgo/templates",
- "static_files_path": "/var/lib/sftpgo/static",
+ "templates_path": "/usr/share/sftpgo/templates",
+ "static_files_path": "/usr/share/sftpgo/static",
"backups_path": "/var/lib/sftpgo/backups",
"auth_user_file": "",
"certificate_file": "",