summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Murino2022-04-30 16:59:53 +0200
committerNicola Murino2022-04-30 16:59:53 +0200
commit486b1db6c6f64f940b31e751961539ad59132d3e (patch)
tree5e52b25e6a774ae2293be29cf3ab9797f5a9e670
parentc29c8b7e82718beaabccbe048e1354b7c0d0b8c9 (diff)
downloadaur-486b1db6c6f64f940b31e751961539ad59132d3e.tar.gz
update to v2.2.3
Signed-off-by: Nicola Murino <nicola.murino@gmail.com>
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--sftpgo.install23
-rw-r--r--sftpgo.json4
4 files changed, 19 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c87bbb682f1..c4444a7cc8f1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sftpgo
pkgdesc = Fully featured and highly configurable SFTP server with optional HTTP, FTP/S and WebDAV support. It can serve local filesystem, S3, GCS, Azure Blob, SFTP
- pkgver = 2.2.2
+ pkgver = 2.2.3
pkgrel = 1
url = https://github.com/drakkan/sftpgo
install = sftpgo.install
@@ -12,17 +12,17 @@ pkgbase = sftpgo
makedepends = git
makedepends = go
makedepends = gzip
- depends = glibc
+ depends = libcap
optdepends = sqlite: to use SQLite provider
optdepends = postgresql: to use PostgreSQL provider
optdepends = mariadb: to use MySQL provider
optdepends = cockroachdb: to use CockroachDB provider
backup = etc/sftpgo/sftpgo.json
- source = git+https://github.com/drakkan/sftpgo#tag=v2.2.2
+ source = git+https://github.com/drakkan/sftpgo#tag=v2.2.3
source = sftpgo.json
source = sftpgo.sysusers
sha256sums = SKIP
- sha256sums = 8fed22f6a8d3216e4acb3e53651f216a8dd131b1e86a9ddad6702ea5ba78084a
+ sha256sums = 382b4a705ff2902b4c0bf39265e10d3ee641e151a57382a49ac2b500c63993e6
sha256sums = 44658210043f805057c2e4b473653637a91204e4da17954b08081292c72edcb8
pkgname = sftpgo
diff --git a/PKGBUILD b/PKGBUILD
index c51b92c344ad..9bb59814bc2e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: drakkan <nicola.murino at gmail dot com>
# Contributor: drakkan <nicola.murino at gmail dot com>
pkgname=sftpgo
-pkgver=2.2.2
+pkgver=2.2.3
pkgrel=1
pkgdesc='Fully featured and highly configurable SFTP server with optional HTTP, FTP/S and WebDAV support. It can serve local filesystem, S3, GCS, Azure Blob, SFTP'
arch=('i686' 'x86_64' 'aarch64')
url="https://github.com/drakkan/${pkgname}"
license=('AGPLv3')
-depends=('glibc')
+depends=('libcap')
makedepends=('gcc' 'git' 'go' 'gzip')
optdepends=(
"sqlite: to use SQLite provider"
@@ -22,7 +22,7 @@ source=("git+https://github.com/drakkan/${pkgname}#tag=v${pkgver}"
"sftpgo.json"
"sftpgo.sysusers")
sha256sums=('SKIP'
- '8fed22f6a8d3216e4acb3e53651f216a8dd131b1e86a9ddad6702ea5ba78084a'
+ '382b4a705ff2902b4c0bf39265e10d3ee641e151a57382a49ac2b500c63993e6'
'44658210043f805057c2e4b473653637a91204e4da17954b08081292c72edcb8')
_uid_sftpgo=315
diff --git a/sftpgo.install b/sftpgo.install
index 7b07b717ccbc..f64e1b59280b 100644
--- a/sftpgo.install
+++ b/sftpgo.install
@@ -1,3 +1,11 @@
+post_install() {
+ setcap cap_net_bind_service=+ep /usr/bin/sftpgo
+}
+
+post_upgrade() {
+ setcap cap_net_bind_service=+ep /usr/bin/sftpgo
+}
+
pre_remove() {
systemctl stop sftpgo.service
cat <<EOF
@@ -6,18 +14,3 @@ pre_remove() {
==> group 'sftpgo'
EOF
}
-
-post_upgrade() {
- if (( $(vercmp $2 1.0.0-4) < 0 )); then
- chown -R 315:315 /etc/sftpgo /var/lib/sftpgo
- chmod 750 /etc/sftpgo /var/lib/sftpgo
- chmod 640 /etc/sftpgo/sftpgo.json
- cat <<EOF
-==> After this update SFTPGo will run using the dedicated "sftpgo"
-==> system user, you will probably need to manually fix the
-==> permissions for the SFTPGo virtual users home directory using
-==>
-==> chown -R sftpgo:sftpgo </path/to/sftpgo/home/dir>
-EOF
-fi
-}
diff --git a/sftpgo.json b/sftpgo.json
index 0456b84b4873..f98343d05c2c 100644
--- a/sftpgo.json
+++ b/sftpgo.json
@@ -235,6 +235,10 @@
"exposed_headers": [],
"allow_credentials": false,
"max_age": 0
+ },
+ "setup": {
+ "installation_code": "",
+ "installation_code_hint": "Installation code"
}
},
"telemetry": {