summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Murino2020-03-07 18:00:22 +0100
committerNicola Murino2020-03-07 18:00:22 +0100
commit497bd51925fb396693ffce89779e09e451c0cd86 (patch)
tree1048a87662bd8422c2085849a48ccd13358446b5
parente4108e71a79a82e4dc4047a7b0b6281ccef1d6cb (diff)
downloadaur-497bd51925fb396693ffce89779e09e451c0cd86.tar.gz
update to 0.9.6
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD26
-rw-r--r--README3
-rw-r--r--sftpgo.install6
-rw-r--r--sftpgo.json66
5 files changed, 95 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 92993a5e1c6c..4f025c97c0c8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sftpgo
pkgdesc = Full featured and highly configurable SFTP server
- pkgver = 0.9.5
+ pkgver = 0.9.6
pkgrel = 1
url = https://github.com/drakkan/sftpgo
install = sftpgo.install
@@ -17,8 +17,12 @@ pkgbase = sftpgo
optdepends = python-requests: REST API CLI
optdepends = python-pygments: REST API CLI colors highlight
backup = etc/sftpgo/sftpgo.json
- source = git+https://github.com/drakkan/sftpgo#tag=0.9.5
+ source = git+https://github.com/drakkan/sftpgo#tag=0.9.6
+ source = sftpgo.json
+ source = README
sha256sums = SKIP
+ sha256sums = c1defd385855fc88a780a611b9076f24c61663123480ba14eee5f37f0396df86
+ sha256sums = 444c3e192a9d75be7d7d15bd75f598df8a400e5431855a787cd8dc5a87187309
pkgname = sftpgo
diff --git a/PKGBUILD b/PKGBUILD
index 0563e16218ed..5887fed250b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: drakkan <nicola.murino at gmail dot com>
# Contributor: drakkan <nicola.murino at gmail dot com>
pkgname=sftpgo
-pkgver=0.9.5
+pkgver=0.9.6
pkgrel=1
pkgdesc='Full featured and highly configurable SFTP server'
arch=('i686' 'x86_64')
@@ -19,8 +19,12 @@ optdepends=(
backup=("etc/${pkgname}/sftpgo.json")
install=${pkgname}.install
-source=("git+https://github.com/drakkan/${pkgname}#tag=${pkgver}")
-sha256sums=('SKIP')
+source=("git+https://github.com/drakkan/${pkgname}#tag=${pkgver}"
+ "sftpgo.json"
+ "README")
+sha256sums=('SKIP'
+ 'c1defd385855fc88a780a611b9076f24c61663123480ba14eee5f37f0396df86'
+ '444c3e192a9d75be7d7d15bd75f598df8a400e5431855a787cd8dc5a87187309')
build() {
cd "${pkgname}"
@@ -29,17 +33,17 @@ build() {
package() {
cd "${pkgname}"
- install -Dm755 sftpgo "$pkgdir/usr/bin/${pkgname}"
+ install -Dm 755 sftpgo "$pkgdir/usr/bin/${pkgname}"
+ install -Dm 755 scripts/sftpgo_api_cli.py "${pkgdir}"/usr/bin/sftpgo_api_cli
install -Dm 644 init/${pkgname}.service -t "${pkgdir}/usr/lib/systemd/system"
- install -Dm 644 sftpgo.json -t "${pkgdir}/etc/${pkgname}"
- cp -r templates "${pkgdir}/etc/${pkgname}/"
- cp -r static "${pkgdir}/etc/${pkgname}/"
+ install -Dm 644 "$srcdir/sftpgo.json" -t "${pkgdir}/etc/${pkgname}"
+ install -d "${pkgdir}/var/lib/${pkgname}"
+ cp -r templates "${pkgdir}/var/lib/${pkgname}/"
+ cp -r static "${pkgdir}/var/lib/${pkgname}/"
install -d "${pkgdir}/usr/share/doc/${pkgname}"
cp -r sql "${pkgdir}/usr/share/doc/${pkgname}/"
- install -Dm 644 README.md "${pkgdir}"/usr/share/doc/${pkgname}/README.md
- install -Dm 755 scripts/sftpgo_api_cli.py "${pkgdir}"/usr/share/doc/${pkgname}/scripts/sftpgo_api_cli.py
- install -Dm 644 scripts/README.md "${pkgdir}"/usr/share/doc/${pkgname}/scripts/README.md
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/${pkgname}/LICENSE
+ install -Dm 644 "$srcdir/README" "${pkgdir}"/usr/share/doc/${pkgname}/README
+ install -Dm 644 LICENSE "$pkgdir"/usr/share/licenses/${pkgname}/LICENSE
}
# vim:set ts=2 sw=2 et:
diff --git a/README b/README
new file mode 100644
index 000000000000..168128d0dd63
--- /dev/null
+++ b/README
@@ -0,0 +1,3 @@
+For documentation please take a look here:
+
+https://github.com/drakkan/sftpgo/blob/0.9.6/README.md
diff --git a/sftpgo.install b/sftpgo.install
index 1afd4e1c5214..b9c4e4c290e5 100644
--- a/sftpgo.install
+++ b/sftpgo.install
@@ -2,5 +2,9 @@
post_install() {
echo ":: You need to initialize a data provider prior to starting the service."
- echo " This can be done using the scripts in /usr/share/doc/sftpgo/sql"
+ echo " This can be done using the initprovider command, for example:"
+ echo ""
+ echo " sftpgo initprovider"
+ echo ""
+ echo " take a look at sftpgo initprovider --help for more options"
}
diff --git a/sftpgo.json b/sftpgo.json
new file mode 100644
index 000000000000..b277998ae182
--- /dev/null
+++ b/sftpgo.json
@@ -0,0 +1,66 @@
+{
+ "sftpd": {
+ "bind_port": 2022,
+ "bind_address": "",
+ "idle_timeout": 15,
+ "max_auth_tries": 0,
+ "umask": "0022",
+ "banner": "",
+ "upload_mode": 0,
+ "actions": {
+ "execute_on": [],
+ "command": "",
+ "http_notification_url": ""
+ },
+ "keys": [],
+ "kex_algorithms": [],
+ "ciphers": [],
+ "macs": [],
+ "login_banner_file": "",
+ "setstat_mode": 0,
+ "enabled_ssh_commands": [
+ "md5sum",
+ "sha1sum",
+ "cd",
+ "pwd",
+ "scp"
+ ],
+ "keyboard_interactive_auth_program": "",
+ "proxy_protocol": 0,
+ "proxy_allowed": []
+ },
+ "data_provider": {
+ "driver": "sqlite",
+ "name": "/var/lib/sftpgo/sftpgo.db",
+ "host": "",
+ "port": 5432,
+ "username": "",
+ "password": "",
+ "sslmode": 0,
+ "connection_string": "",
+ "users_table": "users",
+ "manage_users": 1,
+ "track_quota": 2,
+ "pool_size": 0,
+ "users_base_dir": "",
+ "actions": {
+ "execute_on": [],
+ "command": "",
+ "http_notification_url": ""
+ },
+ "external_auth_program": "",
+ "external_auth_scope": 0,
+ "credentials_path": "/var/lib/sftpgo/credentials",
+ "pre_login_program": ""
+ },
+ "httpd": {
+ "bind_port": 8080,
+ "bind_address": "127.0.0.1",
+ "templates_path": "/var/lib/sftpgo/templates",
+ "static_files_path": "/var/lib/sftpgo/static",
+ "backups_path": "/var/lib/sftpgo/backups",
+ "auth_user_file": "",
+ "certificate_file": "",
+ "certificate_key_file": ""
+ }
+}