summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Murino2021-02-06 12:11:19 +0100
committerNicola Murino2021-02-06 12:11:19 +0100
commit6f9a5bbe73e9aff5229da5333b81ccfce8f711d8 (patch)
tree085d01015f4ac11a98a151b683f054ff580769bf
parentc3c39811f18e54d7c47a1748d89b6de655b4e6a2 (diff)
downloadaur-6f9a5bbe73e9aff5229da5333b81ccfce8f711d8.tar.gz
update to v2.0.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD9
-rw-r--r--sftpgo.json88
3 files changed, 81 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 98072fdf7507..6b92f786254a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sftpgo
- pkgdesc = Fully featured and highly configurable SFTP server with optional FTP/S and WebDAV support. It can serve local filesystem, S3, GCS, Azure Blob
- pkgver = 1.2.2
+ pkgdesc = Fully featured and highly configurable SFTP server with optional FTP/S and WebDAV support. It can serve local filesystem, S3, GCS, Azure Blob, SFTP
+ pkgver = 2.0.0
pkgrel = 1
url = https://github.com/drakkan/sftpgo
install = sftpgo.install
@@ -15,14 +15,12 @@ pkgbase = sftpgo
optdepends = sqlite: to use SQLite provider
optdepends = postgresql: to use PostgreSQL provider
optdepends = mariadb: to use MySQL provider
- optdepends = python-requests: REST API CLI
- optdepends = python-pygments: REST API CLI colors highlight
backup = etc/sftpgo/sftpgo.json
- source = git+https://github.com/drakkan/sftpgo#tag=v1.2.2
+ source = git+https://github.com/drakkan/sftpgo#tag=v2.0.0
source = sftpgo.json
source = sftpgo.sysusers
sha256sums = SKIP
- sha256sums = ec2768a7578c3409fe57fb20420474582d09b0726205ddf53d811a5feed4f90a
+ sha256sums = c78069828a88b18f4ba7454a3e91bdf63829ed17b532528805edb8d08ce8e292
sha256sums = 44658210043f805057c2e4b473653637a91204e4da17954b08081292c72edcb8
pkgname = sftpgo
diff --git a/PKGBUILD b/PKGBUILD
index c7b233be5979..35b7d97300c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: drakkan <nicola.murino at gmail dot com>
# Contributor: drakkan <nicola.murino at gmail dot com>
pkgname=sftpgo
-pkgver=1.2.2
+pkgver=2.0.0
pkgrel=1
-pkgdesc='Fully featured and highly configurable SFTP server with optional FTP/S and WebDAV support. It can serve local filesystem, S3, GCS, Azure Blob'
+pkgdesc='Fully featured and highly configurable SFTP server with optional FTP/S and WebDAV support. It can serve local filesystem, S3, GCS, Azure Blob, SFTP'
arch=('i686' 'x86_64')
url="https://github.com/drakkan/${pkgname}"
license=('GPL3')
@@ -13,8 +13,6 @@ optdepends=(
"sqlite: to use SQLite provider"
"postgresql: to use PostgreSQL provider"
"mariadb: to use MySQL provider"
- "python-requests: REST API CLI"
- "python-pygments: REST API CLI colors highlight"
)
backup=("etc/${pkgname}/sftpgo.json")
install=${pkgname}.install
@@ -23,7 +21,7 @@ source=("git+https://github.com/drakkan/${pkgname}#tag=v${pkgver}"
"sftpgo.json"
"sftpgo.sysusers")
sha256sums=('SKIP'
- 'ec2768a7578c3409fe57fb20420474582d09b0726205ddf53d811a5feed4f90a'
+ 'c78069828a88b18f4ba7454a3e91bdf63829ed17b532528805edb8d08ce8e292'
'44658210043f805057c2e4b473653637a91204e4da17954b08081292c72edcb8')
_uid_sftpgo=315
@@ -40,7 +38,6 @@ build() {
package() {
cd "${pkgname}"
install -Dm 755 sftpgo "$pkgdir/usr/bin/${pkgname}"
- install -Dm 755 examples/rest-api-cli/sftpgo_api_cli "${pkgdir}"/usr/bin/sftpgo_api_cli
install -Dm 644 init/${pkgname}.service -t "${pkgdir}/usr/lib/systemd/system"
install -dm750 -o ${_uid_sftpgo} -g ${_gid_sftpgo} "${pkgdir}/etc/${pkgname}"
install -Dm 640 -o ${_uid_sftpgo} -g ${_gid_sftpgo} "$srcdir/sftpgo.json" -t "${pkgdir}/etc/${pkgname}"
diff --git a/sftpgo.json b/sftpgo.json
index c3afc9ecc3cd..ff2802aef3a6 100644
--- a/sftpgo.json
+++ b/sftpgo.json
@@ -9,11 +9,30 @@
"setstat_mode": 0,
"proxy_protocol": 0,
"proxy_allowed": [],
- "post_connect_hook": ""
+ "post_connect_hook": "",
+ "max_total_connections": 0,
+ "defender": {
+ "enabled": false,
+ "ban_time": 30,
+ "ban_time_increment": 50,
+ "threshold": 15,
+ "score_invalid": 2,
+ "score_valid": 1,
+ "observation_time": 30,
+ "entries_soft_limit": 100,
+ "entries_hard_limit": 150,
+ "safelist_file": "",
+ "blocklist_file": ""
+ }
},
"sftpd": {
- "bind_port": 2022,
- "bind_address": "",
+ "bindings": [
+ {
+ "port": 2022,
+ "address": "",
+ "apply_proxy_config": true
+ }
+ ],
"max_auth_tries": 0,
"banner": "",
"host_keys": [],
@@ -33,25 +52,45 @@
"password_authentication": true
},
"ftpd": {
- "bind_port": 0,
- "bind_address": "",
+ "bindings": [
+ {
+ "port": 0,
+ "address": "",
+ "apply_proxy_config": true,
+ "tls_mode": 0,
+ "force_passive_ip": "",
+ "client_auth_type": 0
+ }
+ ],
"banner": "",
"banner_file": "",
- "active_transfers_port_non_20": false,
- "force_passive_ip": "",
+ "active_transfers_port_non_20": true,
"passive_port_range": {
"start": 50000,
"end": 50100
},
+ "disable_active_mode": false,
+ "enable_site": false,
+ "hash_support": 0,
+ "combine_support": 0,
"certificate_file": "",
"certificate_key_file": "",
- "tls_mode": 0
+ "ca_certificates": [],
+ "ca_revocation_lists": []
},
"webdavd": {
- "bind_port": 0,
- "bind_address": "",
+ "bindings": [
+ {
+ "port": 0,
+ "address": "",
+ "enable_https": false,
+ "client_auth_type": 0
+ }
+ ],
"certificate_file": "",
"certificate_key_file": "",
+ "ca_certificates": [],
+ "ca_revocation_lists": [],
"cors": {
"enabled": false,
"allowed_origins": [],
@@ -76,13 +115,12 @@
"driver": "sqlite",
"name": "/var/lib/sftpgo/sftpgo.db",
"host": "",
- "port": 5432,
+ "port": 0,
"username": "",
"password": "",
"sslmode": 0,
"connection_string": "",
"sql_tables_prefix": "",
- "manage_users": 1,
"track_quota": 2,
"pool_size": 0,
"users_base_dir": "/srv/sftpgo/data",
@@ -109,11 +147,27 @@
"update_mode": 0
},
"httpd": {
- "bind_port": 8080,
- "bind_address": "127.0.0.1",
+ "bindings": [
+ {
+ "port": 8080,
+ "address": "127.0.0.1",
+ "enable_web_admin": true,
+ "enable_https": false,
+ "client_auth_type": 0
+ }
+ ],
"templates_path": "/usr/share/sftpgo/templates",
"static_files_path": "/usr/share/sftpgo/static",
"backups_path": "/srv/sftpgo/backups",
+ "certificate_file": "",
+ "certificate_key_file": "",
+ "ca_certificates": [],
+ "ca_revocation_lists": []
+ },
+ "telemetry": {
+ "bind_port": 10000,
+ "bind_address": "127.0.0.1",
+ "enable_profiler": false,
"auth_user_file": "",
"certificate_file": "",
"certificate_key_file": ""
@@ -122,5 +176,11 @@
"timeout": 20,
"ca_certificates": [],
"skip_tls_verify": false
+ },
+ "kms": {
+ "secrets": {
+ "url": "",
+ "master_key_path": ""
+ }
}
}