summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Murino2021-11-27 14:06:12 +0100
committerNicola Murino2021-11-27 14:06:12 +0100
commit904a7d2c14ce9e02234516bc4d8bb4eef6e0c984 (patch)
tree793cc4603ec2a721680079071d8efa33573753c1
parent3583f4bc9dcb1560c68fb554ea78cba56412fad5 (diff)
downloadaur-904a7d2c14ce9e02234516bc4d8bb4eef6e0c984.tar.gz
update to v2.2.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
-rw-r--r--sftpgo.json67
3 files changed, 68 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d26094bef46b..f49936e480aa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sftpgo
pkgdesc = Fully featured and highly configurable SFTP server with optional FTP/S and WebDAV support. It can serve local filesystem, S3, GCS, Azure Blob, SFTP
- pkgver = 2.1.2
+ pkgver = 2.2.0
pkgrel = 1
url = https://github.com/drakkan/sftpgo
install = sftpgo.install
@@ -18,11 +18,11 @@ pkgbase = sftpgo
optdepends = mariadb: to use MySQL provider
optdepends = cockroachdb: to use CockroachDB provider
backup = etc/sftpgo/sftpgo.json
- source = git+https://github.com/drakkan/sftpgo#tag=v2.1.2
+ source = git+https://github.com/drakkan/sftpgo#tag=v2.2.0
source = sftpgo.json
source = sftpgo.sysusers
sha256sums = SKIP
- sha256sums = 6f1fbbf9d19a10b09bd37f293bcae5a807bfd7bc12552f7b2a5d19eb87afa0dc
+ sha256sums = d9188b0c2eb2d7e486318622a955a01f66e63d8c816ad8c3e548d89ae0af193e
sha256sums = 44658210043f805057c2e4b473653637a91204e4da17954b08081292c72edcb8
pkgname = sftpgo
diff --git a/PKGBUILD b/PKGBUILD
index f56580d83250..207301b92620 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: drakkan <nicola.murino at gmail dot com>
# Contributor: drakkan <nicola.murino at gmail dot com>
pkgname=sftpgo
-pkgver=2.1.2
+pkgver=2.2.0
pkgrel=1
pkgdesc='Fully featured and highly configurable SFTP server with optional FTP/S and WebDAV support. It can serve local filesystem, S3, GCS, Azure Blob, SFTP'
arch=('i686' 'x86_64' 'aarch64')
@@ -22,7 +22,7 @@ source=("git+https://github.com/drakkan/${pkgname}#tag=v${pkgver}"
"sftpgo.json"
"sftpgo.sysusers")
sha256sums=('SKIP'
- '6f1fbbf9d19a10b09bd37f293bcae5a807bfd7bc12552f7b2a5d19eb87afa0dc'
+ 'd9188b0c2eb2d7e486318622a955a01f66e63d8c816ad8c3e548d89ae0af193e'
'44658210043f805057c2e4b473653637a91204e4da17954b08081292c72edcb8')
_uid_sftpgo=315
@@ -30,7 +30,7 @@ _gid_sftpgo=315
build() {
cd "${pkgname}"
- go build -trimpath -ldflags "-s -w -X github.com/drakkan/sftpgo/version.commit=`git describe --always --dirty` -X github.com/drakkan/sftpgo/version.date=`date --utc +%FT%TZ`" -o sftpgo
+ go build -trimpath -ldflags "-s -w -X github.com/drakkan/sftpgo/v2/version.commit=`git describe --always --dirty` -X github.com/drakkan/sftpgo/v2/version.date=`date --utc +%FT%TZ`" -o sftpgo
./sftpgo gen completion bash > sftpgo-completion.bash
./sftpgo gen man -d man1
gzip man1/*
@@ -47,6 +47,7 @@ package() {
install -d "${pkgdir}/usr/share/${pkgname}"
cp -r templates "${pkgdir}/usr/share/${pkgname}/"
cp -r static "${pkgdir}/usr/share/${pkgname}/"
+ cp -r openapi "${pkgdir}/usr/share/${pkgname}/"
install -Dm 644 "$srcdir/sftpgo.json" "${pkgdir}/usr/share/doc/${pkgname}/sftpgo.json.default"
echo "For documentation please take a look here:" > "${pkgdir}"/usr/share/doc/${pkgname}/README
echo "" >> "${pkgdir}"/usr/share/doc/${pkgname}/README
diff --git a/sftpgo.json b/sftpgo.json
index ddf12c4b1764..f9b78fc18fac 100644
--- a/sftpgo.json
+++ b/sftpgo.json
@@ -13,6 +13,8 @@
"proxy_allowed": [],
"startup_hook": "",
"post_connect_hook": "",
+ "post_disconnect_hook": "",
+ "data_retention_hook": "",
"max_total_connections": 0,
"max_per_host_connections": 20,
"defender": {
@@ -41,6 +43,7 @@
"DAV",
"HTTP"
],
+ "allow_list": [],
"generate_defender_events": false,
"entries_soft_limit": 100,
"entries_hard_limit": 150
@@ -70,8 +73,10 @@
"pwd",
"scp"
],
+ "keyboard_interactive_authentication": false,
"keyboard_interactive_auth_hook": "",
- "password_authentication": true
+ "password_authentication": true,
+ "folder_prefix": ""
},
"ftpd": {
"bindings": [
@@ -81,8 +86,12 @@
"apply_proxy_config": true,
"tls_mode": 0,
"force_passive_ip": "",
+ "passive_ip_overrides": [],
"client_auth_type": 0,
- "tls_cipher_suites": []
+ "tls_cipher_suites": [],
+ "passive_connections_security": 0,
+ "active_connections_security": 0,
+ "debug": false
}
],
"banner": "",
@@ -153,6 +162,7 @@
"users_base_dir": "/srv/sftpgo/data",
"actions": {
"execute_on": [],
+ "execute_for": [],
"hook": ""
},
"external_auth_hook": "",
@@ -175,10 +185,19 @@
},
"algo": "bcrypt"
},
+ "password_validation": {
+ "admins": {
+ "min_entropy": 0
+ },
+ "users": {
+ "min_entropy": 0
+ }
+ },
"password_caching": true,
"update_mode": 0,
"skip_natural_keys_validation": false,
- "create_default_admin": false
+ "create_default_admin": false,
+ "is_shared": 0
},
"httpd": {
"bindings": [
@@ -190,17 +209,31 @@
"enable_https": false,
"client_auth_type": 0,
"tls_cipher_suites": [],
- "proxy_allowed": []
+ "proxy_allowed": [],
+ "hide_login_url": 0,
+ "render_openapi": true
}
],
"templates_path": "/usr/share/sftpgo/templates",
"static_files_path": "/usr/share/sftpgo/static",
+ "openapi_path": "/usr/share/sftpgo/openapi",
"backups_path": "/srv/sftpgo/backups",
"web_root": "",
"certificate_file": "",
"certificate_key_file": "",
"ca_certificates": [],
- "ca_revocation_lists": []
+ "ca_revocation_lists": [],
+ "signing_passphrase": "",
+ "max_upload_file_size": 1048576000,
+ "cors": {
+ "enabled": false,
+ "allowed_origins": [],
+ "allowed_methods": [],
+ "allowed_headers": [],
+ "exposed_headers": [],
+ "allow_credentials": false,
+ "max_age": 0
+ }
},
"telemetry": {
"bind_port": 10000,
@@ -224,7 +257,29 @@
"kms": {
"secrets": {
"url": "",
+ "master_key": "",
"master_key_path": ""
}
- }
+ },
+ "mfa": {
+ "totp": [
+ {
+ "name": "Default",
+ "issuer": "SFTPGo",
+ "algo": "sha1"
+ }
+ ]
+ },
+ "smtp": {
+ "host": "",
+ "port": 25,
+ "from": "",
+ "user": "",
+ "password": "",
+ "auth_type": 0,
+ "encryption": 0,
+ "domain": "",
+ "templates_path": "/usr/share/sftpgo/templates"
+ },
+ "plugins": []
}