summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Murino2024-05-15 19:38:55 +0200
committerNicola Murino2024-05-15 19:38:55 +0200
commitae34a386f2830a2f5c95042f4b691cd4f6b93a9a (patch)
tree7679954ffad41599358a14e862a3e044f0a2cd34
parent3ad7022afd6707af0b20467d527b1ceb592c4c8b (diff)
downloadaur-ae34a386f2830a2f5c95042f4b691cd4f6b93a9a.tar.gz
2.6.0
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD7
-rw-r--r--sftpgo.json28
3 files changed, 26 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index efd5ae7d2bca..edd2b1168b54 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sftpgo
- pkgdesc = Fully featured and highly configurable SFTP server with optional HTTP, FTP/S and WebDAV support. It can serve local filesystem, S3, GCS, Azure Blob, SFTP
- pkgver = 2.5.6
+ pkgdesc = Full-featured and highly configurable SFTP, HTTP/S, FTP/S and WebDAV server - S3, Google Cloud Storage, Azure Blob
+ pkgver = 2.6.0
pkgrel = 1
url = https://github.com/drakkan/sftpgo
install = sftpgo.install
@@ -13,16 +13,15 @@ pkgbase = sftpgo
makedepends = go
makedepends = gzip
depends = libcap
- optdepends = sqlite: to use SQLite provider
optdepends = postgresql: to use PostgreSQL provider
optdepends = mariadb: to use MySQL provider
optdepends = cockroachdb: to use CockroachDB provider
backup = etc/sftpgo/sftpgo.json
- source = git+https://github.com/drakkan/sftpgo#tag=v2.5.6
+ source = git+https://github.com/drakkan/sftpgo#tag=v2.6.0
source = sftpgo.json
source = sftpgo.sysusers
sha256sums = SKIP
- sha256sums = dd43c42a5b9e321d1ca500b7e8da7985be25152ef1a4de4e54342d115a398a10
+ sha256sums = b22341fd94927f1bc3b229c3633163149be7519b295257778c48a010fc4b0f31
sha256sums = 44658210043f805057c2e4b473653637a91204e4da17954b08081292c72edcb8
pkgname = sftpgo
diff --git a/PKGBUILD b/PKGBUILD
index 80a7552c8179..fb530734488c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,15 @@
# Maintainer: drakkan <nicola.murino at gmail dot com>
# Contributor: drakkan <nicola.murino at gmail dot com>
pkgname=sftpgo
-pkgver=2.5.6
+pkgver=2.6.0
pkgrel=1
-pkgdesc='Fully featured and highly configurable SFTP server with optional HTTP, FTP/S and WebDAV support. It can serve local filesystem, S3, GCS, Azure Blob, SFTP'
+pkgdesc='Full-featured and highly configurable SFTP, HTTP/S, FTP/S and WebDAV server - S3, Google Cloud Storage, Azure Blob'
arch=('i686' 'x86_64' 'aarch64')
url="https://github.com/drakkan/${pkgname}"
license=('AGPLv3')
depends=('libcap')
makedepends=('gcc' 'git' 'go' 'gzip')
optdepends=(
- "sqlite: to use SQLite provider"
"postgresql: to use PostgreSQL provider"
"mariadb: to use MySQL provider"
"cockroachdb: to use CockroachDB provider"
@@ -22,7 +21,7 @@ source=("git+https://github.com/drakkan/${pkgname}#tag=v${pkgver}"
"sftpgo.json"
"sftpgo.sysusers")
sha256sums=('SKIP'
- 'dd43c42a5b9e321d1ca500b7e8da7985be25152ef1a4de4e54342d115a398a10'
+ 'b22341fd94927f1bc3b229c3633163149be7519b295257778c48a010fc4b0f31'
'44658210043f805057c2e4b473653637a91204e4da17954b08081292c72edcb8')
_uid_sftpgo=315
diff --git a/sftpgo.json b/sftpgo.json
index 4e7ead11f7b5..08529b3d4c42 100644
--- a/sftpgo.json
+++ b/sftpgo.json
@@ -9,6 +9,7 @@
},
"setstat_mode": 0,
"rename_mode": 0,
+ "resume_max_size": 0,
"temp_path": "",
"proxy_protocol": 0,
"proxy_allowed": [],
@@ -21,6 +22,11 @@
"max_per_host_connections": 20,
"allowlist_status": 0,
"allow_self_connections": 0,
+ "umask": "",
+ "server_version": "",
+ "metadata": {
+ "read": 0
+ },
"defender": {
"enabled": false,
"driver": "memory",
@@ -78,7 +84,6 @@
}
],
"max_auth_tries": 0,
- "banner": "",
"host_keys": [],
"host_certificates": [],
"host_key_algorithms": [],
@@ -86,6 +91,7 @@
"kex_algorithms": [],
"ciphers": [],
"macs": [],
+ "public_key_algorithms": [],
"trusted_user_ca_keys": [],
"revoked_user_certs_file": "",
"login_banner_file": "",
@@ -109,6 +115,7 @@
"address": "",
"apply_proxy_config": true,
"tls_mode": 0,
+ "tls_session_reuse": 0,
"certificate_file": "",
"certificate_key_file": "",
"min_tls_version": 12,
@@ -119,10 +126,10 @@
"tls_cipher_suites": [],
"passive_connections_security": 0,
"active_connections_security": 0,
+ "ignore_ascii_transfer_type": 0,
"debug": false
}
],
- "banner": "",
"banner_file": "",
"active_transfers_port_non_20": true,
"passive_port_range": {
@@ -149,6 +156,7 @@
"min_tls_version": 12,
"client_auth_type": 0,
"tls_cipher_suites": [],
+ "tls_protocols": [],
"prefix": "",
"proxy_allowed": [],
"client_ip_proxy_header": "",
@@ -261,15 +269,16 @@
"min_tls_version": 12,
"client_auth_type": 0,
"tls_cipher_suites": [],
+ "tls_protocols": [],
"proxy_allowed": [],
"client_ip_proxy_header": "",
"client_ip_header_depth": 0,
"hide_login_url": 0,
"render_openapi": true,
- "web_client_integrations": [],
"oidc": {
"client_id": "",
"client_secret": "",
+ "client_secret_file": "",
"config_url": "",
"redirect_base_url": "",
"scopes": [
@@ -298,8 +307,7 @@
"content_type_nosniff": false,
"content_security_policy": "",
"permissions_policy": "",
- "cross_origin_opener_policy": "",
- "expect_ct_header": ""
+ "cross_origin_opener_policy": ""
},
"branding": {
"web_admin": {
@@ -310,7 +318,7 @@
"login_image_path": "",
"disclaimer_name": "",
"disclaimer_path": "",
- "default_css": "",
+ "default_css": [],
"extra_css": []
},
"web_client": {
@@ -321,7 +329,7 @@
"login_image_path": "",
"disclaimer_name": "",
"disclaimer_path": "",
- "default_css": "",
+ "default_css": [],
"extra_css": []
}
}
@@ -336,6 +344,7 @@
"ca_certificates": [],
"ca_revocation_lists": [],
"signing_passphrase": "",
+ "signing_passphrase_file": "",
"token_validation": 0,
"max_upload_file_size": 0,
"cors": {
@@ -364,7 +373,8 @@
"certificate_file": "",
"certificate_key_file": "",
"min_tls_version": 12,
- "tls_cipher_suites": []
+ "tls_cipher_suites": [],
+ "tls_protocols": []
},
"http": {
"timeout": 20,
@@ -399,7 +409,7 @@
},
"smtp": {
"host": "",
- "port": 25,
+ "port": 587,
"from": "",
"user": "",
"password": "",