summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Murino2020-07-06 23:06:10 +0200
committerNicola Murino2020-07-06 23:06:10 +0200
commitec310aebfb8fbe6954890c2e173909d44b3f2199 (patch)
tree8594e29e0c252051e3544925e9f844654189f322
parent497bd51925fb396693ffce89779e09e451c0cd86 (diff)
downloadaur-ec310aebfb8fbe6954890c2e173909d44b3f2199.tar.gz
update to 1.0.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD21
-rw-r--r--README3
-rw-r--r--sftpgo.json22
4 files changed, 27 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f025c97c0c8..8351494ace1a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sftpgo
- pkgdesc = Full featured and highly configurable SFTP server
- pkgver = 0.9.6
+ pkgdesc = Fully featured and highly configurable SFTP server
+ pkgver = 1.0.0
pkgrel = 1
url = https://github.com/drakkan/sftpgo
install = sftpgo.install
@@ -17,12 +17,10 @@ pkgbase = sftpgo
optdepends = python-requests: REST API CLI
optdepends = python-pygments: REST API CLI colors highlight
backup = etc/sftpgo/sftpgo.json
- source = git+https://github.com/drakkan/sftpgo#tag=0.9.6
+ source = git+https://github.com/drakkan/sftpgo#tag=v1.0.0
source = sftpgo.json
- source = README
sha256sums = SKIP
- sha256sums = c1defd385855fc88a780a611b9076f24c61663123480ba14eee5f37f0396df86
- sha256sums = 444c3e192a9d75be7d7d15bd75f598df8a400e5431855a787cd8dc5a87187309
+ sha256sums = d4bc2ddb3104e2e1be40103e7653f2d7802658576ba8e80bebfad7901a8b46a4
pkgname = sftpgo
diff --git a/PKGBUILD b/PKGBUILD
index 5887fed250b0..cf8f53cc4455 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: drakkan <nicola.murino at gmail dot com>
# Contributor: drakkan <nicola.murino at gmail dot com>
pkgname=sftpgo
-pkgver=0.9.6
+pkgver=1.0.0
pkgrel=1
-pkgdesc='Full featured and highly configurable SFTP server'
+pkgdesc='Fully featured and highly configurable SFTP server'
arch=('i686' 'x86_64')
url="https://github.com/drakkan/${pkgname}"
license=('GPL3')
@@ -19,30 +19,29 @@ optdepends=(
backup=("etc/${pkgname}/sftpgo.json")
install=${pkgname}.install
-source=("git+https://github.com/drakkan/${pkgname}#tag=${pkgver}"
- "sftpgo.json"
- "README")
+source=("git+https://github.com/drakkan/${pkgname}#tag=v${pkgver}"
+ "sftpgo.json")
sha256sums=('SKIP'
- 'c1defd385855fc88a780a611b9076f24c61663123480ba14eee5f37f0396df86'
- '444c3e192a9d75be7d7d15bd75f598df8a400e5431855a787cd8dc5a87187309')
+ 'd4bc2ddb3104e2e1be40103e7653f2d7802658576ba8e80bebfad7901a8b46a4')
build() {
cd "${pkgname}"
- go build -i -ldflags "-s -w -X github.com/drakkan/sftpgo/utils.commit=`git describe --always --dirty` -X github.com/drakkan/sftpgo/utils.date=`date --utc +%FT%TZ`" -o sftpgo
+ go build -i -ldflags "-s -w -X github.com/drakkan/sftpgo/version.commit=`git describe --always --dirty` -X github.com/drakkan/sftpgo/version.date=`date --utc +%FT%TZ`" -o sftpgo
}
package() {
cd "${pkgname}"
install -Dm 755 sftpgo "$pkgdir/usr/bin/${pkgname}"
- install -Dm 755 scripts/sftpgo_api_cli.py "${pkgdir}"/usr/bin/sftpgo_api_cli
+ install -Dm 755 examples/rest-api-cli/sftpgo_api_cli.py "${pkgdir}"/usr/bin/sftpgo_api_cli
install -Dm 644 init/${pkgname}.service -t "${pkgdir}/usr/lib/systemd/system"
install -Dm 644 "$srcdir/sftpgo.json" -t "${pkgdir}/etc/${pkgname}"
install -d "${pkgdir}/var/lib/${pkgname}"
cp -r templates "${pkgdir}/var/lib/${pkgname}/"
cp -r static "${pkgdir}/var/lib/${pkgname}/"
install -d "${pkgdir}/usr/share/doc/${pkgname}"
- cp -r sql "${pkgdir}/usr/share/doc/${pkgname}/"
- install -Dm 644 "$srcdir/README" "${pkgdir}"/usr/share/doc/${pkgname}/README
+ echo "For documentation please take a look here:" > "${pkgdir}"/usr/share/doc/${pkgname}/README
+ echo "" >> "${pkgdir}"/usr/share/doc/${pkgname}/README
+ echo "https://github.com/drakkan/sftpgo/blob/v${pkgver}/README.md" >> "${pkgdir}"/usr/share/doc/${pkgname}/README
install -Dm 644 LICENSE "$pkgdir"/usr/share/licenses/${pkgname}/LICENSE
}
diff --git a/README b/README
deleted file mode 100644
index 168128d0dd63..000000000000
--- a/README
+++ /dev/null
@@ -1,3 +0,0 @@
-For documentation please take a look here:
-
-https://github.com/drakkan/sftpgo/blob/0.9.6/README.md
diff --git a/sftpgo.json b/sftpgo.json
index b277998ae182..44369fd86074 100644
--- a/sftpgo.json
+++ b/sftpgo.json
@@ -9,13 +9,13 @@
"upload_mode": 0,
"actions": {
"execute_on": [],
- "command": "",
- "http_notification_url": ""
+ "hook": ""
},
- "keys": [],
+ "host_keys": [],
"kex_algorithms": [],
"ciphers": [],
"macs": [],
+ "trusted_user_ca_keys": [],
"login_banner_file": "",
"setstat_mode": 0,
"enabled_ssh_commands": [
@@ -25,7 +25,7 @@
"pwd",
"scp"
],
- "keyboard_interactive_auth_program": "",
+ "keyboard_interactive_auth_hook": "",
"proxy_protocol": 0,
"proxy_allowed": []
},
@@ -38,20 +38,19 @@
"password": "",
"sslmode": 0,
"connection_string": "",
- "users_table": "users",
+ "sql_tables_prefix": "",
"manage_users": 1,
"track_quota": 2,
"pool_size": 0,
"users_base_dir": "",
"actions": {
"execute_on": [],
- "command": "",
- "http_notification_url": ""
+ "hook": ""
},
- "external_auth_program": "",
+ "external_auth_hook": "",
"external_auth_scope": 0,
"credentials_path": "/var/lib/sftpgo/credentials",
- "pre_login_program": ""
+ "pre_login_hook": ""
},
"httpd": {
"bind_port": 8080,
@@ -62,5 +61,10 @@
"auth_user_file": "",
"certificate_file": "",
"certificate_key_file": ""
+ },
+ "http": {
+ "timeout": 20,
+ "ca_certificates": [],
+ "skip_tls_verify": false
}
}