summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Murino2021-11-27 15:00:41 +0100
committerNicola Murino2021-11-27 15:00:41 +0100
commit06e149d0809f1567f1e0a3eb21d5a8c45401a656 (patch)
tree4a5c2c42248481e902599e4cbf857a6c1787d37f
parentbc6a9725b4600745576625f8fb78d6796e3945e8 (diff)
downloadaur-06e149d0809f1567f1e0a3eb21d5a8c45401a656.tar.gz
fix sqlite db perms
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ae9429e80e86..e25423098862 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sftpgo-bin
- pkgdesc = Fully featured and highly configurable SFTP server with optional FTP/S and WebDAV support. It can serve local filesystem, S3, GCS, Azure Blob, SFTP
+ pkgdesc = Fully featured and highly configurable SFTP server with optional HTTP, FTP/S and WebDAV support. It can serve local filesystem, S3, GCS, Azure Blob, SFTP
pkgver = 2.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/drakkan/sftpgo
install = sftpgo-bin.install
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index ee7b568e7436..0a5293603d61 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
pkgname=sftpgo-bin
_pkgname=sftpgo
pkgver=2.2.0
-pkgrel=1
-pkgdesc='Fully featured and highly configurable SFTP server with optional FTP/S and WebDAV support. It can serve local filesystem, S3, GCS, Azure Blob, SFTP'
+pkgrel=2
+pkgdesc='Fully featured and highly configurable SFTP server with optional HTTP, FTP/S and WebDAV support. It can serve local filesystem, S3, GCS, Azure Blob, SFTP'
arch=('x86_64')
url="https://github.com/drakkan/${_pkgname}"
license=('AGPLv3')
@@ -39,7 +39,7 @@ package() {
install -dm750 -o ${_uid_sftpgo} -g ${_gid_sftpgo} "${pkgdir}/etc/${_pkgname}"
install -Dm 640 -o ${_uid_sftpgo} -g ${_gid_sftpgo} "$srcdir/sftpgo.json" -t "${pkgdir}/etc/${_pkgname}"
install -dm750 -o ${_uid_sftpgo} -g ${_gid_sftpgo} "${pkgdir}/var/lib/${_pkgname}"
- install -Dm 600 sqlite/sftpgo.db -t "${pkgdir}/var/lib/${_pkgname}"
+ install -Dm 600 -o ${_uid_sftpgo} -g ${_gid_sftpgo} sqlite/sftpgo.db -t "${pkgdir}/var/lib/${_pkgname}"
install -dm750 -o ${_uid_sftpgo} -g ${_gid_sftpgo} "${pkgdir}/srv/${_pkgname}"
install -d "${pkgdir}/usr/share/${_pkgname}"
cp -r templates "${pkgdir}/usr/share/${_pkgname}/"