summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Murino2021-06-16 18:51:55 +0200
committerNicola Murino2021-06-16 18:51:55 +0200
commit29be9408f01569014c87110b274ae98bffd49fee (patch)
tree23eb71a9925c81621f994a491948d5d54102747c
parent1129f5b3dfabc5c35c6de41d130cade05ab57f7d (diff)
downloadaur-29be9408f01569014c87110b274ae98bffd49fee.tar.gz
update to v2.1.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD9
-rw-r--r--sftpgo.json49
3 files changed, 53 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6fb95e028ad8..47c20a901e3f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,25 @@
pkgbase = sftpgo-bin
pkgdesc = Fully featured and highly configurable SFTP server with optional FTP/S and WebDAV support. It can serve local filesystem, S3, GCS, Azure Blob, SFTP
- pkgver = 2.0.4
+ pkgver = 2.1.0
pkgrel = 1
url = https://github.com/drakkan/sftpgo
install = sftpgo-bin.install
arch = x86_64
- license = GPL3
+ license = AGPLv3
depends = glibc
optdepends = sqlite: to use SQLite provider
optdepends = postgresql: to use PostgreSQL provider
optdepends = mariadb: to use MySQL provider
+ optdepends = cockroachdb: to use CockroachDB provider
provides = sftpgo
conflicts = sftpgo
backup = etc/sftpgo/sftpgo.json
backup = var/lib/sftpgo/sftpgo.db
- source = https://github.com/drakkan/sftpgo/releases/download/v2.0.4/sftpgo_v2.0.4_linux_x86_64.tar.xz
+ source = https://github.com/drakkan/sftpgo/releases/download/v2.1.0/sftpgo_v2.1.0_linux_x86_64.tar.xz
source = sftpgo.json
source = sftpgo.sysusers
- sha256sums = 7b84661987412b5f296dc194cc07c69b8cec31cd240059c1e7cb25956ea1bb30
- sha256sums = 75008457de7bf3e5c6b673a29d79853f75e934d80907c40859ec963bb134a99d
+ sha256sums = c083c4cc40b482c8c6fe79536d81f219b5bd630c6cd8b590cb16f8a36372d192
+ sha256sums = 6f1fbbf9d19a10b09bd37f293bcae5a807bfd7bc12552f7b2a5d19eb87afa0dc
sha256sums = 44658210043f805057c2e4b473653637a91204e4da17954b08081292c72edcb8
pkgname = sftpgo-bin
-
diff --git a/PKGBUILD b/PKGBUILD
index 051c9c0b326b..0ec6dac42815 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,18 @@
# Contributor: drakkan <nicola.murino at gmail dot com>
pkgname=sftpgo-bin
_pkgname=sftpgo
-pkgver=2.0.4
+pkgver=2.1.0
pkgrel=1
pkgdesc='Fully featured and highly configurable SFTP server with optional FTP/S and WebDAV support. It can serve local filesystem, S3, GCS, Azure Blob, SFTP'
arch=('x86_64')
url="https://github.com/drakkan/${_pkgname}"
-license=('GPL3')
+license=('AGPLv3')
depends=('glibc')
optdepends=(
"sqlite: to use SQLite provider"
"postgresql: to use PostgreSQL provider"
"mariadb: to use MySQL provider"
+ "cockroachdb: to use CockroachDB provider"
)
conflicts=('sftpgo')
provides=('sftpgo')
@@ -25,8 +26,8 @@ install=${pkgname}.install
source=("https://github.com/drakkan/sftpgo/releases/download/v${pkgver}/sftpgo_v${pkgver}_linux_x86_64.tar.xz"
"sftpgo.json"
"sftpgo.sysusers")
-sha256sums=('7b84661987412b5f296dc194cc07c69b8cec31cd240059c1e7cb25956ea1bb30'
- '75008457de7bf3e5c6b673a29d79853f75e934d80907c40859ec963bb134a99d'
+sha256sums=('c083c4cc40b482c8c6fe79536d81f219b5bd630c6cd8b590cb16f8a36372d192'
+ '6f1fbbf9d19a10b09bd37f293bcae5a807bfd7bc12552f7b2a5d19eb87afa0dc'
'44658210043f805057c2e4b473653637a91204e4da17954b08081292c72edcb8')
_uid_sftpgo=315
diff --git a/sftpgo.json b/sftpgo.json
index 650b4926da22..ddf12c4b1764 100644
--- a/sftpgo.json
+++ b/sftpgo.json
@@ -4,13 +4,17 @@
"upload_mode": 0,
"actions": {
"execute_on": [],
+ "execute_sync": [],
"hook": ""
},
"setstat_mode": 0,
+ "temp_path": "",
"proxy_protocol": 0,
"proxy_allowed": [],
+ "startup_hook": "",
"post_connect_hook": "",
"max_total_connections": 0,
+ "max_per_host_connections": 20,
"defender": {
"enabled": false,
"ban_time": 30,
@@ -18,12 +22,30 @@
"threshold": 15,
"score_invalid": 2,
"score_valid": 1,
+ "score_limit_exceeded": 3,
"observation_time": 30,
"entries_soft_limit": 100,
"entries_hard_limit": 150,
"safelist_file": "",
"blocklist_file": ""
- }
+ },
+ "rate_limiters": [
+ {
+ "average": 0,
+ "period": 1000,
+ "burst": 1,
+ "type": 2,
+ "protocols": [
+ "SSH",
+ "FTP",
+ "DAV",
+ "HTTP"
+ ],
+ "generate_defender_events": false,
+ "entries_soft_limit": 100,
+ "entries_hard_limit": 150
+ }
+ ]
},
"sftpd": {
"bindings": [
@@ -86,7 +108,9 @@
"address": "",
"enable_https": false,
"client_auth_type": 0,
- "tls_cipher_suites": []
+ "tls_cipher_suites": [],
+ "prefix": "",
+ "proxy_allowed": []
}
],
"certificate_file": "",
@@ -124,6 +148,7 @@
"connection_string": "",
"sql_tables_prefix": "",
"track_quota": 2,
+ "delayed_quota_update": 0,
"pool_size": 0,
"users_base_dir": "/srv/sftpgo/data",
"actions": {
@@ -140,29 +165,38 @@
"check_password_hook": "",
"check_password_scope": 0,
"password_hashing": {
+ "bcrypt_options": {
+ "cost": 10
+ },
"argon2_options": {
"memory": 65536,
"iterations": 1,
"parallelism": 2
- }
+ },
+ "algo": "bcrypt"
},
+ "password_caching": true,
"update_mode": 0,
- "skip_natural_keys_validation": false
+ "skip_natural_keys_validation": false,
+ "create_default_admin": false
},
"httpd": {
"bindings": [
{
"port": 8080,
- "address": "127.0.0.1",
+ "address": "",
"enable_web_admin": true,
+ "enable_web_client": true,
"enable_https": false,
"client_auth_type": 0,
- "tls_cipher_suites": []
+ "tls_cipher_suites": [],
+ "proxy_allowed": []
}
],
"templates_path": "/usr/share/sftpgo/templates",
"static_files_path": "/usr/share/sftpgo/static",
"backups_path": "/srv/sftpgo/backups",
+ "web_root": "",
"certificate_file": "",
"certificate_key_file": "",
"ca_certificates": [],
@@ -184,7 +218,8 @@
"retry_max": 3,
"ca_certificates": [],
"certificates": [],
- "skip_tls_verify": false
+ "skip_tls_verify": false,
+ "headers": []
},
"kms": {
"secrets": {