summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Murino2020-03-07 18:06:03 +0100
committerNicola Murino2020-03-07 18:06:03 +0100
commit4cb41a504f3014894e50ca892411602695f8fd7b (patch)
tree451327a6b5e1f00aeac378167d5c9e9378ce7dc5
parent758e302d33a3964f1ead8f212e2c8c740647a8a2 (diff)
downloadaur-4cb41a504f3014894e50ca892411602695f8fd7b.tar.gz
update to 0.9.6
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD28
-rw-r--r--sftpgo.json66
3 files changed, 87 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9089d1d9ecb3..cbccab9f8f90 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sftpgo-bin
pkgdesc = Full featured and highly configurable SFTP server
- pkgver = 0.9.5
+ pkgver = 0.9.6
pkgrel = 1
url = https://github.com/drakkan/sftpgo
arch = x86_64
@@ -14,9 +14,11 @@ pkgbase = sftpgo-bin
provides = sftpgo
conflicts = sftpgo
backup = etc/sftpgo/sftpgo.json
- backup = etc/sftpgo/sftpgo.db
- source = https://github.com/drakkan/sftpgo/releases/download/0.9.5/sftpgo_0.9.5_linux_x86_64.tar.xz
- sha256sums = d57cfc24cfff6a8b782f49e3b60db6837b4c61bf0ddd54181f1f4edfeda3a924
+ backup = var/lib/sftpgo/sftpgo.db
+ source = https://github.com/drakkan/sftpgo/releases/download/0.9.6/sftpgo_0.9.6_linux_x86_64.tar.xz
+ source = sftpgo.json
+ sha256sums = 128d03ab82abb279eb6b4781411dc68feed149fbc5a218f31acab010dd6ce4e3
+ sha256sums = c1defd385855fc88a780a611b9076f24c61663123480ba14eee5f37f0396df86
pkgname = sftpgo-bin
diff --git a/PKGBUILD b/PKGBUILD
index 5a1f61fa0518..1d734fd77aa0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: drakkan <nicola.murino at gmail dot com>
pkgname=sftpgo-bin
_pkgname=sftpgo
-pkgver=0.9.5
+pkgver=0.9.6
pkgrel=1
pkgdesc='Full featured and highly configurable SFTP server'
arch=('x86_64')
@@ -20,25 +20,27 @@ conflicts=('sftpgo')
provides=('sftpgo')
backup=(
"etc/${_pkgname}/sftpgo.json"
- "etc/${_pkgname}/sftpgo.db"
+ "var/lib/${_pkgname}/sftpgo.db"
)
-source=("https://github.com/drakkan/sftpgo/releases/download/${pkgver}/sftpgo_${pkgver}_linux_x86_64.tar.xz")
-sha256sums=('d57cfc24cfff6a8b782f49e3b60db6837b4c61bf0ddd54181f1f4edfeda3a924')
+source=("https://github.com/drakkan/sftpgo/releases/download/${pkgver}/sftpgo_${pkgver}_linux_x86_64.tar.xz"
+ "sftpgo.json")
+sha256sums=('128d03ab82abb279eb6b4781411dc68feed149fbc5a218f31acab010dd6ce4e3'
+ 'c1defd385855fc88a780a611b9076f24c61663123480ba14eee5f37f0396df86')
package() {
- install -Dm755 sftpgo "$pkgdir/usr/bin/${_pkgname}"
+ install -Dm 755 sftpgo "$pkgdir/usr/bin/${_pkgname}"
+ install -Dm 755 scripts/sftpgo_api_cli.py "${pkgdir}"/usr/bin/sftpgo_api_cli
install -Dm 644 init/${_pkgname}.service -t "${pkgdir}/usr/lib/systemd/system"
- install -Dm 644 sftpgo.json -t "${pkgdir}/etc/${_pkgname}"
- install -Dm 644 sql/sqlite/sftpgo.db -t "${pkgdir}/etc/${_pkgname}"
- cp -r templates "${pkgdir}/etc/${_pkgname}/"
- cp -r static "${pkgdir}/etc/${_pkgname}/"
+ install -Dm 644 "$srcdir/sftpgo.json" -t "${pkgdir}/etc/${_pkgname}"
+ install -d "${pkgdir}/var/lib/${_pkgname}"
+ install -Dm 644 sql/sqlite/sftpgo.db -t "${pkgdir}/var/lib/${_pkgname}"
+ cp -r templates "${pkgdir}/var/lib/${_pkgname}/"
+ cp -r static "${pkgdir}/var/lib/${_pkgname}/"
install -d "${pkgdir}/usr/share/doc/${_pkgname}"
cp -r sql "${pkgdir}/usr/share/doc/${_pkgname}/"
- install -Dm 644 README.pdf "${pkgdir}"/usr/share/doc/${_pkgname}/README.pdf
- install -Dm 755 scripts/sftpgo_api_cli.py "${pkgdir}"/usr/share/doc/${_pkgname}/scripts/sftpgo_api_cli.py
- install -Dm 644 scripts/README.pdf "${pkgdir}"/usr/share/doc/${_pkgname}/scripts/README.pdf
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/${_pkgname}/LICENSE
+ install -Dm 644 README.txt "${pkgdir}"/usr/share/doc/${_pkgname}/README
+ install -Dm 644 LICENSE "$pkgdir"/usr/share/licenses/${_pkgname}/LICENSE
}
# vim:set ts=2 sw=2 et:
diff --git a/sftpgo.json b/sftpgo.json
new file mode 100644
index 000000000000..b277998ae182
--- /dev/null
+++ b/sftpgo.json
@@ -0,0 +1,66 @@
+{
+ "sftpd": {
+ "bind_port": 2022,
+ "bind_address": "",
+ "idle_timeout": 15,
+ "max_auth_tries": 0,
+ "umask": "0022",
+ "banner": "",
+ "upload_mode": 0,
+ "actions": {
+ "execute_on": [],
+ "command": "",
+ "http_notification_url": ""
+ },
+ "keys": [],
+ "kex_algorithms": [],
+ "ciphers": [],
+ "macs": [],
+ "login_banner_file": "",
+ "setstat_mode": 0,
+ "enabled_ssh_commands": [
+ "md5sum",
+ "sha1sum",
+ "cd",
+ "pwd",
+ "scp"
+ ],
+ "keyboard_interactive_auth_program": "",
+ "proxy_protocol": 0,
+ "proxy_allowed": []
+ },
+ "data_provider": {
+ "driver": "sqlite",
+ "name": "/var/lib/sftpgo/sftpgo.db",
+ "host": "",
+ "port": 5432,
+ "username": "",
+ "password": "",
+ "sslmode": 0,
+ "connection_string": "",
+ "users_table": "users",
+ "manage_users": 1,
+ "track_quota": 2,
+ "pool_size": 0,
+ "users_base_dir": "",
+ "actions": {
+ "execute_on": [],
+ "command": "",
+ "http_notification_url": ""
+ },
+ "external_auth_program": "",
+ "external_auth_scope": 0,
+ "credentials_path": "/var/lib/sftpgo/credentials",
+ "pre_login_program": ""
+ },
+ "httpd": {
+ "bind_port": 8080,
+ "bind_address": "127.0.0.1",
+ "templates_path": "/var/lib/sftpgo/templates",
+ "static_files_path": "/var/lib/sftpgo/static",
+ "backups_path": "/var/lib/sftpgo/backups",
+ "auth_user_file": "",
+ "certificate_file": "",
+ "certificate_key_file": ""
+ }
+}