summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Murino2023-05-03 18:19:10 +0200
committerNicola Murino2023-05-03 18:19:10 +0200
commit76f9b7cd5d9af623c981a908c306e9bf4ef08408 (patch)
treef18953b3bae9807b9e1372103757d989a800d729
parent110925bb22877450d5a39ed9ab9b6857a6c18a0f (diff)
downloadaur-76f9b7cd5d9af623c981a908c306e9bf4ef08408.tar.gz
2.5.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--sftpgo.json23
3 files changed, 18 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e9c9abeb5edd..03277659214c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sftpgo-bin
pkgdesc = Fully featured and highly configurable SFTP server with optional HTTP, FTP/S and WebDAV support. It can serve local filesystem, S3, GCS, Azure Blob, SFTP
- pkgver = 2.4.5
+ pkgver = 2.5.0
pkgrel = 1
url = https://github.com/drakkan/sftpgo
install = sftpgo-bin.install
@@ -15,11 +15,11 @@ pkgbase = sftpgo-bin
conflicts = sftpgo
backup = etc/sftpgo/sftpgo.json
backup = var/lib/sftpgo/sftpgo.db
- source = https://github.com/drakkan/sftpgo/releases/download/v2.4.5/sftpgo_v2.4.5_linux_x86_64.tar.xz
+ source = https://github.com/drakkan/sftpgo/releases/download/v2.5.0/sftpgo_v2.5.0_linux_x86_64.tar.xz
source = sftpgo.json
source = sftpgo.sysusers
- sha256sums = 75522a92a5efeaad709d8da22fb9672039f711e03919102e1cdc21e3bdf9d5fa
- sha256sums = 0a6cbaa0a7c460858810cf23a465acdf109efa2c499584b16ffa548adf5d346c
+ sha256sums = d46e40287b0a7c419b9b15863494895c9c08bd7e86410354d13894213f9f6872
+ sha256sums = 01b67418c2f8382ee664b7409122d987d6a193f7d235d441c50cdb6924c6fc2f
sha256sums = 44658210043f805057c2e4b473653637a91204e4da17954b08081292c72edcb8
pkgname = sftpgo-bin
diff --git a/PKGBUILD b/PKGBUILD
index c95b21bdc930..18632538d29e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: drakkan <nicola.murino at gmail dot com>
pkgname=sftpgo-bin
_pkgname=sftpgo
-pkgver=2.4.5
+pkgver=2.5.0
pkgrel=1
pkgdesc='Fully featured and highly configurable SFTP server with optional HTTP, FTP/S and WebDAV support. It can serve local filesystem, S3, GCS, Azure Blob, SFTP'
arch=('x86_64')
@@ -26,8 +26,8 @@ install=${pkgname}.install
source=("https://github.com/drakkan/sftpgo/releases/download/v${pkgver}/sftpgo_v${pkgver}_linux_x86_64.tar.xz"
"sftpgo.json"
"sftpgo.sysusers")
-sha256sums=('75522a92a5efeaad709d8da22fb9672039f711e03919102e1cdc21e3bdf9d5fa'
- '0a6cbaa0a7c460858810cf23a465acdf109efa2c499584b16ffa548adf5d346c'
+sha256sums=('d46e40287b0a7c419b9b15863494895c9c08bd7e86410354d13894213f9f6872'
+ '01b67418c2f8382ee664b7409122d987d6a193f7d235d441c50cdb6924c6fc2f'
'44658210043f805057c2e4b473653637a91204e4da17954b08081292c72edcb8')
_uid_sftpgo=315
diff --git a/sftpgo.json b/sftpgo.json
index 0a690636e876..4699e638b2ac 100644
--- a/sftpgo.json
+++ b/sftpgo.json
@@ -8,16 +8,18 @@
"hook": ""
},
"setstat_mode": 0,
+ "rename_mode": 0,
"temp_path": "",
"proxy_protocol": 0,
"proxy_allowed": [],
+ "proxy_skipped": [],
"startup_hook": "",
"post_connect_hook": "",
"post_disconnect_hook": "",
"data_retention_hook": "",
"max_total_connections": 0,
"max_per_host_connections": 20,
- "whitelist_file": "",
+ "allowlist_status": 0,
"allow_self_connections": 0,
"defender": {
"enabled": false,
@@ -28,14 +30,10 @@
"score_invalid": 2,
"score_valid": 1,
"score_limit_exceeded": 3,
- "score_no_auth": 2,
+ "score_no_auth": 0,
"observation_time": 30,
"entries_soft_limit": 100,
- "entries_hard_limit": 150,
- "safelist_file": "",
- "blocklist_file": "",
- "safelist": [],
- "blocklist": []
+ "entries_hard_limit": 150
},
"rate_limiters": [
{
@@ -49,7 +47,6 @@
"DAV",
"HTTP"
],
- "allow_list": [],
"generate_defender_events": false,
"entries_soft_limit": 100,
"entries_hard_limit": 150
@@ -100,7 +97,7 @@
"pwd",
"scp"
],
- "keyboard_interactive_authentication": false,
+ "keyboard_interactive_authentication": true,
"keyboard_interactive_auth_hook": "",
"password_authentication": true,
"folder_prefix": ""
@@ -117,6 +114,7 @@
"min_tls_version": 12,
"force_passive_ip": "",
"passive_ip_overrides": [],
+ "passive_host": "",
"client_auth_type": 0,
"tls_cipher_suites": [],
"passive_connections_security": 0,
@@ -181,7 +179,8 @@
},
"mime_types": {
"enabled": true,
- "max_size": 1000
+ "max_size": 1000,
+ "custom_mappings": []
}
}
},
@@ -238,7 +237,7 @@
"password_caching": true,
"update_mode": 0,
"create_default_admin": false,
- "naming_rules": 1,
+ "naming_rules": 5,
"is_shared": 0,
"node": {
"host": "",
@@ -338,7 +337,7 @@
"ca_revocation_lists": [],
"signing_passphrase": "",
"token_validation": 0,
- "max_upload_file_size": 1048576000,
+ "max_upload_file_size": 0,
"cors": {
"enabled": false,
"allowed_origins": [],