aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Murino2022-09-26 16:04:02 +0200
committerNicola Murino2022-09-26 16:04:02 +0200
commit6c160de272d63216947d6d4c409fc19c5fcb9523 (patch)
tree9fcb4947af6bd66e3be6c9cbb6de1a8b780983ee
parent967022d48c3456dfde3e91128d86bc4341b8de62 (diff)
downloadaur-6c160de272d63216947d6d4c409fc19c5fcb9523.tar.gz
update config file for upstream changes
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--sftpgo.json7
3 files changed, 12 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b68e9688765c..ddd8bb4bf3a6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sftpgo-git
pkgdesc = Fully featured and highly configurable SFTP server with optional HTTP, FTP/S and WebDAV support. It can serve local filesystem, S3, GCS, Azure Blob, SFTP
- pkgver = r1262.9ddd2d35
+ pkgver = r1298.ddda0b5e
pkgrel = 1
url = https://github.com/drakkan/sftpgo
install = sftpgo-git.install
@@ -24,7 +24,7 @@ pkgbase = sftpgo-git
source = sftpgo.json
source = sftpgo.sysusers
sha256sums = SKIP
- sha256sums = 8b6549b20bb7d9dc6130cac342e7b326c930cc84245da84576516a252c51ddae
+ sha256sums = ba3a1c80cbb6b0c1f96f7284a4ccf7d259d49b46e7aa2d7890e266673c7bff2c
sha256sums = 44658210043f805057c2e4b473653637a91204e4da17954b08081292c72edcb8
pkgname = sftpgo-git
diff --git a/PKGBUILD b/PKGBUILD
index 0ace72b2676d..48b6cc48f60e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: drakkan <nicola.murino at gmail dot com>
pkgname=sftpgo-git
_pkgname=sftpgo
-pkgver=r1262.9ddd2d35
+pkgver=r1298.ddda0b5e
pkgrel=1
pkgdesc='Fully featured and highly configurable SFTP server with optional HTTP, FTP/S and WebDAV support. It can serve local filesystem, S3, GCS, Azure Blob, SFTP'
arch=('i686' 'x86_64' 'aarch64')
@@ -25,7 +25,7 @@ source=("git+https://github.com/drakkan/${_pkgname}.git"
"sftpgo.json"
"sftpgo.sysusers")
sha256sums=('SKIP'
- '8b6549b20bb7d9dc6130cac342e7b326c930cc84245da84576516a252c51ddae'
+ 'ba3a1c80cbb6b0c1f96f7284a4ccf7d259d49b46e7aa2d7890e266673c7bff2c'
'44658210043f805057c2e4b473653637a91204e4da17954b08081292c72edcb8')
_uid_sftpgo=315
@@ -38,7 +38,7 @@ pkgver() {
build() {
cd "${_pkgname}"
- go build -trimpath -ldflags "-s -w -X github.com/drakkan/sftpgo/v2/internal/version.commit=`git describe --always --dirty` -X github.com/drakkan/sftpgo/v2/internal/version.date=`date --utc +%FT%TZ`" -o sftpgo
+ go build -trimpath -ldflags "-s -w -X github.com/drakkan/sftpgo/v2/internal/version.commit=`git describe --always --abbrev=8 --dirty` -X github.com/drakkan/sftpgo/v2/internal/version.date=`date --utc +%FT%TZ`" -o sftpgo
./sftpgo gen completion bash > sftpgo-completion.bash
./sftpgo gen man -d man1
gzip man1/*
diff --git a/sftpgo.json b/sftpgo.json
index b5972e2cf9a4..6a2876aa475d 100644
--- a/sftpgo.json
+++ b/sftpgo.json
@@ -190,6 +190,7 @@
"username": "",
"password": "",
"sslmode": 0,
+ "disable_sni": false,
"root_cert": "",
"client_cert": "",
"client_key": "",
@@ -235,6 +236,11 @@
"create_default_admin": false,
"naming_rules": 1,
"is_shared": 0,
+ "node": {
+ "host": "",
+ "port": 0,
+ "proto": "http"
+ },
"backups_path": "/srv/sftpgo/backups"
},
"httpd": {
@@ -244,6 +250,7 @@
"address": "",
"enable_web_admin": true,
"enable_web_client": true,
+ "enable_rest_api": true,
"enabled_login_methods": 0,
"enable_https": false,
"certificate_file": "",