aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Murino2022-02-25 16:13:15 +0100
committerNicola Murino2022-02-25 16:13:15 +0100
commitba9ad3039639071f5ced0436bdafe7b07cdcf5a5 (patch)
treec70b1c1474839f81d4947b130953045a531330b6
parente98f6765e8f079c758e7c5f1e7363ffc2c53851a (diff)
downloadaur-ba9ad3039639071f5ced0436bdafe7b07cdcf5a5.tar.gz
update deps
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--sftpgo-git.install4
3 files changed, 6 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eba5bb90ab86..30e5aca9f711 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,7 +12,7 @@ pkgbase = sftpgo-git
makedepends = git
makedepends = go
makedepends = gzip
- depends = glibc
+ depends = libcap
optdepends = sqlite: to use SQLite provider
optdepends = postgresql: to use PostgreSQL provider
optdepends = mariadb: to use MySQL provider
diff --git a/PKGBUILD b/PKGBUILD
index 4d11d34f05d7..da2bdcf1d8f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgdesc='Fully featured and highly configurable SFTP server with optional HTTP,
arch=('i686' 'x86_64' 'aarch64')
url="https://github.com/drakkan/${_pkgname}"
license=('AGPLv3')
-depends=('glibc')
+depends=('libcap')
makedepends=('gcc' 'git' 'go' 'gzip')
optdepends=(
"sqlite: to use SQLite provider"
diff --git a/sftpgo-git.install b/sftpgo-git.install
index b00559580cf9..f64e1b59280b 100644
--- a/sftpgo-git.install
+++ b/sftpgo-git.install
@@ -2,6 +2,10 @@ post_install() {
setcap cap_net_bind_service=+ep /usr/bin/sftpgo
}
+post_upgrade() {
+ setcap cap_net_bind_service=+ep /usr/bin/sftpgo
+}
+
pre_remove() {
systemctl stop sftpgo.service
cat <<EOF