aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Murino2022-07-24 20:55:02 +0200
committerNicola Murino2022-07-24 20:55:02 +0200
commite75edb6d27f7b6be7f0c9075d4f1ebe68642f948 (patch)
treeb021a0f81905e01faa9c0855ed6cd49ebe31444c
parentdc77c90ce5c31df80e0d49b8a23593002400fca2 (diff)
downloadaur-e75edb6d27f7b6be7f0c9075d4f1ebe68642f948.tar.gz
update config for upstream changes
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--sftpgo.json20
3 files changed, 16 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 886fe0034a3f..8d23f5ba972d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sftpgo-git
pkgdesc = Fully featured and highly configurable SFTP server with optional HTTP, FTP/S and WebDAV support. It can serve local filesystem, S3, GCS, Azure Blob, SFTP
- pkgver = r1203.6f4475ff
+ pkgver = r1238.81de7d27
pkgrel = 1
url = https://github.com/drakkan/sftpgo
install = sftpgo-git.install
@@ -24,7 +24,7 @@ pkgbase = sftpgo-git
source = sftpgo.json
source = sftpgo.sysusers
sha256sums = SKIP
- sha256sums = 066669009af5b1cc8fad93ce9a3d9738e8dcc6bcf9dbbcd9ae085c45c18610aa
+ sha256sums = 8ad9ccda22c7ca46b4c8c38733af907eefa1acc6294251a81d901496778e09a4
sha256sums = 44658210043f805057c2e4b473653637a91204e4da17954b08081292c72edcb8
pkgname = sftpgo-git
diff --git a/PKGBUILD b/PKGBUILD
index 8d3da7ebd701..08e67cf37e25 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: drakkan <nicola.murino at gmail dot com>
pkgname=sftpgo-git
_pkgname=sftpgo
-pkgver=r1203.6f4475ff
+pkgver=r1238.81de7d27
pkgrel=1
pkgdesc='Fully featured and highly configurable SFTP server with optional HTTP, FTP/S and WebDAV support. It can serve local filesystem, S3, GCS, Azure Blob, SFTP'
arch=('i686' 'x86_64' 'aarch64')
@@ -25,7 +25,7 @@ source=("git+https://github.com/drakkan/${_pkgname}.git"
"sftpgo.json"
"sftpgo.sysusers")
sha256sums=('SKIP'
- '066669009af5b1cc8fad93ce9a3d9738e8dcc6bcf9dbbcd9ae085c45c18610aa'
+ '8ad9ccda22c7ca46b4c8c38733af907eefa1acc6294251a81d901496778e09a4'
'44658210043f805057c2e4b473653637a91204e4da17954b08081292c72edcb8')
_uid_sftpgo=315
@@ -38,7 +38,7 @@ pkgver() {
build() {
cd "${_pkgname}"
- go build -trimpath -ldflags "-s -w -X github.com/drakkan/sftpgo/v2/version.commit=`git describe --always --dirty` -X github.com/drakkan/sftpgo/v2/version.date=`date --utc +%FT%TZ`" -o sftpgo
+ go build -trimpath -ldflags "-s -w -X github.com/drakkan/sftpgo/v2/internal/version.commit=`git describe --always --dirty` -X github.com/drakkan/sftpgo/v2/internal/version.date=`date --utc +%FT%TZ`" -o sftpgo
./sftpgo gen completion bash > sftpgo-completion.bash
./sftpgo gen man -d man1
gzip man1/*
diff --git a/sftpgo.json b/sftpgo.json
index b88610da78b1..8e044523317f 100644
--- a/sftpgo.json
+++ b/sftpgo.json
@@ -202,7 +202,6 @@
},
"external_auth_hook": "",
"external_auth_scope": 0,
- "credentials_path": "/var/lib/sftpgo/credentials",
"pre_login_hook": "",
"post_login_hook": "",
"post_login_scope": 0,
@@ -232,12 +231,7 @@
"create_default_admin": false,
"naming_rules": 1,
"is_shared": 0,
- "backups_path": "/srv/sftpgo/backups",
- "auto_backup": {
- "enabled": true,
- "hour": "0",
- "day_of_week": "*"
- }
+ "backups_path": "/srv/sftpgo/backups"
},
"httpd": {
"bindings": [
@@ -246,6 +240,7 @@
"address": "",
"enable_web_admin": true,
"enable_web_client": true,
+ "enabled_login_methods": 0,
"enable_https": false,
"certificate_file": "",
"certificate_key_file": "",
@@ -263,10 +258,16 @@
"client_secret": "",
"config_url": "",
"redirect_base_url": "",
+ "scopes": [
+ "openid",
+ "profile",
+ "email"
+ ],
"username_field": "",
"role_field": "",
"implicit_roles": false,
- "custom_fields": []
+ "custom_fields": [],
+ "debug": false
},
"security": {
"enabled": false,
@@ -334,7 +335,8 @@
"setup": {
"installation_code": "",
"installation_code_hint": "Installation code"
- }
+ },
+ "hide_support_link": false
},
"telemetry": {
"bind_port": 0,