summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLev Babiev2023-04-05 18:26:10 +0100
committerLev Babiev2023-04-05 18:26:10 +0100
commitd6934dbd232481cb6fbbc3b2d15fc0a505c46ec4 (patch)
treefc81adc482d78ce72237682b1b01572acef8a47e
downloadaur-d6934dbd232481cb6fbbc3b2d15fc0a505c46ec4.tar.gz
initial version
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD44
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1da3b4ef16c2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = sfwbar-git
+ pkgdesc = S* Floating Window taskBar, git version
+ pkgver = r942.de920df
+ pkgrel = 1
+ url = https://github.com/LBCrion/sfwbar
+ arch = x86_64
+ arch = aarch64
+ license = GPL3
+ makedepends = meson
+ depends = wayland
+ depends = gtk3
+ depends = json-c
+ depends = gtk-layer-shell
+ depends = wayland-protocols
+ optdepends = libpulse: pulse audio volume control,
+ optdepends = libmpdclient: music player daemon control,
+ optdepends = libxkbcommon: xkb layout conversion support
+ source = sfwbar::git+https://github.com/LBCrion/sfwbar.git
+ md5sums = SKIP
+ sha512sums = SKIP
+
+pkgname = sfwbar-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f9f1bcddc00
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+pkgname=sfwbar-git
+_pkgname=sfwbar
+pkgver=r942.de920df
+pkgrel=1
+
+pkgdesc='S* Floating Window taskBar, git version'
+arch=('x86_64' 'aarch64')
+url='https://github.com/LBCrion/sfwbar'
+license=('GPL3')
+depends=(
+ 'wayland'
+ 'gtk3'
+ 'json-c'
+ 'gtk-layer-shell'
+ 'wayland-protocols'
+ )
+optdepends=(
+ 'libpulse: pulse audio volume control',
+ 'libmpdclient: music player daemon control',
+ 'libxkbcommon: xkb layout conversion support'
+ )
+makedepends=('meson')
+
+source=("${pkgname%-*}::git+https://github.com/LBCrion/sfwbar.git")
+md5sums=('SKIP')
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_pkgname"
+ meson --prefix=/usr \
+ --buildtype=plain \
+ build
+ ninja -C build
+}
+
+package() {
+ cd "$_pkgname"
+ DESTDIR="$pkgdir" ninja -C build install
+}