summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-10-05 12:08:59 +1300
committercaltlgin2020-10-05 12:08:59 +1300
commit28e83199fdb41dbcc3f3728ea892d0b6aa7ca9f8 (patch)
tree3ee4fe11ab82c3c1a6c9e2bcbce10eaff7c2ae01
downloadaur-28e83199fdb41dbcc3f3728ea892d0b6aa7ca9f8.tar.gz
Add to AUR
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD49
2 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d303aa5d1d0d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = sfxr-qt-git
+ pkgdesc = Qt port of SFXR, a sound effect generator, to generate retro-gaming like sound effects
+ pkgver = 1.3.0.r4.g052ca2b
+ pkgrel = 1
+ url = https://github.com/agateau/sfxr-qt
+ arch = x86_64
+ license = MIT
+ makedepends = cmake
+ makedepends = git
+ depends = hicolor-icon-theme
+ depends = python-jinja
+ depends = python-pyaml
+ depends = qt5-declarative
+ depends = sdl
+ provides = sfxr-qt
+ conflicts = sfxr-qt
+ source = git+https://github.com/agateau/sfxr-qt.git
+ source = git+https://github.com/catchorg/Catch2.git
+ source = git+https://github.com/agateau/qpropgen.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = sfxr-qt-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be37d430448d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+
+_pkgname='sfxr-qt'
+pkgname="${_pkgname}-git"
+pkgver=1.3.0.r4.g052ca2b
+pkgrel=1
+pkgdesc='Qt port of SFXR, a sound effect generator, to generate retro-gaming like sound effects'
+arch=('x86_64')
+url='https://github.com/agateau/sfxr-qt'
+license=('MIT')
+depends=('hicolor-icon-theme' 'python-jinja' 'python-pyaml' 'qt5-declarative' 'sdl')
+makedepends=('cmake' 'git')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("git+${url}.git"
+ "git+https://github.com/catchorg/Catch2.git"
+ "git+${url%/*}/qpropgen.git")
+sha256sums=('SKIP' 'SKIP' 'SKIP')
+
+prepare() {
+ cd "${_pkgname}"
+ # Submodule list: https://github.com/agateau/nanonote/raw/master/.gitmodules
+ git submodule init
+ git config submodule.3rdparty/catch2.url "${srcdir}/Catch2"
+ git config submodule.qpropgen.url "${srcdir}/qpropgen"
+ git submodule update
+}
+
+pkgver() {
+ git -C "${_pkgname}" describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ export CFLAGS+=" ${CPPFLAGS}"
+ export CXXFLAGS+=" ${CPPFLAGS}"
+ cmake -B build -S "${_pkgname}" \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -Wno-dev
+ make -C build
+}
+
+package() {
+ make DESTDIR="${pkgdir}" PREFIX="/usr" -C build install
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" "${_pkgname}/README.md"
+ install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" "${_pkgname}/LICENSE"
+}
+
+# vim: ts=2 sw=2 et: